• Welcome to the new Mac-Forums. See News and Community Announcements for more details.

iMac 2010

Joined
Aug 5, 2011
Messages
123
Reaction score
0
Points
16
My iMac from middel 2010 will not allow
a update from high sierra to a mojav or higher
the i Mac works fine has 16gb ram and sd hard disk
is fast enough for me.
Is there anyway to update this iMac?
 

Raz0rEdge

Well-known member
Staff member
Moderator
Joined
Jul 17, 2009
Messages
12,659
Reaction score
302
Points
83
Location
MA
Your Mac's Specs
2018 Mac-Mini macOS Catalina 10.15.5, 32 GB
Correct, the requirements for Mojave is a 2012 or newer iMac. Your machine can go up to High Sierra but no further. Your are now 2 versions behind (as is my 2009 iMac) and in another release or two, you'll find that applications will begin to want Mojave as the minimum OS and you might have to upgrade to a newer Mac.
 
Joined
Aug 5, 2011
Messages
123
Reaction score
0
Points
16
Thanks Ashwin
I know its quite old now nearly ten years
i dont use it very much as i use my macbook
air for daily things bank email etc.
And nearly all my internet is on my iPad.
But i might buy a newer macbook pro used.
 
Top