I need help!

Joined
Oct 31, 2011
Messages
4
Reaction score
0
Points
1
I have an iMac that I got for christmas several years ago and it has OS X 10.4. It's a "Tiger". Obviously nothing new that I want to load on it is compatible with this version. How can I update my OS to a new version that is compatible. I also have an AirPort that says it is compatible with OS X 10.5 or later. I would like to hook that up as well. Can anyone help me out?
 

RavingMac

Well-known member
Staff member
Moderator
Joined
Jan 7, 2008
Messages
8,304
Reaction score
244
Points
63
Location
In Denial
Your Mac's Specs
16Gb Mac Mini 2018, 15" MacBook Pro 2012 1 TB SSD
First need to verify which CPU you have. If it is an Intel iMac then Snow Leopard will work just fine. If its a G5 then Leopard is the latest OS you can run.
 
Joined
Nov 29, 2010
Messages
2,516
Reaction score
137
Points
63
Location
Warrington, UK
Your Mac's Specs
PPC Mini, 10.4.11. Intel Mini, 10.6.8. MacBook Pro, 10.14.6. M1 MBA 11.6.3 iPhone 5 iOS 12.5,
Plus you will need a minimum of 1Gig of RAM for Snow Loepard.
 

cwa107


Retired Staff
Joined
Dec 20, 2006
Messages
27,042
Reaction score
812
Points
113
Location
Lake Mary, Florida
Your Mac's Specs
14" MacBook Pro M1 Pro, 16GB RAM, 1TB SSD
Click the Apple menu in the upper-left corner and then click 'About this Mac', that should give us an idea of what you're running.
 

Shop Amazon


Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.
Top