I have had enough, ATV3 Audio goes quiet for 1sec . . . Then . . .

Joined
May 19, 2009
Messages
8,428
Reaction score
295
Points
83
Location
Waiting for a mate . . .
Your Mac's Specs
21" iMac 2.9Ghz 16GB RAM - 10.11.3, iPhone6s & iPad Air 2 - iOS 9.2.1, ATV 4Th Gen tvOS, ATV3
Ok, the long of the short of it, is anything over 720p will play on my ATV3, but 7 minutes in, the Audio will go silent for 1 second, then will continue playing, then every 1 minute after that, it will stop for a second and keep playing.

The Audio and video are always in sync, and the buffering is fine, as the progress bar is full. This will happen with ANY file that is HD. iTunes content, other Videos of mine, in my iTunes.
If I click pause for a second then play, the video will play for 7 minutes then audio will go silent for 1sec and around and around we go.
What I have been doing, is every time is goes silent, I have had to pause the video, and then play it again, so I get another 7 minutes of uninterrupted playing.

I suppose the reason I am bringing it up now, is Netflix has finally launched into Australia, and I started to Stream a TV Show via Airplay, and again, 7 minutes in, the audio went quiet for 1 second, and continued, and every 1 minute after that. It really is becoming annoying.

I have full bars on my ATV3 for the WiFi signal. I have 20MBps Download Speeds, and the TimeCapsule is only 8 metres away from the ATV. . . . I have searched online, I have restarted everything, I have reinstalled ATV iOS, I have tried EVERYTHING I know, but I still get this little 1 second Audio silence.

Say I have a 40min TV show, and if it is 320mb in size, everything works well. If it is 650mb or 1.23gb it will give me a Audio silence ??? Arrrgghhhhhh

HELP !!!! Please !!!!
 
OP
TattooedMac
Joined
May 19, 2009
Messages
8,428
Reaction score
295
Points
83
Location
Waiting for a mate . . .
Your Mac's Specs
21" iMac 2.9Ghz 16GB RAM - 10.11.3, iPhone6s & iPad Air 2 - iOS 9.2.1, ATV 4Th Gen tvOS, ATV3
PS: If I rent a Movie through AppleTV, I don't have any issues, it is just the streaming from a Device or Mac.
 
C

chas_m

Guest
From your description it sounds like you have something on your Wi-Fi network that is dragging the speed down. Try creating a separate 5GHz network for ONLY devices that can handle that speed (and a universal a/b/g/n network for all the other stuff) and see if that does the trick.
 
OP
TattooedMac
Joined
May 19, 2009
Messages
8,428
Reaction score
295
Points
83
Location
Waiting for a mate . . .
Your Mac's Specs
21" iMac 2.9Ghz 16GB RAM - 10.11.3, iPhone6s & iPad Air 2 - iOS 9.2.1, ATV 4Th Gen tvOS, ATV3
Thanks Chas. I already have a dedicated 5GHz network from my TimeCapsule that has my iMac (iTunes Library), my ATV3 & 2, my MBP and iPad Air 2.
As I stated above, when streaming from my iMac, the progress bar fills up, (and is buffered fully on the ATV), but I still get the Audio Issue.
I just changed my 30 day preview to SD for Netflix, thinking I could overcome this, but again, after 7 minutes, then 30 seconds, 25 seconds, and 20 seconds it arose. It stayed at 25 seconds after that . . . .

Im doing some testing now, to see what happens if I leave the video running, without pausing it, to see if it gets better as it plays.
 

RavingMac

Well-known member
Staff member
Moderator
Joined
Jan 7, 2008
Messages
8,304
Reaction score
244
Points
63
Location
In Denial
Your Mac's Specs
16Gb Mac Mini 2018, 15" MacBook Pro 2012 1 TB SSD
Out of curiosity, are you subscribing directly to Netflix or going through ATV and iTunes for it? Don't think it has anything to do with it, but have thought about giving Netflix a go myself.
 
OP
TattooedMac
Joined
May 19, 2009
Messages
8,428
Reaction score
295
Points
83
Location
Waiting for a mate . . .
Your Mac's Specs
21" iMac 2.9Ghz 16GB RAM - 10.11.3, iPhone6s & iPad Air 2 - iOS 9.2.1, ATV 4Th Gen tvOS, ATV3
Netflix just came to Aust 2 days ago, and I'm streaming through the iPad App. Its not only that, but anything that is HD on my iTunes Library. TV Shows, Movies I have Bought, in HD from iTunes, my Own Movies, if they are in HD.
As above, a 40 min TV Show 600+mb will have this Audio issue, but the same show, @300mb doesn't do it. Its all buffered to my ATV. . .
 

bobtomay

,
Retired Staff
Joined
Dec 22, 2006
Messages
26,561
Reaction score
677
Points
113
Location
Texas, where else?
Your Mac's Specs
15" MBP '06 2.33 C2D 4GB 10.7; 13" MBA '14 1.8 i7 8GB 10.11; 21" iMac '13 2.9 i5 8GB 10.11; 6S
That just seems strange - I stream here and use Airplay - a lot... almost all HD, from HBO, MaxGo, VUDU & other UV sources, Amazon, iTunes, Netflix, (other which we shall not go into)... my own files - most of which are around 4 GB and incl'g some at 20 + GB.

My only difference in your setup would likely be that my ATV is plugged into ethernet. But, I still am streaming (via wifi) to a Mac (several) or an iPhone and then Airplay back to the ATV.

Based on what you've already done, I'd be po'd and hadn't posted because I don't really have any ideas.
I'd say try another user account on your Mac, but, if it's happening from your iPad, that seems pretty worthless.
Think I might be taking it back to the store and getting another ATV.
If it's out of warranty and at the price they are now, I'd likely buy another one to try.
And I don't know how conveniently located you are to an Apple store there.


edit:
Only thinking out loud here:
The more I think about it, the more your description sounds like an issue at the audio playback device rather than an ATV issue. I've seen audio receivers in particular, but TVs also, display strange things like this.
How and what is your ATV connected to - where is the audio coming from.
A surround receiver or the TV speakers?
If connected to a HDMI switching receiver, have you tried it direct to the TV or vice versa?
Tried a different HDMI port - I'd try it even though a different port on the same device will likely be of no help since it'd still be the same circuitry being used for the audio.
If you don't have another device to connect via HDMI, do you have a device that you could try connecting via optical rather than HDMI to rule out the ATV?

edit 2:
You're not connected direct to a Samdung TV are you?
 
Last edited:
OP
TattooedMac
Joined
May 19, 2009
Messages
8,428
Reaction score
295
Points
83
Location
Waiting for a mate . . .
Your Mac's Specs
21" iMac 2.9Ghz 16GB RAM - 10.11.3, iPhone6s & iPad Air 2 - iOS 9.2.1, ATV 4Th Gen tvOS, ATV3
edit 2:

You're not connected direct to a Samdung TV are you?



No, its to a LG 47" (119CM) FULL HD 3D LED LCD TV 47LM6700 . . .



You have me thinking now, and I will try some cable moving around. I have the ATV connected via HDMI to the HDMI Port on the TV, then have Audio going to my LG Sound Bar, via HDMI from the HDMI (ARC) port.



I will now try and switch out the HDMI cables, (and pretty sure that won't change anything) and then I will try ATV w/out the SoundBar connected, and see what happen.



Thanks Tom . .
 
Last edited:
OP
TattooedMac
Joined
May 19, 2009
Messages
8,428
Reaction score
295
Points
83
Location
Waiting for a mate . . .
Your Mac's Specs
21" iMac 2.9Ghz 16GB RAM - 10.11.3, iPhone6s & iPad Air 2 - iOS 9.2.1, ATV 4Th Gen tvOS, ATV3
EDIT: This is why i love these forums. Something like my problem, and all it needed was a fresh set of eyes.

The long of the short of it, is it is now working as it should be. The Optical Digital Cable, was connected to the TV, and on closer look, it was hook into the out port.
I tried the ATV in a different TV, and it worked, without a SoundBar, so it got me thinking it had to be between the ATV, TV and SoundBar, and changing the HDMI's didnt help.
I did have a Optical Audio Toslink cable, so I connected that to the ATV and directly to the SoundBar, and switched the SoundBar to Optical, and now it works, w/out any 1 sec quiet audio.

Thanks to all for idea's and help. As I said, it only needed a fresh set of eyes.
So the issue seems to be the connection between the TV and SoundBar via HDMI. It was all sync'd correctly apart from that 1 sec of quiet audio. Im now going to go ahead and stay with NetFlix (even though STAN is a Australian company, for now, the App and shows aren't worth the $ Movies are older movies) and because its already on the US ATV as a App, im sure Apple will add it to the Australian version too.

Thanks again all, I can finally start downloading the HD shows and movies I have bought


iPad Air 2 using Mac Forums App
 

Rod


Joined
Jun 12, 2011
Messages
9,823
Reaction score
1,990
Points
113
Location
Melbourne, Australia and Ubud, Bali, Indonesia
Your Mac's Specs
2021 M1 MacBook Pro 14" macOS 14.5 Mid 2010MacBook 13" iPhone 13 Pro max, iPad 6, Apple Watch SE.
I used to have similar problems with 720p and 1080p but I use HandBrake to format all my content using preset settings for ATV 2. There are also presets for ATV 3. But I still had problems until I deleted my account (Forget this account) on the ATV and created a new account (with the same information) I could have sworn that the http settings changed although I can't be sure of that. Since then it has worked perfectly.
 
OP
TattooedMac
Joined
May 19, 2009
Messages
8,428
Reaction score
295
Points
83
Location
Waiting for a mate . . .
Your Mac's Specs
21" iMac 2.9Ghz 16GB RAM - 10.11.3, iPhone6s & iPad Air 2 - iOS 9.2.1, ATV 4Th Gen tvOS, ATV3
Well it seems that Apple has Preempted the coming of Netflix to Aust, as i just signed in to it, on my ATV . . . .Glad i can now stream in HD though :)



iPad Air 2 using Mac Forums App
 

bobtomay

,
Retired Staff
Joined
Dec 22, 2006
Messages
26,561
Reaction score
677
Points
113
Location
Texas, where else?
Your Mac's Specs
15" MBP '06 2.33 C2D 4GB 10.7; 13" MBA '14 1.8 i7 8GB 10.11; 21" iMac '13 2.9 i5 8GB 10.11; 6S
Glad that got you sorted - sounds like an issue with the circuitry that pulls the audio from the HDMI port and then re-routes the output.
 

Shop Amazon


Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.
Top