How to disable spellcheck system-wide in Leopard?

Joined
Jan 18, 2006
Messages
1,868
Reaction score
106
Points
63
Your Mac's Specs
G4 Cube
It's bugging me...it only seems to turn it off per-application, is there a way to disable it permanently system-wide?
 

dtravis7


Retired Staff
Joined
Jan 4, 2005
Messages
30,133
Reaction score
703
Points
113
Location
Modesto, Ca.
Your Mac's Specs
MacMini M-1 MacOS Monterey, iMac 2010 27"Quad I7 , MBPLate2011, iPad Pro10.5", iPhoneSE
Learn to spell? ;)

I tried to rep you but it won't let me so virtual REP to you tech. Funny. :D

Kadio, from all I can find the only way to turn it off is as you said, per application unless someone else can find something I missed. Here is a quote from the Help system.


To turn on automatic spelling and optional grammar check:

■ Open the application that you want to use and choose Edit > Spelling and Grammar > “Check Spelling as You Type.”

■ To also check grammar with spelling, choose Edit > Spelling and Grammar > Check Grammar With Spelling.

If you don’t see this item in the Edit menu, the application doesn’t provide the Mac OS X spell-checking feature. The application may have its own spell checker. Look in the application’s preferences or menus for a spell checker.
 
Joined
Nov 17, 2007
Messages
267
Reaction score
8
Points
18
Location
Greenville, SC
Your Mac's Specs
MacBook Pro 15" Matte 2.33 GHz Intel Core 2 Duo 2 GB 667 MHz DDR2 SDRAM
Just out of curiosity, why do you want spellcheck disabled?

Do you not like spelling things correctly?
 
Joined
Feb 2, 2004
Messages
12,455
Reaction score
603
Points
113
Location
PA
Your Mac's Specs
MacBook
i dont knead know stinkin speel cheker
 
OP
K
Joined
Jan 18, 2006
Messages
1,868
Reaction score
106
Points
63
Your Mac's Specs
G4 Cube
Just out of curiosity, why do you want spellcheck disabled?

Do you not like spelling things correctly?

I type a lot of technical terms that aren't in the dictionary and it's annoying to have to continually add them, plus the constant red underlining makes it difficult to read on my high-rez screen.
 
Joined
Nov 29, 2006
Messages
9
Reaction score
1
Points
3
http://dryfish.livejournal.com/8148.html

The method at the above link works and is easy if you're command line savvy. A few apps may complain repeatedly, such as Aperture, but if you disable their individual spell-checking preference (usually under a "Spelling' sub-menu item) they will quiet down.

Here's part of the thread:

"Disabling spell checking in MacOS X Tiger

sudo mv /System/Library/Services/AppleSpell.service \
/System/Library/Services/AppleSpell.service.disabled

For some reason nobody in the whole internet wants to disable the spell checker. The bloody red dashed underline really annoys me and it's always on the things I say which aren't supposed to be real words and I know that they're not so what's the point of telling me they're not real words!?

Anyway, I did the mv and it's stopped so I could potentially be happy."
 

Shop Amazon


Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.
Top