Have to sign in now?

Joined
Apr 3, 2009
Messages
258
Reaction score
0
Points
16
Location
Utah
Your Mac's Specs
Imac 27"12.2.1 Monterey.1phone 13, iwatch,ipad air
Before I upgraded to Yosemite, each time I sat at my imac, it was 'open'.
Now every time I have to 'sign in'. I have changed every setting I can think of and its still there, takes quite awhile to wake up also.


I would appreciate any help.
 

bobtomay

,
Retired Staff
Joined
Dec 22, 2006
Messages
26,561
Reaction score
677
Points
113
Location
Texas, where else?
Your Mac's Specs
15" MBP '06 2.33 C2D 4GB 10.7; 13" MBA '14 1.8 i7 8GB 10.11; 21" iMac '13 2.9 i5 8GB 10.11; 6S
Saying you looked everywhere you can think of doesn't help us much unless you enjoy getting suggestions of where you've already looked.

Did you look in System Preferences - Users & Groups - Login Options - and select your account in the Automatic Login?
 
OP
royalpei
Joined
Apr 3, 2009
Messages
258
Reaction score
0
Points
16
Location
Utah
Your Mac's Specs
Imac 27"12.2.1 Monterey.1phone 13, iwatch,ipad air
Sorry- yes, I have.
 

chscag

Well-known member
Staff member
Admin
Joined
Jan 23, 2008
Messages
65,249
Reaction score
1,829
Points
113
Location
Keller, Texas
Your Mac's Specs
2017 27" iMac, 10.5" iPad Pro, iPhone 8, iPhone 11, iPhone 12 Mini, Numerous iPods, Monterey
Are you using FileVault? If you are, automatic sign on is overridden by the system. With FileVault, you must sign on.
 
OP
royalpei
Joined
Apr 3, 2009
Messages
258
Reaction score
0
Points
16
Location
Utah
Your Mac's Specs
Imac 27"12.2.1 Monterey.1phone 13, iwatch,ipad air
No, not using File vault.
 

chscag

Well-known member
Staff member
Admin
Joined
Jan 23, 2008
Messages
65,249
Reaction score
1,829
Points
113
Location
Keller, Texas
Your Mac's Specs
2017 27" iMac, 10.5" iPad Pro, iPhone 8, iPhone 11, iPhone 12 Mini, Numerous iPods, Monterey
OK, then check System Preferences, Security & Privacy, General. Make sure you haven't placed a check in the box for "Require Password...... If there's a check in that box, you'll need to click the small lock, enter your admin password to allow the lock to open. Then you can remove the check from the box.
 
OP
royalpei
Joined
Apr 3, 2009
Messages
258
Reaction score
0
Points
16
Location
Utah
Your Mac's Specs
Imac 27"12.2.1 Monterey.1phone 13, iwatch,ipad air
Thank you for your reply, that has been looked into also, its not the problem.
 
Joined
Jul 30, 2009
Messages
7,125
Reaction score
205
Points
63
Location
Wisconsin
Your Mac's Specs
Mac Mini (Late 2014) 2.6GHz Intel Core i5 Memory: 8GB 1600MHz DDR3
... unless you enjoy getting suggestions of where you've already looked.

Point well taken, er, well made.

OP, can you think of other things you've looked at? (So, they don't get suggested as well.)
 
M

MacInWin

Guest
Before I upgraded to Yosemite, each time I sat at my imac, it was 'open'.
Now every time I have to 'sign in'. I have changed every setting I can think of and its still there, takes quite awhile to wake up also.


I would appreciate any help.
1. Please read the link in my sig and give us some meaningful information. Playing Twenty Questions is going to make it very difficult to sort out.

2. What does "Sat at my iMac, it was 'open'" mean? Was the iMac powered off, sleeping, awake, what? We can't even begin to suggest meaningful stuff until we know more.
 
OP
royalpei
Joined
Apr 3, 2009
Messages
258
Reaction score
0
Points
16
Location
Utah
Your Mac's Specs
Imac 27"12.2.1 Monterey.1phone 13, iwatch,ipad air
I am sorry I am not as 'savvy' in my language that you understand me.
It used to be when I returned to my imac it was awake and ready to go.
Now I have to sign in everytime and it takes awhile to be ready to use.
I know it has to do with Yosemite, because now my macbook pro is doing it after installing Yosemite.
I had tried all of the suggestions above, I do not know what else to try.
They were just obvious ones to try.

I hope you can make sense of this post.
 
M

MacInWin

Guest
Yep, that helped.

If you want it always on, go to System Preferences/Energy Saver and move the slider on the two bars, labelled Computer sleep and Display sleep, all the way to the right. Now the machine will never sleep. However a better way to set it up is to have Computer sleep all the way right and Display sleep somewhere around the 15min tick. That way the screen goes black, but wakes up when you press any key. Now, if you do that, to avoid having to enter the password when the screen has gone dark, go to System Preferences/Security & Privacy and make sure that on the General tab there is no tick in the Require Password box. TO make that change you will have to click on the lock at the bottom left, enter your admin password and then make the change or it won't apply.
 
OP
royalpei
Joined
Apr 3, 2009
Messages
258
Reaction score
0
Points
16
Location
Utah
Your Mac's Specs
Imac 27"12.2.1 Monterey.1phone 13, iwatch,ipad air
I truly thank you for your help, that did not work either, I came back 6 hours later and I had to sign in again.
Thanks any way.
 
M

MacInWin

Guest
Yes, you have to sign in. That's a different setting. The suggestion I made was to solve the "takes quite awhile to wake up also" comment. To avoid having to sign in (which is, but the way, for your security) System Preferences/Security & Privacy, General and UN check the "require password ... after sleep or screen saver begins" and your machine should not require you to log in. You may have to press a key to wake the screen, but no login. Also, go to System Preferences/Desktop & Screen Saver and set the "Start After" to Never on the Screen Saver tab. With those settings your machine will never sleep, never screensaver, never ask for a password after you log in and be power consuming and wide open to anyone who comes along.
 
OP
royalpei
Joined
Apr 3, 2009
Messages
258
Reaction score
0
Points
16
Location
Utah
Your Mac's Specs
Imac 27"12.2.1 Monterey.1phone 13, iwatch,ipad air
Yes, you have to sign in. That's a different setting. The suggestion I made was to solve the "takes quite awhile to wake up also" comment. To avoid having to sign in (which is, but the way, for your security) System Preferences/Security & Privacy, General and UN check the "require password ... after sleep or screen saver begins" and your machine should not require you to log in. You may have to press a key to wake the screen, but no login. Also, go to System Preferences/Desktop & Screen Saver and set the "Start After" to Never on the Screen Saver tab. With those settings your machine will never sleep, never screensaver, never ask for a password after you log in and be power consuming and wide open to anyone who comes along.

NOPE, not true at all I have done everything suggested and I was out of the office long enough to eat dinner, came back and my firefox picture was there. Touched the computer return key, all closed and sign on came back on.
Signed in, all programs closed. It is driving me crazy. Imac only a few months old and since upgrading I HATE IT!!!!!!!!!!!!!!
 

chscag

Well-known member
Staff member
Admin
Joined
Jan 23, 2008
Messages
65,249
Reaction score
1,829
Points
113
Location
Keller, Texas
Your Mac's Specs
2017 27" iMac, 10.5" iPad Pro, iPhone 8, iPhone 11, iPhone 12 Mini, Numerous iPods, Monterey
Well, we don't know what to tell you. You've received every possible answer as to why your log on name and password are required and you say none of our suggestions have worked for you. If your account is the only one on the iMac and you have no other accounts activated, and not using FileVault, and have followed all our suggestions, you should not have to sign in. Maybe it's time for you to contact Apple? Your iMac should still be under warranty and free telephone support if it's less than 3 months old.
 
C

chas_m

Guest
Something -- perhaps a third-party program? Is logging you out of your account after X amount of time. Or at least that's what it sounds like.

When you come back to the machine and have to sign in again, is it the standard OS X login screen, or something a little different (like a dimmed-out view of your normal desktop)?

Also, under "Users & Groups," do you have automatic login under your account turned on or off?

Finally, can you verify that Filevault is turned off by telling me what the last line of the Filevault panel says under "Security and Privacy" in System Preferences?
 
M

MacInWin

Guest
+1 for what chscag said. If, in fact, you have taken all the steps we have suggested, there is nothing else to be done.
 
Joined
Jul 30, 2009
Messages
7,125
Reaction score
205
Points
63
Location
Wisconsin
Your Mac's Specs
Mac Mini (Late 2014) 2.6GHz Intel Core i5 Memory: 8GB 1600MHz DDR3
Well, what about creating a new, troubleshooting account to see if the problem persists there?
 
OP
royalpei
Joined
Apr 3, 2009
Messages
258
Reaction score
0
Points
16
Location
Utah
Your Mac's Specs
Imac 27"12.2.1 Monterey.1phone 13, iwatch,ipad air
I really appreciate all of you trying to help and I think you are correct, either contact Apple or live with it.
 
Joined
Jul 30, 2009
Messages
7,125
Reaction score
205
Points
63
Location
Wisconsin
Your Mac's Specs
Mac Mini (Late 2014) 2.6GHz Intel Core i5 Memory: 8GB 1600MHz DDR3
I really think you should create another user account and see if the problem still exists there.
 

Shop Amazon


Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.
Top