• Welcome to the new Mac-Forums. See News and Community Announcements for more details.

Garageband Problems

C

cashmoney

Guest
I just recently switched to a 1.2 ghz mac mini with 266 mb of ram. When using garageband, after adding more then 8-10 loops I get a pop up message saying that garageband cannot play all the tracks. Is this because of the ram or b/c of the processor speed? Is there anything I can do to maximize my garageband experience? Thanx!
 

trpnmonkey41


Retired Staff
Joined
Jul 22, 2003
Messages
6,999
Reaction score
187
Points
63
Location
Hamilton College
Your Mac's Specs
20" iMac C2D 2.16ghz, 13" MacBook 2.0ghz, 60gb iPod vid, 1gb nano
256 mb of ram is nowhere near enough for GarageBand
 
X

xthisisRomancex

Guest
actually there are several ways to fix this problem as stated above MORE RAM wouild be the best choice. but there are ways to get around this.
Make sure your proccessor to the highest setting.. in order to do this go into system prefs // energy saver // in the drop down menu for optimize energy settings: choose highest performance.. ( this might already be chosen since you dont have battery life and what not)
ok another way is to mute some tracks like the ones youi have down to a perfection... MUTE those tracks
the way that works the best seems to be the hardest and most time consuming. is... once you get a track the way you want it.. or maybe even a peaice of a song. export it to ITUNES and then drag it from your itunes filder in your finder into gargeband. it will allow you to listen to all tracks but the down side is you cant edit the exported part.
if this sounds confusing or you need any help with using garage band u can PM or get my AIM account from my profile... i will be more than glad to help you out you of course just post you question here.


aaron%
 

Aptmunich


Retired Staff
Joined
Mar 9, 2004
Messages
9,073
Reaction score
331
Points
83
Location
Munich
Your Mac's Specs
Aluminium Macbook 2.4 Ghz 4GB RAM, SSD 24" Samsung Display, iPhone 4, iPad 2
xthisisRomancex said:
actually there are several ways to fix this problem as stated above MORE RAM wouild be the best choice. but there are ways to get around this.
Make sure your proccessor to the highest setting.. in order to do this go into system prefs // energy saver // in the drop down menu for optimize energy settings: choose highest performance.. ( this might already be chosen since you dont have battery life and what not)
ok another way is to mute some tracks like the ones youi have down to a perfection... MUTE those tracks
the way that works the best seems to be the hardest and most time consuming. is... once you get a track the way you want it.. or maybe even a peaice of a song. export it to ITUNES and then drag it from your itunes filder in your finder into gargeband. it will allow you to listen to all tracks but the down side is you cant edit the exported part.
if this sounds confusing or you need any help with using garage band u can PM or get my AIM account from my profile... i will be more than glad to help you out you of course just post you question here.


aaron%
There's a much easier way to do that - and it isn't called muting the track either:

If you have completed a track (the drum track for example), just select that track and hit the little Padlock icon that's next to the instruments icon.

The track is then LOCKED - meaning it is written to the harddrive with all the effects/filters etc., thus reducing the load on the CPU.

This is a new feature of Garageband 2 - very useful!


But you still need more RAM :)
 
Top