From 10.4.11 to 10.5 Can It Be Done?

Joined
Jul 30, 2008
Messages
48
Reaction score
0
Points
6
OK my question a simple one but one im asking anyway.

Is my Powermac G4 able to run leopard:

Specs:
Dual 450 Processors (again i ask does this equal 900??)
512mb ram
40gb hard drive
DVD-RW

Im currently running on 10.4.11?
Can I upgrade OS?
Other than RAM what would I need to upgrade?
 
Joined
Jan 29, 2008
Messages
703
Reaction score
9
Points
18
Location
Mendocino, CA
There's a program called LeopardAssist that helps you to install Leopard on sub-867MHz G4 Macs. It sounds pretty cool, but it's probably a terrible idea!
 

dtravis7


Retired Staff
Joined
Jan 4, 2005
Messages
30,133
Reaction score
703
Points
113
Location
Modesto, Ca.
Your Mac's Specs
MacMini M-1 MacOS Monterey, iMac 2010 27"Quad I7 , MBPLate2011, iPad Pro10.5", iPhoneSE
There is a reason Apple set that mininum spec of an 867Mhz G4. It will be very slow on a lesser system if you can get it to work.
 
Joined
Jan 29, 2008
Messages
703
Reaction score
9
Points
18
Location
Mendocino, CA
There is a reason Apple set that mininum spec of an 867Mhz G4. It will be very slow on a lesser system if you can get it to work.

Indeed. It's a shame you can't just disable the resource-heavy features and run it on an older computer. My favorite new features are the adjustable icon-spacing (why did it take them so long to implement this?) and tabbed terminal windows. Spaces is pretty cool too, but it's not something that has to require a beefy computer - the Gnome and KDE desktop environments have been doing this for years (as well as many others, I'm sure)!
 

Shop Amazon


Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.
Top