Firewire drive not showing up?



Hello. I just received my external ADS Dual Liknk drive kit to go with a Segate 80gb 7200rmp drive. I can not get the disk to mount via the firewire connection. It DID mount with the USB connection, but the eMac using OS 10 that I have it hooked up to does not have USB 2.0. I followed the directions carefully and initially tried the firewire. When I was unable to get it to mount, I then tried the USB...after a few minutes, it came up. I shut everything down and then tried the Firewire connection again. It came up for about 30 seconds, but then went away saying that I didn't unmoutn it properly, etc.

Also, the disk that came with the dirve says there are some Mac Utlities, but there was least nothing that was compatible with OS10.

Any suggestions? Shouldn't it just popup with firewire just like it did with USB?

There is already data on the drive, but I was able to get it backed up via the USB connection. But when I went to the OS10 Disk Utlities, trhe drive only shows up under USB. Should I format it AGAIN? Is the drive suspect? It is a new drive, but I have had problems with it previously...although I didn't suspect the drive as it was going in a suspect G3 with a scsi drive, etc.

Thanks for any feedback!


Shop Amazon

Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.