external harddrive problem

Joined
Jan 22, 2010
Messages
6
Reaction score
0
Points
1
Hi,

my macbook pro doesn't recognize my external Iomega Hard drive. Yesterday it still worked... The LED-light is on, the drive spins up, but doesn't appear on the desktop or in finder.
I all ready empted caches, rebooted, tried the hard drive on an other pc (it worked). Other USB-devices, such as my USB-sticks still work.
There was one moment of a about 10 seconds it worked again, all data was still on the disk, but then it disappeared again :(
Could you guys help me?
 
Joined
Mar 17, 2009
Messages
3,626
Reaction score
111
Points
63
Your Mac's Specs
2018 15" MBP, 2019 11" iPad Pro, iPhone 11 Pro
So it's worked with your Macbook before?
Did you make sure all connections were good? Jiggle the cables, etc?
 
OP
S
Joined
Jan 22, 2010
Messages
6
Reaction score
0
Points
1
yes, i tried for about 10000000 times to connect :s
Disk utility sees the disk, but can't get any access to it. Very strange...
 

chscag

Well-known member
Staff member
Admin
Joined
Jan 23, 2008
Messages
65,247
Reaction score
1,834
Points
113
Location
Keller, Texas
Your Mac's Specs
2017 27" iMac, 10.5" iPad Pro, iPhone 8, iPhone 11, iPhone 12 Mini, Numerous iPods, Monterey
If Disk Utility can "see" the drive, try doing a verify and repair from the First Aid tab. Post back results. Also, what file format is the iOmega using?

Regards.
 
OP
S
Joined
Jan 22, 2010
Messages
6
Reaction score
0
Points
1
I copied this afternoon all my data to a second hard drive using a Windows PC.
Now, i could see the Hard disk in disk utlilty on my mac, but couldn't do anything with it.
BUT, all of a sudden, this evening, i plug the hard disk into my macbook, and the disk appears on my desktop. So now i verified and repaired it. Hopefully the problems stay away now. In any case, i have a back up now :)
 
Joined
Jan 19, 2010
Messages
32
Reaction score
1
Points
8
Location
Ottawa, Ontario
Your Mac's Specs
2009 13.3" MacBook Pro: 300GB HDD, 2.53 GHz, 4GB DDR3 RAM/ 80GB iPod Video Classic
I'm having the same problem.
I have a 500GB Western Digital External HDD that's not showing up in my Finder.
I've used it countless times before, but now it just won't show up.
It shows up fine in Disk Utility, but not in the Finder.
When I try and open up Finder, it says it's indexing my data, 8 minutes remaining.
I'm thinking it's trying to index the content on the HDD?
It's never said Indexing Finder before though...

The indexing just finished, and it didn't seem to have fixed the problem.
When I tried using the First Aid in the Disk Utility, it gave me the message

"Disk Utility stopped repairing “My Book” because the following error was encountered:

Filesystem verify or repair failed."

Any ideas?
 

Shop Amazon


Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.
Top