Choppy Graphics 10.6.3 on 13" Unibody Macbook

Joined
Dec 3, 2009
Messages
25
Reaction score
1
Points
3
Hey people :Smirk:

Im running 10.6.3 on a 13" Aluminium Macbook (5,1) and am experiencing choppy / laggy graphics with the NVidia GeForce 9400M graphics card but only when running on battery power. When I am running on AC power, the graphics are smooth with no issues.

The graphics are choppy when opening the dashboard, expose, spaces and opening stacks from the dock on battery but fine on power

This is a really annoying issue and want to know how to sort it.

Thanks in advance

(System Specs - 160gb HDD (112gb spare) - 2gb Ram - 2GHz Core 2 Duo)
 
Joined
Jan 19, 2008
Messages
4,695
Reaction score
73
Points
48
Location
houston texas
Your Mac's Specs
09 MBP 8GB ram 500GB HD OS 10.9 32B iPad 4 32GB iPhone 5 iOs7 2TB TC Apple TV3
I would take it to an Apple store and have them give it a look sounds like the hardware
may have an issue.
 
Joined
Jun 22, 2008
Messages
3,343
Reaction score
213
Points
63
Location
Forest Hills, NYC
Your Mac's Specs
15-inch Early 2008; Processor 2.4 GHz Intel Core 2 Duo; Memory 4 GB 667 MHz DDR2 SDRAM; 10.7.5
Here's a good question (I think). Before you did the combo update, and were on 10.6.2, were you experiencing the same issues ?

Doug

P.S. Also, when you upgraded to Snow Leopard, did you do a clean install (reformatting the HD) or did you just update and leave everything else in tact.
 
OP
Mac :)
Joined
Dec 3, 2009
Messages
25
Reaction score
1
Points
3
Hey Doug

On 10.6.2 I did have the same problems and when i upgraded to SL, i did an upgrade rather than clean install
 
Joined
Jun 22, 2008
Messages
3,343
Reaction score
213
Points
63
Location
Forest Hills, NYC
Your Mac's Specs
15-inch Early 2008; Processor 2.4 GHz Intel Core 2 Duo; Memory 4 GB 667 MHz DDR2 SDRAM; 10.7.5
And what about on 10.5.3? Same issues ? If so, then bring it in to Apple before your warranty expires. Sounds fishy.

Doug
 
OP
Mac :)
Joined
Dec 3, 2009
Messages
25
Reaction score
1
Points
3
Cheers Doug

I seem to recall having absolutely no issues whatsoever with Leopard, its just ever since i installed Snow Leopard i've had jittery / choppy graphics issues.

1 interesting thing is that whenever i play a game on battery power, the graphics are fine and the same as they are on AC power.
 
Joined
Jun 22, 2008
Messages
3,343
Reaction score
213
Points
63
Location
Forest Hills, NYC
Your Mac's Specs
15-inch Early 2008; Processor 2.4 GHz Intel Core 2 Duo; Memory 4 GB 667 MHz DDR2 SDRAM; 10.7.5
You might think me crazy, and the suggestion to be a bit overkill but... How about backing your stuff up and reformatting your HD and starting from scratch with SL ? I take it you've run Onyx or at the least have gone into utilities and have run disk utility to repair permissions ? If not, try that first. I personally have never had a good experience in trying to upgrade an OS without a fresh install/reformat. I now make it a habit to reformat my HD's and even zero out the disk (regular pass is fine) before installing a new OS version.

Doug
 

Shop Amazon


Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.
Top