• Welcome to the new Mac-Forums. See News and Community Announcements for more details.

Can't Add Fonts In Font Book



I just updated my OS to Panther, and one of the main reasons for doing so was because it had its own font manager. Unfortunately, it seems my Mac prayers have gone unanswered. I can double click SOME fonts in the finder, and the Font Book works as advertised: a window opens up previewing the font with a button below for adding the font to the Font Book program. However, for whatever reason, this does not work with ALL the fonts. Some fonts I click on and I get nothing... no preview window, no option to add the font. I also tried adding these fonts to Font Book both through the menu and by clicking the "+" (add font) button on the window. That doesn't work either.

I opened information windows on a font that Font Book accepted, and one one that it did not. The two fonts are identical in both kind and ownship/permissions. I'm at a loss. Please help, as (of course) the fonts that Font Book won't take are the very ones I need.

Thank you in advance.

Dual 867 MHz PowerPC G4, OS X 10.3.5, 1GB DDR SDRAM
Aug 25, 2004
Reaction score
New Zealand
Your Mac's Specs
13" MBA. 15" MBP. iPhone 4. 3G Pad 2.
I've had a few fonts that Panther didn't like for some reason too.
Just a work around that worked with most of them. Install the fonts onto any XP box then send to the mac (via email is OK) from the XP's font list then try again.
Fingers crossed. :)