ATV 2, lost Netflix

Mar 25, 2011
Reaction score

I have an Apple TV2, its a jailbroken unit running XBMC but thats another story! Anyway, recenntly I have been getting an error message when I load Netflix, "Netflix is currently unavailable, please try again later". Having googled this message it appears that it could be to do with logging out and back in, rebooting routers and the ATV, changing the country I reside in through Itunes etc etc etc. I have done all of those things and still no joy, I even called Netflix who ended up saying it was an apple problem.

I have tried to reset and restore factory defaults on the ATV but it just goes dead and doesnt seem to reset, The only thing that recently changed was the cable I used to connect to my router as it previously went through a netgear switch and it seems that around that time is when the trouble started.

In essence is their a way to reinstall apps on the ATV or does anyone have any other potential solution to this as I am totally stuck!

With XBMC I find now that all the links are broken however if I use it on my computer I seem to be able to land them so that also is pretty pointless now!

Shop Amazon

Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.