Apple TV not accessing iTunes

Joined
Jul 3, 2010
Messages
56
Reaction score
0
Points
6
After installing Yosemite, Apple TV will not access my iTunes library although I have Home Sharing turned on. And ideas? Qball.
 
OP
Q
Joined
Jul 3, 2010
Messages
56
Reaction score
0
Points
6
Yes, I am running latest version of iTunes. One possible reason could be that I did a clean install of Yosemite, Not sure if that might be causing problems. My iTunes account is the same and I have reset Apple TV. To all intents and purposes, everything is in order.
 
Joined
Nov 1, 2007
Messages
1,193
Reaction score
58
Points
48
Location
Swansea - South Wales
Your Mac's Specs
2021 M1 Pro 14" MBP, 2020 M1 Mac Mini (MacOS 12.4), iPhone 12 (iOS 15.5)
I was suffering with the same problem. This solved it:

system preferences
sharing
make sure your computer's name is correct (mine was showing (my) 27" iMac (11) - I deleted the 11)
then go into iTunes
file
turn off home sharing
then turn it back on

hope this works for you
 

bobtomay

,
Retired Staff
Joined
Dec 22, 2006
Messages
26,561
Reaction score
677
Points
113
Location
Texas, where else?
Your Mac's Specs
15" MBP '06 2.33 C2D 4GB 10.7; 13" MBA '14 1.8 i7 8GB 10.11; 21" iMac '13 2.9 i5 8GB 10.11; 6S
I had to restart the AppleTV to get it to work.
 
OP
Q
Joined
Jul 3, 2010
Messages
56
Reaction score
0
Points
6
Have restarted Apple TV several times, updated software and checked that home sharing is on in iTunes. It simply won't acknowlege iTunes since upgrading to Yosemite. I love. Challenge but this is so frustrating considering everything worked perfectly before upgrading.
 
M

MacInWin

Guest
Long shot, but there is a bug in Yosemite (and mavericks and several generations back) where if your Mac goes to sleep and the network loses connections, when it wakes up and reconnects the name of the Mac will become "whatever (#)" where whatever is the original name and the number increments up from 2 to infinity, I guess. That's why nickyr had to delete the (11) from his machine. There is no fix. But this article discusses some possible approaches. What I did was to go into System Preferences/Energy Saver and set the Computer Sleep slider all the way to the right at "Never." That way the CPU never shuts off and you never lose the WiFi connection, so the renaming doesn't happen. You can let the display sleep have the screen go black, just leave the CPU ticking over. It seems to be working for me.
 
OP
Q
Joined
Jul 3, 2010
Messages
56
Reaction score
0
Points
6
I am somewhat embarrassed, but I have just fixed this problem.I have been trying to set up Home Sharing through iTunes preferences. There is a tick box there so I thought that was the only option. However, I found there is a Home Sharing link the dropdown menu. I clicked and hey presto I am back online. Thanks for helping and sharing my frustration.
 

Shop Amazon


Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.
Top