Apple TV gets music from iTunes, but not movies!?

Joined
May 6, 2014
Messages
15
Reaction score
0
Points
1
Location
Scotland, UK
Your Mac's Specs
27" Mid 2011 iMac running OSX 10.9.2 | 2.7GHz Inter Core i5 | 8GB Ram | w/External 32" Monitor
Hey guys! Really hope you can shed some light on this situation!

I've had my 3rd Gen Apple TV for a while now, and other than a couple of little bugs it's more or less always held it's own. It's in mine and the wife's room linked to the TV so we can occasionally watch Netflix and stream videos from my iMac ( in the next room. ) Usually works absolutely fine, although last night the Apple TV would pick up my 'photos', 'music', and 'TV shows', but not 'movies' from my shared iTunes library...

Very weird, I know home sharing is on through iTunes, tried disabling and enabling it. Authorised my mac again, to see if that would help. Restarted both the iMac and the Apple TV, checked for updates on the Apple TV ( it's up to date, ) and nothing seems to fix it.

What's even more strange though, is that it's only the movies. I can still scroll through and listen to my entire music collection on the Apple TV... There's just no mention of movies on the list..

m3ehx.jpg


Really hoping someone can help me out here..

Cheers!
 
Joined
Sep 30, 2007
Messages
9,484
Reaction score
817
Points
113
Location
The Republic of Neptune
Your Mac's Specs
2019 iMac 27"; 2020 M1 MacBook Air; macOS up-to-date... always.
Well color me baffled. I just spent 20 minutes trying to HIDE my movies in order to recreate your problem and never actually could do it. I would have thought that I could uncheck "Movies" from the selected playlists under iTunes' Sharing prefs, but even after rebooting my ATV, it continued to show my movies. I can't find any settings in iTunes or on the ATV itself to do this. Oh sure, if I hide "Movies" in my sharing settings, they don't show up in iTunes when I switch over to my wife's user account, but apparently the ATV is something special. "Sharing" and "Home Sharing" appear to be 2 different things, and you can't control "Home Sharing" like you can "Sharing". It's stupid stupid stupid and one of the things that aggravate the living **** out of me when it comes to Apple.

My best suggestion, barring a solution from someone else, is to restore the firmware on the ATV.
https://support.apple.com/kb/ht4367
 
OP
A
Joined
May 6, 2014
Messages
15
Reaction score
0
Points
1
Location
Scotland, UK
Your Mac's Specs
27" Mid 2011 iMac running OSX 10.9.2 | 2.7GHz Inter Core i5 | 8GB Ram | w/External 32" Monitor
Well color me baffled. I just spent 20 minutes trying to HIDE my movies in order to recreate your problem and never actually could do it. I would have thought that I could uncheck "Movies" from the selected playlists under iTunes' Sharing prefs, but even after rebooting my ATV, it continued to show my movies. I can't find any settings in iTunes or on the ATV itself to do this. Oh sure, if I hide "Movies" in my sharing settings, they don't show up in iTunes when I switch over to my wife's user account, but apparently the ATV is something special. "Sharing" and "Home Sharing" appear to be 2 different things, and you can't control "Home Sharing" like you can "Sharing". It's stupid stupid stupid and one of the things that aggravate the living **** out of me when it comes to Apple.

My best suggestion, barring a solution from someone else, is to restore the firmware on the ATV.
https://support.apple.com/kb/ht4367

I just reset my Apple TV before, which is a total pain in the hoop because of having to put in all of the login details for netflix, apple ID, wi-fi etc is a tad annoying, but I suppose doing a reset is the only other option I have... I'll do it and report back!
 
OP
A
Joined
May 6, 2014
Messages
15
Reaction score
0
Points
1
Location
Scotland, UK
Your Mac's Specs
27" Mid 2011 iMac running OSX 10.9.2 | 2.7GHz Inter Core i5 | 8GB Ram | w/External 32" Monitor
Nope! Apple TV restored, same sketch applies. What else could I do? :(

Just to note;

- iMac has been restarted
- ATV has been restarted
- WiFi has been restarted
- ATV has been reset
- ATV has been restored
- iMac is running OSX Yosemite ( can't be the issue as it's been working before on this OS )
- ATV is up to date

Home sharing is clearly on as I can listen to all of my iTunes library on ATV, the 'movies' option under computers is just completely gone now.

260s9vk.jpg


Literally anyone with any suggestions would be appreciated guys, it's doing my head in.
 
Last edited:
Joined
Feb 14, 2004
Messages
4,781
Reaction score
166
Points
63
Location
Groves, Texas
Shot in the dark...
Select 'Share selected playlists'. Select all of them. Click OK.
Open it back up. Put it back to 'Share entire library'.
Hey, you never know...
 
OP
A
Joined
May 6, 2014
Messages
15
Reaction score
0
Points
1
Location
Scotland, UK
Your Mac's Specs
27" Mid 2011 iMac running OSX 10.9.2 | 2.7GHz Inter Core i5 | 8GB Ram | w/External 32" Monitor
Shot in the dark...
Select 'Share selected playlists'. Select all of them. Click OK.
Open it back up. Put it back to 'Share entire library'.
Hey, you never know...

Cheers for the reply dude, but nope. Still the same.
 
OP
A
Joined
May 6, 2014
Messages
15
Reaction score
0
Points
1
Location
Scotland, UK
Your Mac's Specs
27" Mid 2011 iMac running OSX 10.9.2 | 2.7GHz Inter Core i5 | 8GB Ram | w/External 32" Monitor
Does anyone know if it would be worth uninstalling iTunes on my iMac and re-installing? Really don't want to do this as my iTunes library is 239GB and adding all of the content back in takes a **** while, but if anyone has any viable reason to believe it might work I'll bite the bullet. Clutching straws before it's a trip back to Apple.
 
Joined
Sep 30, 2007
Messages
9,484
Reaction score
817
Points
113
Location
The Republic of Neptune
Your Mac's Specs
2019 iMac 27"; 2020 M1 MacBook Air; macOS up-to-date... always.
I'm just asking the obvious, but it has to be asked.... do you have any movies in iTunes? I don't mean purchases in the cloud... movies that are on your hard drive?
 
OP
A
Joined
May 6, 2014
Messages
15
Reaction score
0
Points
1
Location
Scotland, UK
Your Mac's Specs
27" Mid 2011 iMac running OSX 10.9.2 | 2.7GHz Inter Core i5 | 8GB Ram | w/External 32" Monitor
I'm just asking the obvious, but it has to be asked.... do you have any movies in iTunes? I don't mean purchases in the cloud... movies that are on your hard drive?

2hs956o.jpg


231 'Home Movies' and 1 'TV show' my man.
 
OP
A
Joined
May 6, 2014
Messages
15
Reaction score
0
Points
1
Location
Scotland, UK
Your Mac's Specs
27" Mid 2011 iMac running OSX 10.9.2 | 2.7GHz Inter Core i5 | 8GB Ram | w/External 32" Monitor
And they all play fine in iTunes, I can play them in iTunes and then hit the airplay button within iTunes to play them on the Apple TV, so they're working okay. Just the list within the Apple TV no longer has 'Movies' or 'Home Movies' in it ( Forgotten what it's called in the list. )
 
Joined
Sep 30, 2007
Messages
9,484
Reaction score
817
Points
113
Location
The Republic of Neptune
Your Mac's Specs
2019 iMac 27"; 2020 M1 MacBook Air; macOS up-to-date... always.
Those aren't "movies" They are "home videos". At least as far as iTunes is concerned. There may be a problem with the way they are tagged. But I see a bigger problem. You are running the beta version of Yosemite, judging from your screen shot. It's beta for a reason. I'm just going to go ahead and assume that is the problem.
 
OP
A
Joined
May 6, 2014
Messages
15
Reaction score
0
Points
1
Location
Scotland, UK
Your Mac's Specs
27" Mid 2011 iMac running OSX 10.9.2 | 2.7GHz Inter Core i5 | 8GB Ram | w/External 32" Monitor
Those aren't "movies" They are "home videos". At least as far as iTunes is concerned. There may be a problem with the way they are tagged. But I see a bigger problem. You are running the beta version of Yosemite, judging from your screen shot. It's beta for a reason. I'm just going to go ahead and assume that is the problem.

They've always been like that and shown up under 'movies' on the Apple TV. And as far as Yosemite is concerned usually I'd 100% agree with you, I run it knowing that not everything will work as intended, my Final Cut Pro for instance needs a fair bit of guidance to even open, but I was watching movies through my Apple TV from my iTunes library by clicking Computers, going into Movies and pressing play only two days ago, now the movie option under computers has just completely disappeared.
 
Joined
Sep 30, 2007
Messages
9,484
Reaction score
817
Points
113
Location
The Republic of Neptune
Your Mac's Specs
2019 iMac 27"; 2020 M1 MacBook Air; macOS up-to-date... always.
They've always been like that and shown up under 'movies' on the Apple TV. And as far as Yosemite is concerned usually I'd 100% agree with you, I run it knowing that not everything will work as intended, my Final Cut Pro for instance needs a fair bit of guidance to even open, but I was watching movies through my Apple TV from my iTunes library by clicking Computers, going into Movies and pressing play only two days ago, now the movie option under computers has just completely disappeared.

Any video files with metadata flagging them as "Home Videos" show up under the "Home Videos" section of iTunes, not "Movies". At least they are supposed to. You either have severely flawed metadata, or a bug in the beta version of Yosemite because it simply isn't working like it should. Try re-tagging all your movies, or even just a handful as a test, with iDentify 2. There is no better software for this task on OS X.

EDIT: be sure to remove the videos from your list in iTunes before re-tagging them, then re-add them to iTunes. iDentify can auto-add to iTunes also.
 
OP
A
Joined
May 6, 2014
Messages
15
Reaction score
0
Points
1
Location
Scotland, UK
Your Mac's Specs
27" Mid 2011 iMac running OSX 10.9.2 | 2.7GHz Inter Core i5 | 8GB Ram | w/External 32" Monitor
Any video files with metadata flagging them as "Home Videos" show up under the "Home Videos" section of iTunes, not "Movies". At least they are supposed to. You either have severely flawed metadata, or a bug in the beta version of Yosemite because it simply isn't working like it should. Try re-tagging all your movies, or even just a handful as a test, with iDentify 2. There is no better software for this task on OS X.

How would I go about doing that buddy? Willing to give anything a shot right now aha
 
Joined
Sep 30, 2007
Messages
9,484
Reaction score
817
Points
113
Location
The Republic of Neptune
Your Mac's Specs
2019 iMac 27"; 2020 M1 MacBook Air; macOS up-to-date... always.
How would I go about doing that buddy? Willing to give anything a shot right now aha

Download iDentify and drop a few (or even one) sample video as a test. Make sure that iDentify is set to overwrite existing tags and uses iMDB as a source (de-select any options for TagChimp... they shut down a few days ago). Note that this doesn't work for iTunes purchases due to DRM. And if these are in fact iTunes purchases, then the metadata should be fine, pointing to a bug in Yosemite.

The easiest way to settle this would be to simply boot back into Mavericks and test from there. You do have a dual-boot setup, right? Not using a beta OS as something you rely on, right???

One other thing to do... pull up the "Get Info" sheet on a sample video in iTunes and post screen caps of the "Sorting" and "Options" tab so we can see how these are tagged.
 

Slydude

Well-known member
Staff member
Moderator
Joined
Nov 15, 2009
Messages
16,950
Reaction score
681
Points
113
Location
North Louisiana, USA
Your Mac's Specs
2.8 GHz 2008 MacBook Pro 10.11, 8 GB mem, iPhone 12 Pro Max, 2015 iMac 16 GB Big Sur
If you have manually changed any of the metadata from within iMovie you often have to change the setting in two places in iTunes. On the first info screen in iTunes setting the genre to Movie is not enough to make iTunes realize the change. You have to go to the Options tab and change the Media Kind setting as well.
 
Joined
Aug 19, 2014
Messages
792
Reaction score
4
Points
18
it might be compatible with iTunes and quicktime but unable to play them back on the apple tv because its a unsupported format
 
Joined
Jan 10, 2011
Messages
36
Reaction score
1
Points
8
They've always been like that and shown up under 'movies' on the Apple TV. And as far as Yosemite is concerned usually I'd 100% agree with you, I run it knowing that not everything will work as intended, my Final Cut Pro for instance needs a fair bit of guidance to even open, but I was watching movies through my Apple TV from my iTunes library by clicking Computers, going into Movies and pressing play only two days ago, now the movie option under computers has just completely disappeared.

They just changed the menu options.

Computers>Home Videos

that's where you're going to find that group of movies you are showing. Used to be under Movies and if you had it set to "By Name" the Home Videos would show up. It's a separate main menu option now.

If you want to move them to movies, click the top one, hold down the shift key and click the bottom one, CTRL+click "Get Info" go over to Options and for Media Type change it to Movies.
 

Shop Amazon


Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.
Top