Aperture 2 freezing.

Oct 13, 2009
Reaction score
Your Mac's Specs
MacBook Pro, 2.53 GHz, 4 GB DDR3, 250 GB HDD, 10.6.4
I've had Aperture 2 for a couple of years and used it without a problem. Recently, my hard drive died. I reinstalled Aperture and it worked fine. A few days ago, I tried importing around 200 photos from an SD card. It seemed to be going fine, then froze about three quarters of the way through. On every subsequent attempt to run Aperture, I see the main screen, but as soon as I click, I get the spinning beach ball of death, and it persists until I get fed up and force quit.

I've Googled around and it appears to be a pretty common problem, but none of the solutions mentioned worked. I deleted the .plist, reinstalled, and everything else I could think of.
I checked Console, and got this:

I realize the image is a bit hard to read at that resolution, it says
***WARNING: Method selectedRowEnumerator in class NSProOutlineView is deprecated. It will be removed in a future release and should no longer be used.
Not at all sure what it means, but maybe someone else does?

**I tried asking around in the Imaging... forum, but didn't get any help from there, so I'm coming here.

Shop Amazon

Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.