apache server (httpd.conf error)

O

oo_mac_oo

Guest
apache server

my apache server can't start


Failed to start apache :
Syntax error on line 1044 of /etc/httpd/httpd.conf:
without matching section
/usr/sbin/apachectl start: httpd could not be started

:mad: :mad: :mad:
 
Joined
Oct 27, 2002
Messages
1,345
Reaction score
0
Points
36
Location
Vermont
Your Mac's Specs
17" iMac G4 800MHz 1GB RAM
Whats on line 1044 of /etc/httpd/httpd.conf?

Cut and paste that line here....
 
OP
O

oo_mac_oo

Guest
### Section 3: Virtual Hosts
#
# VirtualHost: If you want to maintain multiple domains/hostnames on your
# machine you can setup VirtualHost containers for them. Most configurations
# use only name-based virtual hosts so the server doesn't need to worry about
# IP addresses. This is indicated by the asterisks in the directives below.
#
# Please see the documentation at <URL:http://www.apache.org/docs/vhosts/>
# for further details before you try to setup virtual hosts.
#
# You may use the command line option '-S' to verify your virtual host
# configuration.

#
# Use name-based virtual hosting.
#
# NameVirtualHost limmac.myftp.org
#
# VirtualHost example:
# Almost any Apache directive may go into a VirtualHost container.
# The first VirtualHost section is used for requests without a known
# server name.
#
#<VirtualHost limmac.myftp.org>

### WWW ###

# primary domain name for this virtual host

ServerAdmin [email protected]
ServerName limmac.myftp.org
ErrorLog /Library/WebServer/limmac.myftp.org-error_log
TransferLog /Library/WebServer/limmac.myftp.org-access_log

### FTP ###

ErrorLog /Library/ftp/error_log
TransferLog /Library/ftp/access_log
</VirtualHost>

Include /private/etc/httpd/users


# begin entropy.ch PHP module activation
Include /usr/local/php/httpd.conf.php
# end entropy.ch PHP module activation

# begin entropy.ch PHP module activation
AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps
NameVirtualHost 10.0.88.2
DocumentRoot /Library/WebServer/Documents
User www
Group www
Options ExecCGI FollowSymLinks Includes IncludesNOEXEC Indexes MultiViews SymLinksIfOwnerMatch
# end entropy.ch PHP module activation
 
Joined
Jun 11, 2003
Messages
4,915
Reaction score
68
Points
48
Location
Mount Vernon, WA
Your Mac's Specs
MacBook Pro 2.6 GHz Core 2 Duo 4GB RAM OS 10.5.2
Are you still having problems with this? And which line was 1044?
 
Joined
Oct 27, 2002
Messages
1,345
Reaction score
0
Points
36
Location
Vermont
Your Mac's Specs
17" iMac G4 800MHz 1GB RAM
There isn't a line 1044? That is weird. Out of what you have posted, I don't see anything wrong. Attach the whole httpd.conf file. Either compress it or add the extension .txt so you can attach it. Upload the WHOLE thing, not just a cut and paste, and I will take a look at it....
 

rman


Retired Staff
Joined
Dec 24, 2002
Messages
12,625
Reaction score
168
Points
63
Location
Los Angeles, California
Your Mac's Specs
14in MacBook Pro M1 Max 32GB 2TB
Normally when the count exceeds the length fo the file. The error caused the compiler to lose sync (count) of the number of lines. In most cases the eror is something simple and near the end of the file.

That is what I have seen working with most programming languages.
 
Joined
Jun 11, 2003
Messages
4,915
Reaction score
68
Points
48
Location
Mount Vernon, WA
Your Mac's Specs
MacBook Pro 2.6 GHz Core 2 Duo 4GB RAM OS 10.5.2
Yep exactly and like Emry's I was going to say attatch the whole file for us to look at. We'll get you up and going! :)
 
OP
O

oo_mac_oo

Guest
Murlyn said:
Yep exactly and like Emry's I was going to say attatch the whole file for us to look at. We'll get you up and going! :)


I will the file when I at home ....
 
Joined
Jun 11, 2003
Messages
4,915
Reaction score
68
Points
48
Location
Mount Vernon, WA
Your Mac's Specs
MacBook Pro 2.6 GHz Core 2 Duo 4GB RAM OS 10.5.2
You need to uncomment line 1029:

#<VirtualHost limmac.myftp.org>

so that it looks like this:

<VirtualHost limmac.myftp.org>

Cheers!
 
Joined
Oct 27, 2002
Messages
1,345
Reaction score
0
Points
36
Location
Vermont
Your Mac's Specs
17" iMac G4 800MHz 1GB RAM
Yup, that looks like the culprit...
 
OP
O

oo_mac_oo

Guest
after change to <VirtualHost limmac.myftp.org> & delete Include /private/etc/httpd/users it works, Thank you all your help.. Cheers
 

Shop Amazon


Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.
Top