Airport Express can't find PPPoE host

Apr 15, 2007
Reaction score
I set up a second-hand AE base unit to connect to the Internet through a DSL modem. It worked fine but the status light was always amber. I succeeded in updating the firmware, but it no longer connected to the Internet. I did a factory reset of the AEBS and did the setup again. Now when I try to connect, the connection to the AEBS is fine but I always get the message "looking for PPPoE Host" until it eventually says that a PPPoE host cannot be found. System Preferences/Network tells me that I am connected to the Internet via Airport and the the connection is OK!

I am getting so frustrated! I have tried many things including deselecting the built-in Ethernet setting "Connect automatically when needed" as advised by Apple [artnum 107530].

Anyone any idea what I might be doing wrong?

Shop Amazon

Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.