Addressbook in OSX Lion not working

Oct 23, 2009
Reaction score
In my MBP(Lion) ,used by my wife, the adressbook got stuck on an other desktop. Some time ago she tried to update a page in adressbook but did not succeed. Yesterday I found out about it.When tapping ,via the trackpad, the adressbook-icoon in the dock nothing happens. With 2 finger tapping the adressbook appears from beneath the dock, on the same page as she tried to update. When tapping the adressbook again it disappears again, so you can not make any changes in it. You can only close it via the dock or in the adressbooks bar. When using mission control I see the adresbook (with that same opened page) in an other desktop.

So far I have done the following things:

1) Close adressbook and restart the MBP. And opened it again.
2) Start up in safe mode and repeated the steps under 1).
3) Put the com.aplle.Adressbook.plist file on the desktop and restarted the Adressbook again.

All these steps did not help any.

Who can help?


Shop Amazon

Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.