Results 1 to 15 of 15
  1. #1
    Adding Image to Photo
    I noticed my new MacBook Pro is not capable of adding image from one application or one site ( Facebook) when I control click on the image and click Add Image to Photos.... this process of Add Image to Photos works well with my old MBP but not with my new MBP... New MBP High Sierra v10.13.6 Mid 2015......Old MBP High Sierra v10.13.6 2011..
    Did I miss something?
    Attached Images Attached Images
    Last edited by greyzland; 11-18-2018 at 06:00 AM.

  2. #2
    Adding Image to Photo
    ferrarr's Avatar
    Member Since
    May 21, 2012
    Location
    Pawtucket, RI, US
    Posts
    5,350
    Your Mac's Specs
    L2014 Mac mini macOS Mojave, iPhone 8+ iOS 12, 12.9" iPad Pro 1 iOS 12, Pencil 1
    Did you add your Facebook account to System Preferences > Internet Accounts?
    -- Bob --
    Please backup. Everything has a life cycle, unexpected and warning free. Nothing will last as long as you want it to.

  3. #3
    Adding Image to Photo
    badshoehabit's Avatar
    Member Since
    Aug 02, 2011
    Location
    Tyneside, UK
    Posts
    1,357
    Your Mac's Specs
    MBP Retina late 2015 15.4" 16GB 2.5 GHz OS Mojave; iPhone 7 128gb; iPad Mini 2, 32gb
    Since you can no longer directly upload from Photos to Facebook, probably doesn't work the other way round either.
    Sue

    If the shoe fits, buy it in every colour.

  4. #4
    Adding Image to Photo
    IWT's Avatar
    Member Since
    Jan 23, 2009
    Location
    Born in Scotland, Worked in Scotland then England, Now live in Wales
    Posts
    4,838
    Your Mac's Specs
    Late 2015 5K 27-inch Retina iMac, 4GHz i7, 32GB RAM, 1TB Flash Drive, macOS High Sierra 10.13.6
    Sue is correct.

    Things have changed.

    This may help you - uploading & downloading use the same method (ie via the FB app): https://www.wikihow.tech/Upload-Phot...k-from-Android

    Ian
    Ian

  5. #5
    My problem is not only with Facebook image ( FB was just an example BTW ) and my problem is not about uploading nor downloading from FB, my problem is about adding image to My Photos, following the instructions " Add Image to Photos"... my old MBP is capable of adding any image from Yahoo, Google, Facebook etc. up to now following the same instructions of Control Click and Choosing Add Image to Photos..... but not with my newer MBP.....
    Thanks for all your replies.... I will try again as I know there will be something I need to check or uncheck somewhere in that newer MBP..

  6. #6
    Adding Image to Photo
    pm-r's Avatar
    Member Since
    Oct 16, 2010
    Location
    Brentwood Bay, BC, Canada
    Posts
    10,255
    this process of Add Image to Photos works well with my old MBP but not with my new MBP...

    What do you see when you control-click or right-click on an image with your new MacBook Pro?

    Do you see what you posted above or is that from your old MacBook Pro??

    Also, what application are you using when your "Add Image to Photos" doesn't work?? I'm guessing you are using a browser, which one, when it doesn't work.

    Have you shutdown your MacBook Pro that isn't working properly and then booted it??


    EDIT:
    BTW: when viewing an image in Facebook, to get the "Add Image to Photos" option to work you often have to double click on the image first and then right-click to get that option.
    But I guess you already knew that as it's working for you on your old MacBook Pro.

    It was just a thought I was thinking about…








    - Patrick
    ======
    Last edited by pm-r; 11-21-2018 at 01:02 AM.

  7. #7
    Hi Patrick... that image above is from my New MBP and yes I can see it in my old MBP, I can even Add Image to Photos ( that image above ) in my old MBP just to test the difference between the 2.... it is really strange/weird for my newer MBP to behave this way being unable to do what it is supposed to do...
    My browser is Safari.... and I can Add Image to Photo in my old MBP from Yahoo or Google.... but unable to do in my newer MBP...
    Strange indeed.......Thanks for your reply....
    I Need more research I guess.....

  8. #8
    I have finally resolved this failure to Add Image to Photos by comparing the Path of the Old MBP and my newer MBP in the Photos Preference.......thanks for all your inputs......

  9. #9
    Adding Image to Photo
    Slydude's Avatar
    Member Since
    Nov 16, 2009
    Location
    North Louisiana, USA
    Posts
    13,558
    Your Mac's Specs
    2.8 GHz 2008 MacBook Pro 10.11, 8 GB mem, iPhone XS, 2015 iMac 16 GB 10.14.1 beta
    Glad you got that sorted out and working the way that you want. What exactly was the solution that you found? It might help others if they encounter similar problems.

  10. #10
    Adding Image to Photo
    pm-r's Avatar
    Member Since
    Oct 16, 2010
    Location
    Brentwood Bay, BC, Canada
    Posts
    10,255
    I have finally resolved this failure to Add Image to Photos

    I'm glad to see you got things fixed what ever it was you did as Sly questioned.

    BTW: I couldn't help thinking if ClipMenu.app ( I couldn't work without it) and PopClip.app wouldn't make such saving and posting easier for you:
    ClipMenu
    ClipMenu.com: A clipboard manager for Mac OS X - ClipMenu.com

    PopClip
    https://pilotmoon.com/popclip/
    https://www.macupdate.com/app/mac/39470/popclip





    - Patrick
    ======

  11. #11
    Adding Image to Photo
    pm-r's Avatar
    Member Since
    Oct 16, 2010
    Location
    Brentwood Bay, BC, Canada
    Posts
    10,255
    Quote Originally Posted by Slydude View Post
    Glad you got that sorted out and working the way that you want. What exactly was the solution that you found? It might help others if they encounter similar problems.

    2Bits says the Photos library wasn't in the default location??? Hmmm…???





    - Patrick
    ======

  12. #12
    I do not know to how say it in computer lingo but seems like it is how you say it pm-r...I compared the Preferences of the 2 Laptops and found the difference.....in my 2011 MBP, that Box " Use As System Photo Library" opposite the "Show in Finder " box is greyed..... in my 2015 MBP, that Box "Use as System Photo Library" is Active ( not greyed?).. so I just clicked that box thinking to inactivate which it did and voila!!!! it resolved my problem...
    Screen Shot 2018-11-22 at 6.04.41 AM.png

  13. #13
    Adding Image to Photo
    pm-r's Avatar
    Member Since
    Oct 16, 2010
    Location
    Brentwood Bay, BC, Canada
    Posts
    10,255
    so I just clicked that box thinking to inactivate which it did and voila!!!! it resolved my problem...

    Well OK, and I learn something new every day, and I didn't know just clicking on such a greyed out option could change things. Whatever works!!!





    - Patrick
    ======

  14. #14
    Adding Image to Photo
    ferrarr's Avatar
    Member Since
    May 21, 2012
    Location
    Pawtucket, RI, US
    Posts
    5,350
    Your Mac's Specs
    L2014 Mac mini macOS Mojave, iPhone 8+ iOS 12, 12.9" iPad Pro 1 iOS 12, Pencil 1
    Quote Originally Posted by pm-r View Post
    Well OK, and I learn something new every day, and I didn't know just clicking on such a greyed out option could change things. Whatever works!!!





    - Patrick
    ======
    Patrick, the "old" MBP, had the "Use as System Photo library" greyed out, but the "new" MBP, had the "Use as System Photo library" was not greyed out.
    -- Bob --
    Please backup. Everything has a life cycle, unexpected and warning free. Nothing will last as long as you want it to.

  15. #15
    Adding Image to Photo
    pm-r's Avatar
    Member Since
    Oct 16, 2010
    Location
    Brentwood Bay, BC, Canada
    Posts
    10,255
    Quote Originally Posted by ferrarr View Post
    Patrick, the "old" MBP, had the "Use as System Photo library" greyed out, but the "new" MBP, had the "Use as System Photo library" was not greyed out.

    Just going on what I read that the OP said…
    .....in my 2011 MBP, that Box " Use As System Photo Library" opposite the "Show in Finder " box is greyed..... in my 2015 MBP, that Box "Use as System Photo Library" is Active ( not greyed?).. so I just clicked that box thinking to inactivate which it did and voila!!!! it resolved my problem...
    Maybe I got something mixed up… or not…





    - Patrick
    ======

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Adding hyperlink to jpg image?
    By karlrlilliendah in forum Images, Graphic Design, and Digital Photography
    Replies: 5
    Last Post: 12-06-2011, 08:20 PM
  2. IPad 2 no image in Photo app Photo Stream
    By MikeV99 in forum iPad Hardware and Accessories
    Replies: 1
    Last Post: 10-23-2011, 09:53 AM
  3. Adding image in imovie?
    By JH82 in forum Movies and Video
    Replies: 4
    Last Post: 11-14-2008, 08:34 PM
  4. Adding a link to an image?
    By Thorax_impales in forum Images, Graphic Design, and Digital Photography
    Replies: 7
    Last Post: 09-08-2007, 04:02 PM
  5. Adding a background image in iweb
    By jeffnewc in forum Web Design and Hosting
    Replies: 3
    Last Post: 12-11-2006, 06:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •