Please visit the new Mac-Forums Facebook page:
Join Us @ Mac-Forums Facebook Page



Results 1 to 4 of 4
  1. #1
    Why won't links to pages work??
    When my website publishes online...the links to the different pages will not work. They work when I test my website inside of iWeb, but not live.

    Any suggestions?

    I have already tried to re-publish it a few times incase their was a break. I am using a FTP to an outside hosting services and not mobile me.

    Help!

    www.WhiteBearDanceCenter.com is the website.

    Thanks for the help!

  2. #2
    dude the only real way to answer this is to see yr code.

    Have you checked your a tags...? I had a quick look with firebug and from what I can see you need to redo them. The home a tag doesnt actually have a link in it and the others have characters that may confuse.

    Have a look at writing css rollover menu. This will cut down your code quite a bit from what I can see

  3. #3
    chas_m
    Guest
    Most common error of this sort: you're linking to local files (or local addresses), which of course aren't going to work when uploaded. Another possibility: you're using spaces in page names. That's a no-no.

    Open one of your pages in Safari (or browser of choice) and switch to an HTML view and find the link to another page that's not working. Post that snippet of the HTML code here.

    In the meantime, try making links to the actual http address those pages WILL have, ie http://www.domainname.com/site/page2.html and see if that works.

  4. #4
    Why won't links to pages work??
    xstep's Avatar
    Member Since
    Jun 25, 2005
    Location
    On the road
    Posts
    3,231
    Your Mac's Specs
    2011 MBP, i7, 16GB RAM, MBP 2.16Ghz Core Duo, 2GB ram, Dual 867Mhz MDD, 1.75GB ram, ATI 9800 Pro vid
    Rep Power
    17
    I can tell you that there appear to be no href's on your pages. Also, you did upload all of your 4 pages.

    In iWeb, I'd click on one of the link titles and the info panel review if the link is set and turned on.
    CameraTime - Time lapse photography for novice and advanced users.

    When asking questions, post the version of your software. You'll receive better answers.

    Please post your results to the thread as it is good feedback.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 4
    Last Post: 09-25-2014, 05:35 PM
  2. Safari web pages won't load/work
    By Kennedy2084 in forum Apple Notebooks
    Replies: 0
    Last Post: 07-19-2014, 05:26 PM
  3. No Textbox links in Pages 5
    By RowleyBrooke in forum macOS - Apps and Games
    Replies: 3
    Last Post: 11-20-2013, 08:09 AM
  4. PAGES for MAC and PAGES for iOS How does this work?
    By Maxtcc in forum macOS - Apps and Games
    Replies: 21
    Last Post: 11-03-2011, 12:26 PM
  5. Safari not changing color for visited links on Google Search pages
    By LarryMcJ in forum macOS - Apps and Games
    Replies: 1
    Last Post: 04-26-2009, 04:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •