My wife's iMac is an old (2012) one and she still has High Sierra. It is less vulnerable than iPhones which, as you say, should always be updated if possible.