Did you select None for Safari in System Preferences > Notifications? Does Firefox show in System Preferences > Notifications?