I've been trying to print from a shared printer that is connected to a windows computer on my network; the same network as my mac.

The problem is I cannot get it to work through just windows printing. I have to go to the extra options, and print via Samba, using the computer's ip address. Now the problem is, the computer I'm sharing the printer from does not have a static ip (I don't think my ISP allows it) so every so often my printer will not work (the IP changes) so I have to go in and re-ad the printer again in the mac's system preferences. It's kind of irritating.

Now here's my problem. When I try to add the printer, instead under Windows Printing (the one you can get without holding down option), the workgroup "workgroup" comes up. I click on that, and I get another screen, showing my ibook's network sharing name, and something called Family, which is what I suspect is the workgroup or whatever of the windows machine (my father set it up, and I don't know what the whole thing is). The one thing I do know is that the computer is named "Our Family Computer" (don't ask). So I click on "Family", and it asks for a name and password. I've tried leaving both blank, I've tried users on the Windows machine (both with passwords and without), the network password for the router, and all I ever get is

"Unable to connect to server with the provided password and username
Error: 256

Does anyone have a solution to this problem? If you can't tell what I'm talking about, I can post some screens of the printer setup menus if it would help.

Thanks in advance, I'm really clueless about this one.