Please visit the new Mac-Forums Facebook page:

Results 1 to 3 of 3
  1. #1
    USB 3.0 Flash Drives won't mount; USB 2.0 Flash Drives mount fine
    I have USB flash drives, both USB 2.0 and USB 3.0 from various manufacturers - Kingston, Verbatim, Sony, Lexar, even no-name China ones; sizes from 256 MB (Yes MB's!) to 128 GB
    They all mount fine on a 2012 Mac Mini with USB 3.0 ports as expected.

    But on a 2017 MacBook air, none of the Verbatim 3.0 Flash Drives mount, however all the USB 2.0 Flash Drives from various manufacturers do mount withiut issues.
    That's true for all USB ports on that machine
    There is no indication or error message why the USB 3.0 drives don't mount; they also don't show up in Disk Utility.

    For a few weeks I worked around that by transferring files to a USB 2.0 drive and use that with the 2017 MacBook air, but yesterday I got fed up with that.
    Was ready to send the MacBook air back to Apple under Warranty assuming the USB 3.0 Flash drives must be fine since they mount on the 2012 Mini and the 2017 MacBook air USB ports are the problem.
    Read through a few articles on line which provided all sorts of possibilities why a USB flash drive would not mount.
    Eventually, one of them mentioned right at the end to try a SMC reset.

    Didn't really think that would do anything since the USB 2.0 drive mounted (just the USB 3.0 drives did not) and I would have thought if the SMC was the problem, none of the USB Flash drives would mount - but I was wrong!
    I reset the SMC and all the USB 3.0 flash drives mounted as if there had never been a problem.

    Just posting this in case anyone else has this type of problem.

  2. #2
    USB 3.0 Flash Drives won't mount; USB 2.0 Flash Drives mount fine
    dtravis7's Avatar
    Member Since
    Jan 04, 2005
    Modesto, Ca.
    Your Mac's Specs
    iMac late 2012 21.5 i5 10:14. iMac 2010 27"QuadI7 OS10.13, MBPLate2011, iPad Pro10.5", iPhone7
    Rep Power
    Thanks for sharing this. It might help someone else down the road.

  3. #3
    USB 3.0 Flash Drives won't mount; USB 2.0 Flash Drives mount fine
    IWT's Avatar
    Member Since
    Jan 23, 2009
    Born in Scotland, Worked in Scotland then England, Now live in Wales
    Your Mac's Specs
    Late 2015 5K 27-inch Retina iMac, 4GHz i7, 32GB RAM, 1TB Flash Drive, macOS High Sierra 10.13.6
    Rep Power
    Thanks for sharing this with us, krs. I've never encountered this problem before, but your solution may help others.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. USB drives won't mount unless I reboot.
    By kwahamot in forum macOS - Operating System
    Replies: 2
    Last Post: 08-28-2018, 04:28 PM
  2. OS X Lion will not read external hard drives and USB flash drives
    By tompam in forum macOS - Operating System
    Replies: 71
    Last Post: 04-21-2012, 01:16 AM
  3. USB drives won't mount
    By cowwart in forum Apple Notebooks
    Replies: 0
    Last Post: 01-01-2010, 05:08 PM
  4. Our Drives Wont Mount
    By onqdirector in forum Other Hardware and Peripherals
    Replies: 1
    Last Post: 02-21-2009, 04:04 PM
  5. Auto un-mount drives?
    By Ozone42 in forum macOS - Operating System
    Replies: 4
    Last Post: 06-05-2006, 10:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts