i have used these forums to solve lots of my technical questions over the years! and this is the first time i have had to post- hope someone can help me.

the problem.

i have a home network with imac running tiger connected directly to canon mp150 printer via usb, and a macbook. my macbook was running tiger initially and i had set up printer sharing- was easy and all worked well. the laptop on wifi "found" the printer after print sharing was turned on on my desktop and away i went.

however, since upgrading to leopard on my lap top (but not the desktop- memory issues) i can no longer print form my laptop. i have tried:
installing latest drivers on both machines
"reseting printers" in the printers control panel

whenever i open printers on the laptop i cannot see the "shared" printer. once, after resetting printing system i saw the printer as a bonjour printer and thought hallelujah! but after selecting it i got a cogwheel for a while and then it went away never to reappear?!

im desparate- have used macs for 20 years and can't believe that this is so hard to solve?
any suggestions?

thanks in advance,
your humble servant

george