Please visit the new Mac-Forums Facebook page:
https://www.facebook.com/macforums1




Results 1 to 11 of 11

Thread: Mac Update

  1. #1
    Mac Update
    hi....I have an iMac OSX 10.6.8 computer .....snow leopard has not updated for a while....im not very computer minded....whats the best way of updating

  2. #2
    safari doesnt update too

  3. #3
    Mac Update
    chscag's Avatar
    Member Since
    Jan 23, 2008
    Location
    Keller, Texas
    Posts
    58,862
    Your Mac's Specs
    2017 27" iMac, 10.5" iPad Pro, iPhone 7+, iPhone 8, Numerous iPods, Mojave
    Rep Power
    53
    Which Mac do you have? Year and model? (click on the Apple menu in the upper left corner and select "About This Mac")

    In order to update your version of OS X and Safari, you will need to do it through the Mac App Store. How far you can update depends on which Mac you have.

  4. #4
    Quote Originally Posted by chscag View Post
    Which Mac do you have? Year and model? (click on the Apple menu in the upper left corner and select "About This Mac")

    In order to update your version of OS X and Safari, you will need to do it through the Mac App Store. How far you can update depends on which Mac you have.
    thanks....

    safari 5.1.10


    Model Name: iMac
    Model Identifier: iMac8,1
    Processor Name: Intel Core 2 Duo
    Processor Speed: 2.8 GHz
    Number Of Processors: 1
    Total Number Of Cores: 2
    L2 Cache: 6 MB
    Memory: 4 GB
    Bus Speed: 1.07 GHz
    Boot ROM Version: IM81.00C1.B00
    SMC Version (system): 1.30f1

  5. #5
    Mac Update
    chscag's Avatar
    Member Since
    Jan 23, 2008
    Location
    Keller, Texas
    Posts
    58,862
    Your Mac's Specs
    2017 27" iMac, 10.5" iPad Pro, iPhone 7+, iPhone 8, Numerous iPods, Mojave
    Rep Power
    53
    According to Mactracker, you have a 2008 24" iMac. If that is correct, you can update to El Capitan (10.11.6). At the same time, Safari will be updated to the latest version. I also recommend that you add more memory to your iMac if you do decide to upgrade. Your iMac will take 6 GB of memory, which means you will need 1 x 4 GB + 1 x 2 GB = 6 GB. Your machine only has two memory slots.

  6. #6
    Yes it is a 24" imac.....have you got a link to download this?
    Do I have backup anything?

  7. #7
    According to Wikipedia it can be run if you can't do it if you have previously used snow leopard ?

  8. #8
    Mac Update
    chscag's Avatar
    Member Since
    Jan 23, 2008
    Location
    Keller, Texas
    Posts
    58,862
    Your Mac's Specs
    2017 27" iMac, 10.5" iPad Pro, iPhone 7+, iPhone 8, Numerous iPods, Mojave
    Rep Power
    53
    You don't need a link. You have the Mac App Store application and direct link already on your machine. (Apple Menu, App Store.) And yes, it's very important that you make a backup before doing any upgrading.

    Also, you need to understand that Snow Leopard (10.6.8) which you are currently using is the last version of OS X that can run Power PC applications. If you have any old applications that are PPC, they will not run on any version of OS X later than Snow Leopard. And, you my have older versions of other software and printer drivers that may not work with El Capitan. What we are saying is do your homework first before upgrading otherwise you may have lots of difficulty later on.

  9. #9
    Sorry....i meant, it can't be used on snow leopard computers?

  10. #10
    Ok. .. thanks for your help

  11. #11
    Mac Update
    harryb2448's Avatar
    Member Since
    Nov 28, 2007
    Location
    Nambucca Heads Australia
    Posts
    25,222
    Your Mac's Specs
    iMac, i7 4GHz, 32GB memory, 1TB Blade, macOS Catalina,
    Rep Power
    31
    I take it you are referring to the latest version of Safari?

    If so, the version of Safari is tied to your operating system. A later version of Safari equals updating the iMac. OS X.11 which is available at the App Store, has the latest Safari version and that is the only way to get it. You will need an Apple ID, not your login password, but your email and a password. Have a read of this link if you do not have an Apple ID:-


    https://appleid.apple.com/account#!&page=create
    Using OS X.7 or later make a bootable USB thumb drive before running Installer!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Software Update: Java for Mac OS X 10.6 Update 5, Mac OS X 10.5 Update 10
    By OneMoreThing... in forum Apple Rumors and Reports
    Replies: 0
    Last Post: 06-28-2011, 06:55 PM
  2. Apple releases Mac OS X update to catch MAC Defender malware
    By OneMoreThing... in forum Apple Rumors and Reports
    Replies: 7
    Last Post: 05-31-2011, 09:12 PM
  3. This update requires MAC OS X 10.4.10 or higher / MAC OS X Tiger Only
    By newtomacsneal in forum Running Windows (or anything else) on your Mac
    Replies: 7
    Last Post: 06-21-2009, 11:09 AM
  4. This update requires MAC OS X 10.4.10 or higher / MAC OS X Tiger Only
    By newtomacsneal in forum macOS - Operating System
    Replies: 2
    Last Post: 06-21-2009, 05:15 AM
  5. This update requires the Mac OS X Networking Update???
    By HeyImJ0 in forum iPod Hardware and Accessories
    Replies: 1
    Last Post: 12-31-2005, 07:06 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •