Please visit the new Mac-Forums Facebook page:
Join Us @ Mac-Forums Facebook Page



Page 1 of 3 123 LastLast
Results 1 to 15 of 36
  1. #1
    Images not loading on certain websites

    Member Since
    Nov 18, 2016
    Location
    845 NY
    Posts
    16
    Rep Power
    4
    Images not loading on certain websites
    I am having a problem with certain websites with images loading. The only thing that will show up is a blue question mark. This recently started happening, and was never a problem before. Ive tried fixing it but nothing has worked. Can someone please point me in the right direction. Here is a picture of what is happening. I am running the latest OS Sierra 10.12.1. Thanks in advance to anyone who can help.


    IMG_5372.JPG
    Last edited by MikeWRX90; 11-18-2016 at 03:36 AM.

  2. #2
    MacInWin
    Guest
    Welcome to the forum.

    That symbol means the link in the website to the picture didn't work. It could be because the picture isn't there anymore, or it could be that the link is bad. You can try reloading the page, but if the icon remains, there's not much you can do. Are you using any blockers (adblocker, tracker blockers, etc)?

  3. #3
    Images not loading on certain websites

    Member Since
    Nov 18, 2016
    Location
    845 NY
    Posts
    16
    Rep Power
    4
    Quote Originally Posted by MacInWin View Post
    Welcome to the forum.

    That symbol means the link in the website to the picture didn't work. It could be because the picture isn't there anymore, or it could be that the link is bad. You can try reloading the page, but if the icon remains, there's not much you can do. Are you using any blockers (adblocker, tracker blockers, etc)?
    I could see that would be the case but, the website works on my guest account which i find quite weird, and it works on my iPad/iphone. As for the the ad blockers, no i am not using any of that. One of the particular websites i am talking about is a very common site i would visit in the past, and always worked until one day it didn't, and hasn't since. Thanks for your response BTW!

  4. #4
    MacInWin
    Guest
    Clear out your browser cache and history and reload the page.

  5. #5
    Images not loading on certain websites

    Member Since
    Nov 18, 2016
    Location
    845 NY
    Posts
    16
    Rep Power
    4
    Quote Originally Posted by MacInWin View Post
    Clear out your browser cache and history and reload the page.
    Already tried that. And actually i recently cleared my cache for the first time in a while and thats when this problem started.

  6. #6
    Images not loading on certain websites
    Rod's Avatar
    Member Since
    Jun 12, 2011
    Location
    Melbourne, Australia and Ubud, Bali, Indonesia
    Posts
    5,487
    Your Mac's Specs
    2015 MacBook Pro Retina 13" macOSX 10.15.1
    Rep Power
    14
    Are you going to this site from a bookmark? If so try searching for the site with Google or whatever and try to open it from the search results. You may have lost vital site data when you cleared the cache.
    I used to be conceited but now I'm perfect.

  7. #7
    Images not loading on certain websites

    Member Since
    Nov 18, 2016
    Location
    845 NY
    Posts
    16
    Rep Power
    4
    Quote Originally Posted by Rod Sprague View Post
    Are you going to this site from a bookmark? If so try searching for the site with Google or whatever and try to open it from the search results. You may have lost vital site data when you cleared the cache.
    Nope, not using the site from a bookmark. Always just typed it in. Tried doing what you said with searching the site on Google and going to the website, but still getting same results.

  8. #8
    Images not loading on certain websites

    Member Since
    Nov 18, 2016
    Location
    845 NY
    Posts
    16
    Rep Power
    4
    Anyone???

  9. #9
    Images not loading on certain websites
    chscag's Avatar
    Member Since
    Jan 23, 2008
    Location
    Keller, Texas
    Posts
    59,061
    Your Mac's Specs
    2017 27" iMac, 10.5" iPad Pro, iPhone 7+, iPhone 8, Numerous iPods, Mojave
    Rep Power
    53
    I could see that would be the case but, the website works on my guest account which i find quite weird, and it works on my iPad/iphone. As for the the ad blockers, no i am not using any of that. One of the particular websites i am talking about is a very common site i would visit in the past, and always worked until one day it didn't, and hasn't since.
    If you can load the images with your guest account and from your iPad/iPhone, then it has to be something you have recently installed that's blocking the images. You might not even be aware that you installed something. Either that, or your regular admin account has become corrupt. I would tend to think it's something that may have been inadvertantly installed that's the culprit. Now it's up to you to hunt it down.

  10. #10
    Images not loading on certain websites
    Rod's Avatar
    Member Since
    Jun 12, 2011
    Location
    Melbourne, Australia and Ubud, Bali, Indonesia
    Posts
    5,487
    Your Mac's Specs
    2015 MacBook Pro Retina 13" macOSX 10.15.1
    Rep Power
    14
    Yes it's hard to imagine that something hasn't changed. After all the site works on your other devices so it's not a network thing or a site problem. As a last resort I would try a different browser. I'm assuming you are using the native Safari (you have not said) on all devices but iOS Safari is not the same beast as the version on your laptop. Try downloading another popular browser such as Firefox or Chrome and try again, both are very good at rendering web images. It's not a bad idea to have another browser as a backup anyway, I have three other browsers.
    I used to be conceited but now I'm perfect.

  11. #11
    Images not loading on certain websites

    Member Since
    Nov 18, 2016
    Location
    845 NY
    Posts
    16
    Rep Power
    4
    Quote Originally Posted by Rod Sprague View Post
    Yes it's hard to imagine that something hasn't changed. After all the site works on your other devices so it's not a network thing or a site problem. As a last resort I would try a different browser. I'm assuming you are using the native Safari (you have not said) on all devices but iOS Safari is not the same beast as the version on your laptop. Try downloading another popular browser such as Firefox or Chrome and try again, both are very good at rendering web images. It's not a bad idea to have another browser as a backup anyway, I have three other browsers.
    The site works with Firefox. Safari is the problem. Is there a way to restore Safari to factory settings and or delete and re download it?

  12. #12
    Images not loading on certain websites
    Rod's Avatar
    Member Since
    Jun 12, 2011
    Location
    Melbourne, Australia and Ubud, Bali, Indonesia
    Posts
    5,487
    Your Mac's Specs
    2015 MacBook Pro Retina 13" macOSX 10.15.1
    Rep Power
    14
    OK so that certainly narrows down the possible causes.
    There is no way that I know to remove and reinstall a native app like Safari.
    The best you could do would be to completely erase all Extensions and History, as annoying as that is. It's also worth running Malwarebytes in case you have picked something up. You might also like to try disabling plugins. In Preferences>Security>Click Plugin Settings next to Allow Plugins. If you see Adobe Flash Player turn that off by unselecting the box. If you have any others let us know.
    Restart and try again.
    I used to be conceited but now I'm perfect.

  13. #13
    Images not loading on certain websites
    ferrarr's Avatar
    Member Since
    May 21, 2012
    Location
    Pawtucket, RI, US
    Posts
    6,963
    Your Mac's Specs
    L2014 Mac mini macOS 15, iPhone 8+ iOS 13, 12.9" iPad Pro 1 iPadOS 13,  Pencil 1
    Rep Power
    14
    Quit Safari, and hold "shift" when starting Safari. I also found this, https://support.apple.com/en-us/HT204098, not sure if it was mentioned already.
    -- Bob --
    Please backup. Everything has a life cycle, unexpected and warning free. Nothing will last as long as you want it to.

  14. #14
    Images not loading on certain websites

    Member Since
    Nov 18, 2016
    Location
    845 NY
    Posts
    16
    Rep Power
    4
    Quote Originally Posted by Rod Sprague View Post
    OK so that certainly narrows down the possible causes.
    There is no way that I know to remove and reinstall a native app like Safari.
    The best you could do would be to completely erase all Extensions and History, as annoying as that is. It's also worth running Malwarebytes in case you have picked something up. You might also like to try disabling plugins. In Preferences>Security>Click Plugin Settings next to Allow Plugins. If you see Adobe Flash Player turn that off by unselecting the box. If you have any others let us know.
    Restart and try again.
    Ran Malwarebytes and it found nothing. The only plugins that are in that menu is Divx web player and nothing else. The box is un checked.

    Quote Originally Posted by ferrarr View Post
    Quit Safari, and hold "shift" when starting Safari. I also found this, https://support.apple.com/en-us/HT204098, not sure if it was mentioned already.
    Just tried that, and nothing happened when holding shift. Also deleted all website data for that specific website like the link you posted suggested, and restarted Safari and the problem still persists. I am stumped lol.

  15. #15
    Images not loading on certain websites
    Rod's Avatar
    Member Since
    Jun 12, 2011
    Location
    Melbourne, Australia and Ubud, Bali, Indonesia
    Posts
    5,487
    Your Mac's Specs
    2015 MacBook Pro Retina 13" macOSX 10.15.1
    Rep Power
    14
    It is just possible that it is due to not having a specific plugin. Honestly I stopped using Safari a long time ago, I revisit it at each new OS upgrade but I just don't like it. This is purely a personal thing but with so many other browsers out there it's pretty easy to change. Opera, Chrome and Firefox to mention a few. I choose not to use Chrome these days because of the tracking it does but that can be overcome with a different search engines like DuckDuck Go and or a tracker blocking extension like Ghostery.
    Is this the only site that you are having display problems with?
    I used to be conceited but now I'm perfect.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. trouble loading some websites
    By m_k_o in forum Switcher Hangout
    Replies: 2
    Last Post: 06-03-2012, 01:47 AM
  2. Slow or not loading certain websites
    By BevS in forum Internet, Networking, and Wireless
    Replies: 0
    Last Post: 05-30-2012, 11:46 AM
  3. Certain websites not loading
    By Subajew in forum macOS - Operating System
    Replies: 6
    Last Post: 08-09-2009, 08:01 PM
  4. websites not loading
    By essentialfun in forum Switcher Hangout
    Replies: 2
    Last Post: 02-08-2009, 03:28 AM
  5. Problems loading certain websites
    By yesteryear in forum macOS - Operating System
    Replies: 11
    Last Post: 08-16-2008, 09:00 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •