Results 1 to 7 of 7

Thread: Mavericks trash

  1. #1
    Mavericks trash
    Since updateing my MacBook Pro to Mavericks everything I delete bypasses the trash bin and just deletes. Is there any way to fix this so that deleted items go to the trash bin until it is emptied?
    Thanks.

  2. #2
    Mavericks trash
    McBie's Avatar
    Member Since
    Apr 26, 2008
    Location
    Belgium
    Posts
    2,955
    Your Mac's Specs
    iPad Pro 12.9 latest iOS
    Rep Power
    15
    Are you deleting files from removable media or from your internal hard disk ?

    Cheers ... McBie
    A computer lets you make more mistakes faster than any invention in human history - with the possible exceptions of handguns and tequila.
    The bitterness of poor quality remains long after the sweetness of low price is forgotten.

  3. #3
    Mavericks trash
    McYukon's Avatar
    Member Since
    May 14, 2009
    Location
    Near Whitehorse, Yukon
    Posts
    2,052
    Your Mac's Specs
    2012 MBP i7 2.7 GHz 15" Matte - 16 GB RAM - 120 GB Intel SSD - 500 GB DataDoubler Mac OS 10.9
    Rep Power
    13
    If your deleting from the internal HDD and it's acting that way it sounds like your permissions are messed up on the Trash folder.
    In the Finder hit command+shift+g and enter .Trash
    Then hit command+i and make sure you have read/write permissions and everybody else has No Access.


    And if that doesn't fix it, use this command in Terminal and reboot your Mac after.
    Code:
    sudo rm -rf ~/.Trash
    Use the reputation system if a post helps you!
    Mac Forums IRC Channel - Help build it by hanging out with us
    The next sentence is true. The previous sentence is false.

  4. #4
    I'm deleting from the internal Mac HD. I ran repair permissions but that didn't help. When I follow the suggested command+shift+g and enter .Trash the finder can't locate the trash folder, but it's there in the dock. I'll try the Terminal command suggestion after my backup to an external drive completes.

  5. #5
    Updated command
    In Mavericks, Apple has changed the hidden to just filename Trash so the command would be

    sudo rm -rf ~/Trash


    And it does fix the issue, at least for me. Thanks!

  6. #6
    Found hidden Trash file, changed permissions. Problem solved. Thanks to all for the help.

  7. #7
    Mavericks trash
    vansmith's Avatar
    Member Since
    Oct 19, 2008
    Location
    Toronto
    Posts
    19,853
    Your Mac's Specs
    Early 2015 13" rMBP
    Rep Power
    31
    Quote Originally Posted by jniford View Post
    In Mavericks, Apple has changed the hidden to just filename Trash so the command would be

    sudo rm -rf ~/Trash


    And it does fix the issue, at least for me. Thanks!
    No, the Trash folder is still called .Trash and is consequently a hidden folder. If you have a folder called Trash, it's not the system one but one that was generated by an application or you.
    Important Links: Community Guidelines : Use the reputation system if you've been helped.
    M-F Blog :: Write for the blog
    Writing a Quality Post

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. unable to empty trash - OSx Mavericks
    By Homelyn in forum macOS - Operating System
    Replies: 3
    Last Post: 05-25-2015, 02:01 PM
  2. mavericks delay when moving file to trash ...
    By macgig in forum macOS - Operating System
    Replies: 6
    Last Post: 02-07-2014, 11:00 PM
  3. Replies: 4
    Last Post: 04-21-2013, 08:11 AM
  4. Trash problems: Files disappear after moving to trash
    By pimsche in forum macOS - Operating System
    Replies: 10
    Last Post: 08-31-2012, 11:57 AM
  5. Trash problem: Can't see deleted files in Trash
    By Anil_robo in forum macOS - Operating System
    Replies: 0
    Last Post: 08-27-2006, 05:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •