Please visit the new Mac-Forums Facebook page:
Join Us @ Mac-Forums Facebook Page

Results 1 to 3 of 3
  1. #1
    Can't mount 3TB Hard Drive
    Hey everyone, I'm having some issues with a 3TB drive. So this drive was part of a WD myBook and recently it just stopped mounting. I took the drive out of the enclosure figuring there might be a problem with the SATA to USB hub. Well I was wrong on that account. I can see the drive in Disk Utility without any partitions and the info on it says 0 Bytes. I'm really thinking its a partition table issue, it's formatted in Mac OS Journaled. I've bought several different data recovery tools and tried them all without success (Data Rescue 3, test disk, DiskWarrior, Drive Genius, Stellar Phenix) . I've been searching for days and finally broke down and had to put the question on here. TestDisk recognizes that the "partition" is too small 512 MiB, which if memory serves me is the Partition table. But for some reason it tells me it cannot fix it.

    Anyway, any ideas or help would be appreciated. Thanks,


  2. #2
    Can't mount 3TB Hard Drive
    chscag's Avatar
    Member Since
    Jan 23, 2008
    Keller, Texas
    Your Mac's Specs
    2017 27" iMac, 10.5" iPad Pro, iPhone 7+, iPhone 8, Numerous iPods, Mojave
    Rep Power
    I've bought several different data recovery tools and tried them all without success (Data Rescue 3, test disk, DiskWarrior, Drive Genius, Stellar Phenix) .
    With the money you spent on those programs you could have bought a new 3 TB hard drive. I'm assuming the real problem here is that you have valuable data on the drive that you need to recover?

    This article says to use Testdisk to do the repairs which I gather from your post you already tried. I have to say if Testdisk can't repair the partition table to recover your data, you may have to resort to a data recovery service.

    There are several articles floating around which purport to using a Linux (Ubuntu) GPT utility to repair the partition table, however, I have not tried it so can not say if it works or not.

  3. #3
    CHSCAG, thanks for the reply. Yes I have about 20,000 photos and 9 languages of Rosetta Stone on this drive. The Rosetta Stone isn't a huge deal because I can use the CD, I just have to find it but the photos are from the last 10 years. I'll have to take another look at Testdisk because the original article wasn't very helpful. I have not used Ubuntu yet so maybe I'll throw that on a VM and give it a try. Thanks again for the reply.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: 06-20-2015, 03:34 AM
  2. Please help, hard drive won't mount.
    By DorkFromOrk in forum Apple Desktops
    Replies: 1
    Last Post: 10-11-2011, 04:28 PM
  3. Seagate confirms Mac support for 3TB hard drive
    By the8thark in forum Apple Rumors and Reports
    Replies: 3
    Last Post: 05-21-2010, 02:05 PM
  4. Can't get the external hard drive to Mount
    By plmiller0905 in forum Apple Notebooks
    Replies: 3
    Last Post: 06-29-2009, 04:24 PM
  5. hard drive won't mount!!!!!
    By sadida31 in forum Other Hardware and Peripherals
    Replies: 3
    Last Post: 03-06-2006, 11:04 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts