Page 1 of 2 12 LastLast
Results 1 to 15 of 18
  1. #1
    OS hangs on blue screen just before login
    Hi everyone,

    I am using a macbook (early 2008 version) running OS 10.5.8 on a journalled hard drive. Since yesterday it has been hanging on the blue screen just before the login box pops up.

    The full details are:

    I was trying to set up sharing so I could transfer files from my Windows machine to my mac, so I went into the share settings and noticed the 'file sharing' option was already enabled with afp, so I disabled afp and enabled smb instead for my user profile. When the sharing didn't work (unrelated issue, I now know that I was just typing the address into my Windows machine in the wrong format) I disabled smb but didn't re-enable afp, so that all file sharing was completely disabled.

    When I'd done that, I clicked on the 'lock' button in the system preferences - for no apparent reason, it's not like anyone else uses my computer. Later on once I'd found what I'd done with sharing, I went back to the settings to change them and clicked to unlock them but it wouldn't do anything - normally it pops up a password box but it wasn't doing anything. I tried a couple of other system preference windows with the same problem.

    So using my knowledge from watching 'The IT Crowd' I went for the usual approach of "have you tried turning it off and on again?" and that's when it got stuck on booting.

    Now if I try to boot it up I can't get to the log-in screen, it sticks on the blue screen just before that. I've tried all the help suggested on the Apple website Resolve startup issues and perform disk maintenance with Disk Utility and fsck and it hasn't helped:

    • I can't get into safe mode
    • If I boot from the Mac OS X cd then I can use disk utilities; 'repair disk' said it found no problems, 'repair permissions' said underlying disk reported failure and it couldn't finish
    • The Apple article for that error Disk Utility reports "Underlying task reported failure" when repairing a volume says to use fsck in single user mode, which I have tried
    • The first time I run /sbin/fsck -fy it says some errors have been repaired, so I run it again and it says no errors found, but when I reboot it still doesn't work
    • If I go and repeat the fsck command then it still finds errors the next time

    I don't have another mac so I can't access the disk any other way to get my data and unfortunately I don't have a backup because my external hard drive is formatted for Windows compatibility...

    I have looked at the system log using
    more /var/log/system.log

    and I have found this error:
    my-macbook mds[21]: (Error) Import: importer:0x83dc00 Importer start failed for 89 (kr:268435459 (ipc/send) invalid destination port)
    my-macbook /System/Library/CoreServices/[158]: Login Window Application Started -- Threaded auth
    my-macbook loginwindow[158]: Login Window Started Security Agent
    my-macbook loginwindow[158]: Login Window - Returned from Security Agent
    my-macbook loginwindow[158]: AuthorizationRef doesn't have a username (LoginAuthRefMgr: 0x5305b0). Exiting.
    my-macbook[158]: AuthorisationRef doesn't have a username (LoginAuthRefMgr: 0x5305b0). Exiting.
    my-macbook[1] ( respawn: Will start in 10 seconds
    my-macbook[1] ([162]): Exited: Terminated
    my-macbook ManagedClient[164]: CGSShutdownServerConnections: Detaching application from window server
    my-macbook[1] ([167]): posix_spawnp("usr/sbin/mDNSResponder", ...): No such file or directory
    my-macbook[1] ([167]): Exited with exit code: 1
    my-macbook[1] ( Throttling respawn: Will start in 10 seconds
    my-macbook[1] ([168]): posix_spawnp("/System/Library/PrivateFrameworks/MobileDevice.framework/Versions/A/Resources/usbmuxd", ...): No such file or directory
    my-macbook[1] ([168]): Exited with exit code: 1
    my-macbook[1] ( Throttling respawn: Will start in 10 seconds

    So then I started up in Single-User mode and ran

    /sbin/fsck -fy

    twice until I got a message 'The volume <yourdiskname> appears to be OK'. Then continued with

    /sbin/mount -uw /
    cd /Library/Preferences
    cd /Library/Caches
    rm -r *
    cd /System/Library
    rm Extensions.kextcache
    cd /System/Library/Caches
    rm -r *

    Unfortunately this STILL hasn't fixed the problem and now I'm completely out of ideas. Can anyone help?!

  2. #2
    Unhappy Small world, big problems
    Omg, I'm having the EXACT same problems! Only, I'm on a macbook pro OSX (I'm not sure which version).

    Did you figure out how to fix it? I'm really trying to find a way to fix it without having to wipe it, as I haven't backed up my files and I have some important school stuff that I would really like to keep.

    I tried to use the CD to fix it, but, like you, it said there was a problem with the volume.

    Did you ever figure out how to fix it? Or did you have to wipe it?

  3. #3
    I had the same problem and I found the answer from the below link
    Apple - Support - Discussions - Boot failure looking for mDNSResponder ...
    Extract from the link:
    "As far as I can tell (I will test further) it was caused by sharing the boot volume via Server Admin and then removing read access for 'everyone' (within Server Admin). In my opinion this is a serious bug - Server Admin settings should never be able to inhibit booting - preferably file sharing controlled by Server Admin should be totally independent of any local conventional OS X file sharing, or is this too much to expect?

    Others finding this may be interested in my investigations and solution below:

    OS X will not boot if the boot volume lacks read access for 'everyone'.

    My investigations show that this can be caused by:

    Tiger - Terminal (sudo chmod 770 /) - G4 with OS X 10.4.11

    Leopard - Terminal (sudo chmod 770 /) and Finder Get Info - G4 with OS X 10.5.8

    Snow Leopard Server - Disabling 'everyone' access to boot volume in Server Admin (bug?) - Xserve with OS X Server 10.6.2

    Symptoms: Boot failure with indefinite (sometimes intermittent) spinning gear. This step is unnecessary but it provides another symptom of this issue - boot in Verbose Mode (cmd v at start-up) and look for the following repeated every few seconds; 'posix_spawnp("/usr/bin/mDNSResponder", ...): No such file or directory'.

    To confirm that the cause is incorrect boot volume permissions start in Single User Mode (cmd s at start-up). Wait until all activity subsides and type:

    ls -ld /

    followed by the return key.

    Correct permissions are: drwxrwxr-t

    The eighth character is critical. If it is not an r you can correct it as follows:


    /sbin/mount -uw /

    followed by the return key.


    chmod 1775 /

    followed by the return key.



    followed by the return key.

    Hopefully your Mac will now be OK and booting correctly. "

    Hope it helps you, guys.

  4. #4
    I have no idea who you are j_forever, but I think I love you!

    I've been sweating ALL day trying to solve this self same issue and your walkthrough cracked it in two minutes flat, thank you!

    You rock!

  5. #5
    Thank you
    J. I had the same problem as described above and shorted with your advice.

    You saved me from a lot of trouble. Thanks a lot! - much appriciated


  6. #6
    Yes, Thanks j_forever!!! It worked for me too.

  7. #7
    You should be working for Apple! Seriously, with over three decades of experience with various flavours of *NIX (back to PWB) I never imagined for a moment that sharing settings would reset the mode of the system root directory. Don't know how you figured it out but you saved me big time! Now I can again login to my system. Kudos!

  8. #8
    Smile Yes, Thanks!
    A year later this advice helped me also! Same issue, I changed some file sharing permissions by removing "Adminstrators" from the user list for the primary boot drive. What a crazy problem, I thought I was just being more secure!

  9. #9
    just registered to thank you j_forever you are my hero,
    i did the sharing thing to bork my system and fixed it by resetting / permissions to 1755

  10. #10
    True God-Send, Thanks
    I was getting Blue Screen and long stalls and did'nt even realized I caused the problem.

    I had just change "Everyone" from ReadOnly to none.

    Your instructions were scary, but if followed to the letter worked perfectly.

    Thank you very much.

  11. #11
    This is the best piece of information online. Bloody brilliant! I even registered here just to be able to thank you for this very useful piece of information. so, Thank you!

  12. #12
    Keyboard issue
    I believe I'm having the same issue but I have a partially working keyboard on my MacBook. Without an 'enter' key how can I apply this fix? Would an external keyboard work in safe mode?

  13. #13
    j_forever.........U DA BEST!
    I've been working on my iMac for the last two days and couldn't find one single solution to my problem. I was already thinking of getting a new one......maybe a Christmas gift to myself? Well.....that of course, until I ran into this forum. j_forever's reply on this thread is the ONLY one that saved my computer from being put to rest forever. The steps probably lasted less than five minutes. So I bow to you J_FOREVER and I thank you for your help! You are my iMac god!

  14. #14
    thanks , you are a star , got my daughters apple going again wow .
    I bow to your wisdom J_FOREVER .

  15. #15
    thank you. You saved me from the unthinkable... unnecessarily reformatting my hard drive.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. eMac won't startup, hangs at blue screen (with white Mac OS X box )
    By cyclobill in forum macOS - Operating System
    Replies: 2
    Last Post: 09-19-2011, 06:32 PM
  2. iMac hangs at blue screen on shutdown or restart
    By Hicksville in forum macOS - Operating System
    Replies: 1
    Last Post: 06-18-2011, 09:10 AM
  3. Startup Hangs on Blue Screen, Won't Proceed to Desktop
    By mirrordrive in forum macOS - Operating System
    Replies: 0
    Last Post: 04-27-2011, 02:05 PM
  4. Replies: 1
    Last Post: 01-16-2011, 11:17 PM
  5. Mac OSX Hangs at blue screen and get message Spotlight quit
    By Artmuzz in forum macOS - Operating System
    Replies: 3
    Last Post: 06-12-2009, 05:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts