Attention: Please checkout the new Mac-Forums Facebook page.

Additional details in the "News & Community Announcements" thread.

Results 1 to 5 of 5
  1. #1
    Exclamation Qt application for mac not being launched
    I am working on an application written in Qt for macOS environment. In order to generate release build i have set up external server.

    I am seeing this:

    After generating build, if I download and install the application on Applications folder, when opening it, first I see the popup asking if I am sure to open app downloaded from Internet(Gatekeeper), so I click Open and then app dies.

    App works fine if I open it from CommandLine in Terminal.

    Checking the attributes of app file I can see that it has If remove it manually, using xattr -dr application opens without any problem

    Any ideas about why it is not launched ?? Thanks is advance

  2. #2
    Once the apps launches with the warning and dies, can you go to System Preferences->Security & Privacy and see an option to "Open Anyway" the app? Also you should check to see what setting you have for Allow Apps Downloaded from.

    Apple has been pushing people to use App Store and identified developers, but some apps require you to say Anywhere since some app developers don't have to be identified (usually means paying Apple some money).

    Depending on how you intend to eventually distribute your app, you should figure out how you want to "sign" it now so that people with the more restrictive options can actually use your app.

  3. #3
    Application is signed. I have verified using codesign and spctl tools that signature is correct.
    Also I tried to disable Gatekeeper using this command spctl --master-disable but still when I run the application for first time I see the popup and after clicking on Open application dies.
    Remark: Application only dies first time I try to open it, only when I see the popup. Then it opens without any problem

  4. #4
    I can't help you why the app fails to launch the first time and works the second time. Perhaps you can look at the Console for any logs that might help. While disabling Gatekeeper to debug the issue is OK, you should ensure that your app works with those restrictions in place. I, for one, definitely run with that enabled and pretty restrictive settings for security.

  5. #5
    Do you know how to look for gatekeeper logs in console?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. iPad Pro Launched
    By pigoo3 in forum iPad Hardware and Accessories
    Replies: 19
    Last Post: 12-18-2015, 01:34 PM
  2. When 4S will be launched at HK?
    By Slowli in forum macOS - Operating System
    Replies: 2
    Last Post: 10-18-2011, 10:45 PM
  3. Centrino 2 launched.
    By cowasaki in forum Apple Rumors and Reports
    Replies: 2
    Last Post: 07-15-2008, 12:26 PM
  4. Mac OS X Archive Launched!!!
    By Ghostshadow in forum Web Design and Hosting
    Replies: 2
    Last Post: 08-24-2006, 01:26 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts