Results 1 to 6 of 6
  1. #1
    xcode update not fully recognised
    My Mac was running Xcode 8.2 Build 8c38
    I needed to upgrade the ios SDK to 11.0 which needed Xcode 9.0 or later
    In order to install Xcode 9, I needed to upgrade from El Capitan to High Sierra
    I did that. I am now running High Sierra v 10.13.6
    I downloaded, unzipped and installed Xcode 9
    If I run up Xcode, it reports v9.4.1 (9F2000)
    However, if I enter xcodebuild - version in a terminal, it still reports 8.2 and
    my Xamarin IOS project is still using iOS 10.2 SDK from Xcode 8
    How come the mac is confused about which version of Xcode is installed and how
    do i get it to recognise that Xcode 9.4.1 is installed?


  2. #2
    You don't unzip Xcode. Rather you install it from the App Store. The latest version is 10.0 (10A255) and have you run xcode-select to get the command line tools installed?

  3. #3
    Thanks for the reply

    Well, when I say unzip, I downloaded Xcode_9.4.1.xip (can't even recall from where now) and opened the archive. I ended up with an instance of Xcode 9.4.1 but not one which seemed to be recognised.
    I didn't run installing it now
    I am also currently updating Xcode to 10 from the AppStore to see if that is better

  4. #4
    You definitely should not be downloading these apps from random places, only from the app store.

  5. #5
    Understood - my recollection is that I got the Xcode_9.4.1.xip from an Apple site but no matter, installing the Xcode 10 upate from the AppStore has worked.
    Thanks for your input.

  6. #6
    Excellent, glad you are back in business!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: 04-23-2016, 08:01 AM
  2. Xcode stopped letting me run Xcode app on iPad
    By ildsarria in forum iOS Development
    Replies: 1
    Last Post: 11-09-2011, 04:15 PM
  3. Xcode 4 Update
    By Adz_Rox in forum macOS - Apps and Games
    Replies: 0
    Last Post: 04-29-2011, 10:42 PM
  4. How to update latex packages in Xcode?
    By ypsd in forum macOS - Development and Darwin
    Replies: 1
    Last Post: 09-25-2010, 07:07 PM
  5. CD/DVD not recognised on Vista, recognised on Mac
    By Joel_i in forum Running Windows (or anything else) on your Mac
    Replies: 2
    Last Post: 01-24-2009, 04:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts