Attention: Please checkout the new Mac-Forums Facebook page.

https://www.facebook.com/macforums1

Additional details in the "News & Community Announcements" thread.



Page 1 of 2 12 LastLast
Results 1 to 15 of 16
  1. #1
    Exclamation "Flash" has suddenly disappeared - unable to reinstall!
    Dear Forum,

    I am using a iBook G4 for almost 2 years and it is the first time that I experience a somewhat strange problem...

    For no apparent reason at all (i.e. I haven't done anything that I am aware of!!!) flash player appears to have disappeared enabling me to visit many features of a page and indeed many sites altogether!

    Almost naturally, my mac has identified this error and issues following information which I acknowledge and follow up. Please see sequence of events which unfortunately still don't solve the problem after multiple attempts:

    1. Message: "Additional plugins are required to display all the media on this page" - Install missing plugins
    2. Window: Available plugin downloads - Adobe flash player is stated
    3. I agree license agreement and start to install (process starts)
    4. Conclusion screen: "no plugins were installed"
    5. Manual install opens following page:
    http://www.adobe.com/shockwave/downl...ShockwaveFlash
    6. I download the PowerPC based flash player version
    7. When prompted to install flash player, it is announced that i need a shockwave also from the same site
    8. downloading and installing shockwave appears to be successful (confirmed)
    9. after repeating steps 5. to 7., nothing is solved.

    I tried to place/drag it all into Applications and all that, nothing works :-(
    Please can anyone help me out to get flash back on the computer???
    What could have possibly happened that it disappeared????

    Any comments are welcome.

    Thanks, Mcman

  2. #2
    Please can anybody share a light on my problem? Any help would be appreciated... also, if I have posted my query into the wrong forum, please can you advise me where to get help on this matter...

    Thanks in advance, Mcman.

  3. #3
    MacHeadCase
    Guest
    Well for one thing we need a bit more info.

    What OS X version are you using? Not for instance OS X Tiger but 10.4.6.

    What have you done for troubleshooting on your own so far?

    When did this disappearing act happen? After a software install? After a change in your user account? After adding a new peripheral?

    Did you try creating a new user account to see if Flash is in that account?

  4. #4
    Hi MacHeadCase,

    Thanks for getting back to me.

    I am using OSX 10.4.10
    For troubleshooting, I didn't know what else to do other than to repeat the installation process highlighted in my thread.
    I tried to find an alternative website/download provider of flash, but the link stated appears to be the only link which my computer gets referred to when the error message appears.
    I really don't know what I did to trigger this situation. Very remotely, I can remember that it happened shortly after my Yahoo mail account became upgraded to some sort of "beta" account... Then again, iTunes performed an upgrade also roundabout the same time... however, under oath, I couldn't be certain by all means....
    I have not changed my user account (wouldn't know how to do it anyway) and haven't added any peripherals either.
    You see, I am very basic in terms of computers as my mac has always done anything for me so far....

    Hope this helps!

    Thanks, Mcman

  5. #5
    "Flash" has suddenly disappeared - unable to reinstall!
    cradom's Avatar
    Member Since
    Feb 14, 2004
    Location
    Groves, Texas
    Posts
    4,781
    Your Mac's Specs
    21in. iMac 10.11 --- HP Linux Mint 18
    Look in /Library/Internet Plug-ins/ and see if there is a Flash Player.plugin
    If there is, it's installed. If it is, go to your home folder/Library/Preferences/Macromedia and delete the Flash Player folder.
    This should restore the use of the plug-in.
    Any priest or shaman must be presumed guilty until proved innocent.

  6. #6
    Hi Cradom,

    my "internet plugin" folder in home/library is empty!
    my "internet plugin" folder in HD/library however has flashplayer plugin in there (as a lego brick lookalike symbol, next to flashplayer plugin enable - both not "highlighted")

    Just in case you meant the latter, i did delete the macromedia flashplayer folder and restarted - with no effect...
    What to do???? Do i need to install flashplayer into the home/library folder?
    Please help!

    Thanks a mill...

  7. #7
    "Flash" has suddenly disappeared - unable to reinstall!
    cradom's Avatar
    Member Since
    Feb 14, 2004
    Location
    Groves, Texas
    Posts
    4,781
    Your Mac's Specs
    21in. iMac 10.11 --- HP Linux Mint 18
    Have no idea what you mean by "highlighted".
    I have Flash Player.plugin and flashplayer.xpt in my Internet Plug-ins folder.
    This is at the root of my drive, not in my home folder. You do not need to install it into your home folder if it is in HD/Library/.
    What version did you install? The latest version is 9.
    Any priest or shaman must be presumed guilty until proved innocent.

  8. #8
    Go to:

    System Preferences -> Quicktime -> Advanced -> Mime settings -> Miscellaneous and disable Flash media.

    If that doesn't help you should try:

    • Uninstalling Flash and re-downloading it,
    • Repair Permissions (they can affect the installation of Flash) then
    • Reboot and test it out.

    Link re: How to uninstall Flash

  9. #9
    Hi Cradom,

    I have also Flash Player.plugin and flashplayer.xpt in my Internet Plug-ins folder (on the HD/Library). In addition, I have Flash Player Enabler.plugin too (!?) By "highlighted" I mean that all the above items are displayed in a very "pale" white/grey color as if they are not activated or so (klicking on them doesn't change it and the info from the menu says they have no size at all!)... This plugin icon doesn't state a version, but the versions I unsuccessfully tried to install are all version 9.

    Hi Spawn_*_Dooley,
    Thanks for joining in. I followed the path you provided and found that the Flash media is disabled. Then I uninstalled Flash via the link provided and it worked. However, I could not re-download Flash. It didn't work automatically as well as manually! Same problems as described in initial posting...

    What to do?????

    Please help.... Thanks in advance.

  10. #10
    "Flash" has suddenly disappeared - unable to reinstall!
    cradom's Avatar
    Member Since
    Feb 14, 2004
    Location
    Groves, Texas
    Posts
    4,781
    Your Mac's Specs
    21in. iMac 10.11 --- HP Linux Mint 18
    If you still have the installer on your drive you shouldn't need to redownload it. Try repairing permissions and then try re-installing it. Then repair permissions again.
    Also that "Enabler" might be from an older version or an Intel Mac. Is your Mac an Intel or PPC? If it's Intel you might be better off with someone else helping you as I have PPC only.
    Any priest or shaman must be presumed guilty until proved innocent.

  11. #11
    Hi Cradom,

    I don't have the intel version, mine is a power pc too (summer 05).

    Do i need to drag and drop the Flash installer anywhere in particular?
    After unsuccessfully trying to install it, i left the flash installer in its dmg on desktop.
    would you dump the enabler from the library?

    how do i repair permissions?? Sorry, i am not in IT at all....

    Thanks again....

  12. #12
    Quote Originally Posted by Mcman View Post
    Hi Cradom,

    I don't have the intel version, mine is a power pc too (summer 05).

    Do i need to drag and drop the Flash installer anywhere in particular?
    After unsuccessfully trying to install it, i left the flash installer in its dmg on desktop.
    would you dump the enabler from the library?

    how do i repair permissions?? Sorry, i am not in IT at all....

    Thanks again....
    Don't worry about not being able to download Flash, if you have the installer handy from before, just use that.

    So, to begin, navigate to Mactintosh HD ~> Library ~> Internet Plug-ins and move the Flash Player Enabler, the Flash Player Plug-In and the Flash Player.xpt to your desktop for now.

    Then, save and/or quit any open documents/applications then navigate to:

    Macintosh HD ~> Applications ~> Utilities ~> Disc Utility

    Or you can use the keyboard combo Shift + Command + U to launch the Utilities folder in Finder.

    Select your HD in the left column and click on Repair Disc Permissions.

    Restart your Mac.

    To install the plugin in your browser, double-click on the .dmg and then double-click on the Install Flash Player icon.



    Click through the dialogue boxes and close all open browsers. Then to finish, click on the Install button.

    The plug-in is installed in Macintosh HD ~> Library ~> Internet Plug-ins, so there's no dragging involved, just double-click on the Installer and click through the dialogues to complete the install.

    The latest version is Ver 9,0,47,0. If you're using Safari, go to Help in the menubar and you can view the installed Plug-ins.

    BTW, Do you have any of these installed ? If not I advise you to download them.

    http://www.flip4mac.com/flip4mac_home.htm

    http://perian.org/

    http://www.versiontracker.com/dyn/moreinfo/macosx/14738


    If after all of the above, you still have problems with Flash you could try the following:

    Go to:

    Macintosh HD ~> Library ~> Internet Plug-ins

    and delete the Quicktime Plugin.webplugin.

    When you have done that you should reboot your Mac.




    #

  13. #13
    Hi Spawn_*_Dooley,
    Hi Cradom,

    Thank you ever so much for all your help and support over the last week!
    The last trick has fixed it!!!

    Your patience was highly appreciated.

    Bye for now!

  14. #14
    Hi Mcman, glad to see it's all worked out fine !!

    Could you please be a lil' more specific as to what the fix was in the end, just for the benefit of future/present members who might have the same problem and are searching the forums for a solution ..

  15. #15
    Hi Spawn_*_Dooley,

    Thanks for your latest message, i should have come up with it myself :-)

    They way i could fix it:
    - took Flash Player Enabler, the Flash Player Plug-In and the Flash Player.xpt out from HD/Library onto desktop
    - performed utility disk repair
    - ran previously downloaded Flash Player Install
    - Install placed new Flash Player Plug-In and Flash Player xpt into HD/Library
    - Moved Flash Player items from desktop into trash
    - deleted trash and restarted computer
    = ALL WORKED FINE!!!!

    Thanks again to all who read the post!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Unable to search a ".sparsebundle" file using "File Size" option
    By Sunrock in forum macOS - Operating System
    Replies: 2
    Last Post: 01-26-2013, 05:25 PM
  2. Safari "copy to dashboard" icon disappeared...
    By w.markegard in forum macOS - Apps and Games
    Replies: 2
    Last Post: 07-08-2009, 04:15 AM
  3. "whoosh" mac mail (2.1.3) sound has disappeared
    By marz in forum Switcher Hangout
    Replies: 2
    Last Post: 09-24-2008, 12:18 PM
  4. "You are unable to login to the user account "warner" at this time."
    By warnerbrown in forum macOS - Operating System
    Replies: 1
    Last Post: 09-04-2008, 10:32 PM
  5. Programs suddenly give "requires newer OS" on OS X 10.4/won't update
    By skylar in forum macOS - Operating System
    Replies: 8
    Last Post: 03-01-2006, 07:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •