Please visit the new Mac-Forums Facebook page:
Join Us @ Mac-Forums Facebook Page



Results 1 to 9 of 9
  1. #1
    ffmpeg Installed With MacPorts Fails After Catalina Update
    I use ffmpeg daily to make time-laps videos from a series of JEPGs.

    This has been working fine for years.

    You can see a sample here: Cha Am Time-Lapse Video

    However, after updating my machine to Catalina and updating MacPorts to the Catalina version, ffmpeg now fails:

    Code:
    ./skyvideo.sh: line 38: 33940 Broken pipe: 13         cat $ipath
         33941 Segmentation fault: 11  | /opt/local/bin/ffmpeg -f image2pipe -framerate 10 -vcodec mjpeg -i - -vcodec libx264 -preset veryslow -hide_banner -loglevel panic -r 10 -crf 28 -y -pix_fmt yuv420p "$vfile" >> "$log"
    I'm hoping that someone smarter than I can help me figure out what's wrong here.

  2. #2
    ffmpeg Installed With MacPorts Fails After Catalina Update
    MacInWin's Avatar
    Member Since
    Jan 01, 2009
    Location
    Winchester, VA
    Posts
    7,257
    Your Mac's Specs
    MBP 15" Mid 2015, iPhone 11 Pro, an iMac, plus ATVs, AWatch, MacMini
    Rep Power
    28
    Just a mention that Apple changed from Bash to zsh as the shell in Terminal with Catalina. Don't know if that makes a difference to your script, but you ought to know.
    Jake

  3. #3
    Quote Originally Posted by MacInWin View Post
    Just a mention that Apple changed from Bash to zsh as the shell in Terminal with Catalina. Don't know if that makes a difference to your script, but you ought to know.
    Yeah, I'm reminded of that every time I open a new shell.

    Code:
    Last login: Fri Dec 13 06:58:33 on ttys001
    The default interactive shell is now zsh.
    To update your account to use zsh, please run `chsh -s /bin/zsh`.
    For more details, please visit https://support.apple.com/kb/HT208050.
    But, my scripts all have the following shebang line, so they should run fine under bash:

    Code:
    #!/bin/bash
    All my other scripts are working fine; it's just ffmpeg on the iMac that's failing.

    And, I seem to still have bash as the default shell:

    Code:
    MrMuscle:bin mnewman$ echo $SHELL
    /bin/bash

  4. #4
    ffmpeg Installed With MacPorts Fails After Catalina Update
    MacInWin's Avatar
    Member Since
    Jan 01, 2009
    Location
    Winchester, VA
    Posts
    7,257
    Your Mac's Specs
    MBP 15" Mid 2015, iPhone 11 Pro, an iMac, plus ATVs, AWatch, MacMini
    Rep Power
    28
    I'm not an expert, but I did go ahead and do the chsh command to change to zsh on my MBP with Catalina. ffmpeg that I have with an app to download video files that runs just fine to convert video. I don't know much about ffmpeg either, it is incorporated into the app folder and runs after a download is complete. So it's not a fundamental issue with Catalina and ffmpeg. Could it be that ffmpeg has an update that your application hasn't incorporated?
    Jake

  5. #5
    Quote Originally Posted by MacInWin View Post
    I'm not an expert, but I did go ahead and do the chsh command to change to zsh on my MBP with Catalina. ffmpeg that I have with an app to download video files that runs just fine to convert video. I don't know much about ffmpeg either, it is incorporated into the app folder and runs after a download is complete. So it's not a fundamental issue with Catalina and ffmpeg. Could it be that ffmpeg has an update that your application hasn't incorporated?
    I'm not ready for zsh. A future project.

    I just recompiled ffmpeg from source, so I'm sure it's the latest version; at least the latest offered by MacPorts. Still no joy.

    I did get the time-lapse working using avconv instead of ffmpeg. avconv is a fork of ffmpeg, so moving there wasn't too hard.

  6. #6
    After spending a huge amount of time with this I've found the following:

    These work. They were both installed using brew:

    Code:
    /usr/local/bin/avconv -y -r 10 -i $inpath -r 10 -vcodec libx264 -q:v 3 $vfile;
    
    /usr/local/bin/ffmpeg -y -r 10 -i $inpath -r 10 -vcodec libx264 -q:v 3 $vfile;
    This doesn’t. It was installed using MacPorts:

    Code:
    /opt/local/bin/ffmpeg -y -r 10 -i $inpath -r 10 -vcodec libx264 -q:v 3 $vfile;
    Both ffmpegs are version 4.2.1

    It seems to be a MacPorts issue.

    (Note that I simplified the commands and made them identical in all cases to equalize conditions for all cases. inpath is the location of the JPEG files. vfile is the time-lapse video.)

  7. #7
    ffmpeg Installed With MacPorts Fails After Catalina Update
    Raz0rEdge's Avatar
    Member Since
    Jul 17, 2009
    Location
    MA
    Posts
    12,248
    Rep Power
    24
    Do the following
    Code:
    file /usr/local/bin/avconv
    file /usr/local/bin/ffmpeg
    file /opt/local/bin/ffmpeg
    and tell us what it says.

    A 'segmentation fault' means that the code is doing something bad.
    --
    Regards
    ...Ashwin


  8. #8
    Code:
    MrMuscle:bin mnewman$ file /usr/local/bin/avconv
    /usr/local/bin/avconv: Mach-O 64-bit executable x86_64
    MrMuscle:bin mnewman$ file /usr/local/bin/ffmpeg
    /usr/local/bin/ffmpeg: Mach-O 64-bit executable x86_64
    MrMuscle:bin mnewman$ file /opt/local/bin/ffmpeg
    /opt/local/bin/ffmpeg: Mach-O 64-bit executable x86_64
    As expected as these were all built recently.

    MacOS Crash Report - PasteBin

  9. #9
    There are two recent MacPorts tickets which, I believe, involve the same error:

    ffmpeg and ffmpeg-devel immediately crash with segfault 11 when input is mp4

    ffmpeg @4.2.1 crash using -vcodec libx264

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How to ignore the Catalina update
    By chscag in forum macOS - Operating System
    Replies: 4
    Last Post: 10-18-2019, 04:40 PM
  2. Prevent update to Catalina
    By tomg35 in forum macOS - Operating System
    Replies: 4
    Last Post: 09-01-2019, 11:39 AM
  3. EFI Update fails
    By microsnook in forum Apple Notebooks
    Replies: 1
    Last Post: 03-04-2012, 10:51 AM
  4. Software Update Fails
    By NeedSomeAnswers in forum macOS - Operating System
    Replies: 7
    Last Post: 09-24-2009, 03:30 PM
  5. Macbook Fails Upon Software Update
    By teev in forum macOS - Operating System
    Replies: 1
    Last Post: 01-08-2009, 04:53 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •