Please visit the new Mac-Forums Facebook page:
Join Us @ Mac-Forums Facebook Page



Results 1 to 7 of 7
  1. #1
    Mail  -  Is this a bug?
    spock999's Avatar
    Member Since
    May 21, 2013
    Location
    Nr Oxford, UK
    Posts
    101
    Your Mac's Specs
    27" iMac 5K late 2015, 24Gb RAM, 4.0Ghz, 512 Gb SSD; MacBook Pros 13" retina early 2013 & 2018
    Rep Power
    7
    Mail - Is this a bug?
    Hi,

    I am on the latest version of Mojave and use Apple mail. We have multiple Apple devices in the house that check our two IMAP email accounts. For 14.4 and now on 14.5, I have noticed that when an email is received on iPad or iPhone, and I check for it on either on my iMac or MacBook Pro, it often returns the no message answer. Yet if I hit the check email button again, it immediately starts to download the new message(s). It happens so often that it is quite irritating.

    It doesn't come up with the can't access email account symbol but it is clear that the message is there waiting to be collected and it just doesn't do it!

    Any suggestions gratefully received.

    Thanks.

  2. #2
    Mail  -  Is this a bug?
    MacInWin's Avatar
    Member Since
    Jan 01, 2009
    Location
    Winchester, VA
    Posts
    7,290
    Your Mac's Specs
    MBP 15" Mid 2015, iPhone 11 Pro, an iMac, plus ATVs, AWatch, MacMini
    Rep Power
    28
    Sounds like a problem with the email server. Who is the provider?
    Jake

  3. #3
    Mail  -  Is this a bug?
    spock999's Avatar
    Member Since
    May 21, 2013
    Location
    Nr Oxford, UK
    Posts
    101
    Your Mac's Specs
    27" iMac 5K late 2015, 24Gb RAM, 4.0Ghz, 512 Gb SSD; MacBook Pros 13" retina early 2013 & 2018
    Rep Power
    7
    BT in the UK

  4. #4
    Mail  -  Is this a bug?
    MacInWin's Avatar
    Member Since
    Jan 01, 2009
    Location
    Winchester, VA
    Posts
    7,290
    Your Mac's Specs
    MBP 15" Mid 2015, iPhone 11 Pro, an iMac, plus ATVs, AWatch, MacMini
    Rep Power
    28
    Don't know how well BT works, but from the symptoms, it sounds like the server is slow to respond to the request to check mail. The message is marked as having been read, from the reading on the other devices, so the server is probably looking first for unread messages and only after that looking for un-sent ones for that device. To you, that looks like it isn't sending them at all. I don't have any suggestions for how to change the behavior, sorry. On thought is that you might look at Mail preferences and on the General tab set "Check for new messages" to "Automatically."
    Jake

  5. #5
    Mail  -  Is this a bug?
    spock999's Avatar
    Member Since
    May 21, 2013
    Location
    Nr Oxford, UK
    Posts
    101
    Your Mac's Specs
    27" iMac 5K late 2015, 24Gb RAM, 4.0Ghz, 512 Gb SSD; MacBook Pros 13" retina early 2013 & 2018
    Rep Power
    7
    I already have it set up to automatically check for mail quite frequently. It is just me being impatient and wanting to see what has come! It is worth noting that it didn't used to happen but if it is the server that could easily change without explanation.

    Thanks for the response.

  6. #6
    Mail  -  Is this a bug?
    IWT's Avatar
    Member Since
    Jan 23, 2009
    Location
    Born in Scotland, Worked in Scotland then England, Now live in Wales
    Posts
    6,174
    Your Mac's Specs
    iMac 5K Retina 27", August 2019, 3.6GHz Intel Core i9, Memory 32GB, 2TB SSD, macOS Mojave 10.14.6
    Rep Power
    21
    @spock999

    I'm sorry to say that this is "normal" for BT - at least "normal" since their recent upgrade of their servers.

    There have been quite a few changes behind the scenes, one example being how you log into the web version of BT. This now requires logging in to "My BT" and then going to "Email", then logging in again (probably with a different PW - certainly in my case because I've been with BT for years and years, but "My BT" is relatively new so I had to choose a new PW for that.)

    Anyway, I frequently find that I have to summon new mail when I check in on a new device.

    I guess we have to live with it???

    Ian
    Ian

  7. #7
    Mail  -  Is this a bug?
    spock999's Avatar
    Member Since
    May 21, 2013
    Location
    Nr Oxford, UK
    Posts
    101
    Your Mac's Specs
    27" iMac 5K late 2015, 24Gb RAM, 4.0Ghz, 512 Gb SSD; MacBook Pros 13" retina early 2013 & 2018
    Rep Power
    7
    Quote Originally Posted by IWT View Post
    @spock999

    I'm sorry to say that this is "normal" for BT - at least "normal" since their recent upgrade of their servers.

    Ian
    Thanks. Pity about that but it is useful to know where the problem lies.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: 10-19-2015, 07:36 PM
  2. Apple Mail: Duplicate mail boxes inbox vs all mail
    By BoBran in forum macOS - Operating System
    Replies: 0
    Last Post: 10-28-2014, 12:59 PM
  3. Replies: 2
    Last Post: 02-14-2012, 11:12 PM
  4. Mac Mail POP IMAP Multiple Computer Duplicate E-Mail Problem on Laptop
    By killertofu in forum macOS - Apps and Games
    Replies: 1
    Last Post: 02-11-2011, 07:15 PM
  5. Yahoo mail has acted weird last few days. wont download mail at all now
    By k2snowboards88 in forum iPhone Hardware and Accessories
    Replies: 9
    Last Post: 09-20-2007, 11:08 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •