Please visit the new Mac-Forums Facebook page:
https://www.facebook.com/macforums1




Results 1 to 7 of 7
  1. #1
    Asking for Skype for OS 10.8.5 Snow Leopard
    I'd like to know if there are any reliable download sites where I can get the Skype version for OS 10.8.5 Snow Leopard? I have a 24" IMac Early 2008, 2.8GHz Intel Core Duo and 4GB 800 MHZ DDR2RAM. Thanks for any help you can give me.

  2. #2
    Asking for Skype for OS 10.8.5 Snow Leopard
    Raz0rEdge's Avatar
    Member Since
    Jul 17, 2009
    Location
    MA
    Posts
    11,719
    Rep Power
    22
    Most recent versions of an application require macOS Yosemite 10.10 to function. Looks like Skype requires macOS Mavericks 10.9 at the minimum. So the recent version is out. 10.8.5 is Mountain Lion, now Snow Leopard (which is 10.6.8).

    Googling around, it looks like you will want Skype v6.19, but I couldn't find a "safe" place to download it and it isn't available from Skype.com directly.

    Know, that if you do manage to download that particular version, Skype might require you to upgrade to allow the app to continue to work anyway.
    --
    Regards
    ...Ashwin


  3. #3
    Thanks for answering. Is uptodown a safe place to download from? Or is filehippo good?
    Last edited by eschwartz; 05-25-2019 at 11:09 PM.

  4. #4
    Sorry, my mac OS is Mountain Lion (10.8.5).

  5. #5
    Asking for Skype for OS 10.8.5 Snow Leopard
    pm-r's Avatar
    Member Since
    Oct 16, 2010
    Location
    Brentwood Bay, BC, Canada
    Posts
    11,596
    Rep Power
    18
    As it looks like you just discovered:
    Skype old versions - Mac

    Skype old versions - Mac

    I have no idea if any version prior to the one that needs 10.9.5 will actually run and work. I have a feeling they killed earlier versions.


    - Patrick
    ======

  6. #6
    Asking for Skype for OS 10.8.5 Snow Leopard
    ferrarr's Avatar
    Member Since
    May 21, 2012
    Location
    Pawtucket, RI, US
    Posts
    6,274
    Your Mac's Specs
    L2014 Mac mini macOS 14, iPhone 8+ iOS 12, 12.9" iPad Pro 1 iOS 12, Pencil 1
    Rep Power
    13
    -- Bob --
    Please backup. Everything has a life cycle, unexpected and warning free. Nothing will last as long as you want it to.

  7. #7
    Asking for Skype for OS 10.8.5 Snow Leopard
    pm-r's Avatar
    Member Since
    Oct 16, 2010
    Location
    Brentwood Bay, BC, Canada
    Posts
    11,596
    Rep Power
    18
    NOTE: from my own experiences with Skype, even though some older versions may be available, Don't be surprised if you get cut off and prevented from using them, which is what happened to me some years ago.

    And here are some notes and excerpts:
    What are the system requirements for Skype?

    Support for Skype versions 7 and below is ending
    Support for Skype versions 7 and below will end on November 1, 2018 on desktop devices and November 15, 2018 on mobile and tablet devices. What does end of...

    Beyond the end of support dates in November:

    You may find that you can continue to use older versions of Skype for a short period of time, but we encourage you to update today to avoid any interruption.
    Customer support will no longer be provided for versions 7 or below, other than for account or billing questions.

    Support for Skype versions 7 and below is ending | Skype Support
    and
    Getting started | Download, install, and upgrade
    For anything less than their current Supported version of Skype, basically you just have to try running it and see what happens. It may and it may not work.

    Good luck.


    - Patrick
    ======

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: 08-10-2011, 02:00 PM
  2. Remove Snow Leopard Server and re-install Snow Leopard
    By b-rad in forum macOS - Operating System
    Replies: 4
    Last Post: 08-09-2011, 01:33 AM
  3. Replies: 6
    Last Post: 01-02-2011, 06:15 PM
  4. Replies: 2
    Last Post: 04-10-2010, 05:09 AM
  5. Leopard and Skype
    By cu8sfan in forum macOS - Operating System
    Replies: 6
    Last Post: 11-04-2007, 06:40 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •