Please visit the new Mac-Forums Facebook page:
https://www.facebook.com/macforums1




Results 1 to 4 of 4
  1. #1
    Apache failing to start from launched plist, starts from httpd
    rachalmers's Avatar
    Member Since
    Mar 26, 2019
    Posts
    161
    Your Mac's Specs
    Mac mini. July 2012
    Rep Power
    1
    Apache failing to start from launched plist, starts from httpd
    Apache is working fine if I start it with /usr/sbin/httpd -k start But If I use the apachectl start command it fails, as does the plist file. Itís only started doing this I think since I rebooted a few days ago.
    Summary:
    httpd -k start ,works
    apachectl start ,does not.

    The error in system.log appears to be ďService could not initialise: 18E226Ē but I canít see what the problem is. Latest Mojave.

    The full error seems to be.
    com.apple.xpc.launchd[1] (org.apache.httpd[2412]): Service could not initialize: 18E226: xpcproxy + 11291 [1534][1571C9B2-C489-3268-9D6B-73137AC77303]: 0x2

    Anyone know why this could be happening?
    Thanks


    Sent from my iPad using Mac-Forums

  2. #2
    apachectl is a shell script.

    Is it possible that there is a path problem? Is everything the script wants in the place where the script expects it to be? Have you installed any non-Apple versions of any software that ended up in a location different from the Apple version?

    FWIW (nothing), it works on my machine.

  3. #3
    Apache failing to start from launched plist, starts from httpd
    rachalmers's Avatar
    Member Since
    Mar 26, 2019
    Posts
    161
    Your Mac's Specs
    Mac mini. July 2012
    Rep Power
    1
    Hi thanks.
    The problem was, I'd moved the Ruby binary - and httpd-wrapper needs the Apple Ruby in /usr/bin/ruby.

    I put it back, and all started to work again.

  4. #4
    Yeah, I figured it had to be something like that.

    Glad you got it sorted.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Mamp : The apache configuration file httpd.conf couldn't be written
    By Nephila in forum Web Design and Hosting
    Replies: 1
    Last Post: 11-28-2016, 09:17 AM
  2. Yosemite - Failed to start apache
    By ali55 in forum macOS - Operating System
    Replies: 0
    Last Post: 03-29-2015, 09:48 AM
  3. Getting Applications to start when OS-X starts
    By Solong in forum macOS - Apps and Games
    Replies: 4
    Last Post: 08-22-2008, 03:57 PM
  4. Apache does not start
    By plutonito in forum macOS - Development and Darwin
    Replies: 3
    Last Post: 07-28-2004, 12:19 PM
  5. apache server (httpd.conf error)
    By oo_mac_oo in forum macOS - Development and Darwin
    Replies: 15
    Last Post: 10-09-2003, 10:44 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •