Please visit the new Mac-Forums Facebook page:
Join Us @ Mac-Forums Facebook Page



Page 1 of 2 12 LastLast
Results 1 to 15 of 17

Thread: Safari setting?

  1. #1
    MacInWin
    Guest
    Safari setting?
    Safari 9.1.1, OSX 10.11.5, Mid 2015 rMBP, 15"

    When I open Safari the entire screen is larger than I want. I use CMD + "-" to go down one tick in size. Is there a way to set that permanently? I've searched and found nothing.

    TIA
    Last edited by MacInWin; 05-30-2016 at 11:24 AM. Reason: Clarification

  2. #2
    Safari setting?
    pigoo3's Avatar
    Member Since
    May 20, 2008
    Location
    U.S.
    Posts
    41,404
    Your Mac's Specs
    2011 17" MBP 2.2ghz, 16gig ram, OS 10.11.6
    Rep Power
    43
    Hey Jake…just wanted to clarify. Are you saying that you prefer (would like) the Safari text setting to be one-tick smaller in size than the default "Actual Size" setting?

    Thanks,

    - Nick
    - Too many "beachballs", read this: Beachballs
    - Computer seems slower than it used to? Read this for some slow computer tips: Speedup
    - Almost full hard drive? Some solutions. Out of Space
    - Apple Battery Info. Battery

  3. #3
    Safari setting?
    pigoo3's Avatar
    Member Since
    May 20, 2008
    Location
    U.S.
    Posts
    41,404
    Your Mac's Specs
    2011 17" MBP 2.2ghz, 16gig ram, OS 10.11.6
    Rep Power
    43
    Give this a try Jake. In Safari Preferences…under the "Advanced" tab…there's a setting for "Never use font sizes smaller than…". From what you describe…sounds like you would like it the other way around (Never use font sizes larger than…".

    Also did some web searches…and seems that most questions are focused on how to make the default Safari text setting larger (rather than smaller).

    Not sure if any of this will lead to a solution.

    - Nick
    - Too many "beachballs", read this: Beachballs
    - Computer seems slower than it used to? Read this for some slow computer tips: Speedup
    - Almost full hard drive? Some solutions. Out of Space
    - Apple Battery Info. Battery

  4. #4
    Safari setting?
    RadDave's Avatar
    Member Since
    Jan 20, 2012
    Location
    North Carolina
    Posts
    4,537
    Your Mac's Specs
    MBP 13" (2013); 8 GB RAM; SSD 256 GB; OS 10.15.1
    Rep Power
    20
    Hi Jake - I'll sometimes 'Zoom in or out', and then simply go to the 'View' menu and click the 'Actual Size' option which returns me to the default font (arrow in diagram) - not sure how this will work for you but let us know - Dave

    P.S. this menu choice is grayed out if the default font size is already set.
    .
    Screen Shot 2016-05-30 at 1.11.27 PM.png
    If you are helped, increase the reputation of the poster -

  5. #5
    MacInWin
    Guest
    Nick, yes, I want it a tick smaller. I got a new retina MBP last week, and the fonts are so clear that I can see them better just a tick smaller. I now invoke Safari, immediately hit CMD & "-" to get that one tick smaller. Would like to have that be the default.

    Rod, Actual Size goes back to the default, which is one too large. I want it one smaller than Actual size.

    I don't think there is a way to do that. I've done a lot of searching and haven't seen a permanent fix. I'll have to live with it, I guess.

  6. #6
    Safari setting?
    chscag's Avatar
    Member Since
    Jan 23, 2008
    Location
    Keller, Texas
    Posts
    59,049
    Your Mac's Specs
    2017 27" iMac, 10.5" iPad Pro, iPhone 7+, iPhone 8, Numerous iPods, Mojave
    Rep Power
    53
    Try this Jake:

    Create a CSS file and put it somewhere that it can be pointed to. Then note it in Safari Preferences "Advanced" under Style Sheet. Here's an example that would work for you:

    body {
    zoom: 90%;
    }


    (You can use textedit to create it, but make sure you give it a file extension of css.) I use something similar but with a larger font and I named it "default.css".

  7. #7
    MacInWin
    Guest
    Thanks, chscag, but that didn't work. No change in behavior. I cut/pasted your three lines, saved as default.css, made the change in Preferences, restarted Safari and no change. Thanks for trying, though.

  8. #8
    Safari setting?
    chscag's Avatar
    Member Since
    Jan 23, 2008
    Location
    Keller, Texas
    Posts
    59,049
    Your Mac's Specs
    2017 27" iMac, 10.5" iPad Pro, iPhone 7+, iPhone 8, Numerous iPods, Mojave
    Rep Power
    53
    That should have worked. I have mine set to 150% and it works OK. I guess we can't zoom down, just up.

  9. #9
    MacInWin
    Guest
    Yeah, I don't know why it won't work. Maybe you are right, it's up, not down. Not a big thing, I'm getting into the habit of the immediate CMD- now.

  10. #10
    Safari setting?
    Slydude's Avatar
    Member Since
    Nov 16, 2009
    Location
    North Louisiana, USA
    Posts
    14,592
    Your Mac's Specs
    2.8 GHz 2008 MacBook Pro 10.11, 8 GB mem, iPhone XS, 2015 iMac 16 GB 10.14.4 beta
    Rep Power
    25
    [
    Quote Originally Posted by chscag View Post
    That should have worked. I have mine set to 150% and it works OK. I guess we can't zoom down, just up.
    No, You can zoom down. I tried the main forum page at 75% and it worked. Not sure if you have to quit Safari for the setting to take effect (don't think so) but I did.

    When Charlie initially suggested that I use this to soon in/enlarge pages I had some trouble getting it to work. When I tried this months ago to enlarge files I had to try it twice. Worked right away tonight. I did make sure to put the .css extension on it. TextEdit will ask if you want to replace the .txt extension. Let it do so.
    “Hard work beats talent when talent fails to work hard.”
    Kevin Durant

  11. #11
    MacInWin
    Guest
    Sly, I don't know what to say. The default.css is a pure text file. It's pointed to in Safari Preferences. I've rebooted Safari a half dozen times, no effect. I've double-checked that it's a text file and it exactly matches what Charlie suggested. It SHOULD work, but it simply doesn't.

    EDIT: I looked at default.css with a hex editor and there are no extraneous characters at all. Just the 19 Charlie has in his post.
    Last edited by MacInWin; 05-30-2016 at 09:52 PM.

  12. #12
    MacInWin
    Guest
    I got it to work! The hex editor gave me an idea. What I was seeing was actually 21 bytes, with a leading "*" and a trailing "*" in the file. It must have put them there when I cut/pasted from Charlie's post. I deleted those two characters and restarted Safari and it worked!

    Thanks Charlie and Sly!

  13. #13
    Safari setting?
    Slydude's Avatar
    Member Since
    Nov 16, 2009
    Location
    North Louisiana, USA
    Posts
    14,592
    Your Mac's Specs
    2.8 GHz 2008 MacBook Pro 10.11, 8 GB mem, iPhone XS, 2015 iMac 16 GB 10.14.4 beta
    Rep Power
    25
    Not doubting your word at all. As I say IIRC when I tried this to enlarge pages a few months ago it took a few tries. My encoding setting is Latin 1. Iy also seems to work with Western (Mac US Roman)
    “Hard work beats talent when talent fails to work hard.”
    Kevin Durant

  14. #14
    Safari setting?
    chscag's Avatar
    Member Since
    Jan 23, 2008
    Location
    Keller, Texas
    Posts
    59,049
    Your Mac's Specs
    2017 27" iMac, 10.5" iPad Pro, iPhone 7+, iPhone 8, Numerous iPods, Mojave
    Rep Power
    53
    Glad you got it to work. I was beginning to doubt that the zoom would work both ways. But when you think about it, we can zoom up and down in Safari by using plus and minus.

  15. #15
    Safari setting?
    Slydude's Avatar
    Member Since
    Nov 16, 2009
    Location
    North Louisiana, USA
    Posts
    14,592
    Your Mac's Specs
    2.8 GHz 2008 MacBook Pro 10.11, 8 GB mem, iPhone XS, 2015 iMac 16 GB 10.14.4 beta
    Rep Power
    25
    I see your post crossed with my last one. Glad that finally worked for you. maybe that's why I first had trouble with this months ago earn Charlie suggested it. IIRC it took three or four tries for me.
    “Hard work beats talent when talent fails to work hard.”
    Kevin Durant

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. iOS Safari Language Setting Irritant
    By kitty-mus in forum iOS and Apps
    Replies: 0
    Last Post: 08-18-2015, 07:31 PM
  2. Setting Safari to mute sound from all websites as default?
    By dvdchance in forum macOS - Operating System
    Replies: 0
    Last Post: 04-26-2012, 02:48 PM
  3. HELP!!! Lost all setting on Apple Mac. Gone back to original setting!!!!!
    By HappySad99 in forum macOS - Operating System
    Replies: 9
    Last Post: 02-24-2011, 02:16 PM
  4. Safari passwords setting
    By windymiller in forum Running Windows (or anything else) on your Mac
    Replies: 5
    Last Post: 08-22-2009, 11:21 PM
  5. Problem with setting "homepage" in Safari
    By CrossBones in forum Switcher Hangout
    Replies: 2
    Last Post: 01-31-2006, 11:41 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •