Please visit the new Mac-Forums Facebook page:
Join Us @ Mac-Forums Facebook Page



Page 1 of 2 12 LastLast
Results 1 to 15 of 21
  1. #1
    Unhappy iMessage no longer works. Upgraded to El Capitan
    Mac Pro. iPhone 6. Handful of other Apple hardware products that work fine with both iMessage (Messages) and Facetime.

    On this Mac Pro, iMessage and Facetime worked great. I used them two/three times a week each and they were a non-issue.

    Upgraded to 10.11.2 El Capitan and got everything up and running including Facetime. iMessage opens with the "Log in with your appleid and password" I do, the fields go light gray for a second or three then come back full colour. Nothing else happens.

    I click "Not Now" and get into the program. All of my gmail and appleid accounts are there with (inactive) on them. Try to log in with my appleid and password and "An Error Occurred During Authentication" Just now while I was writing this I got a "must log into icloud with System Preferences again, so I did. Still getting error occurred and spinning disc with nothing happening other than that.

    I have turned iMessage off and on on my phone, set the time/date manually then automatic, rebooted computer, logged into computer in single user mode, I'm running out of ideas.

    Help?!?
    Thanks
    DanH

  2. #2
    chas_m
    Guest
    Some specifics on the Mac Pro model would be very helpful, but in the meantime I'd suggest logging out of, and then back into, your iCloud account from System Preferences. That is where the problem is happening, not in Messages: if the iCloud account is properly working, then Messages won't ask for credentials at all.

  3. #3
    Well that didn't work. iCloud drive works, facetime works, contacts got repopulated, safari bookmarks et al are back, calendar is back with items in it.

    Only iMessages doesn't work. Everything else from iCloud works fine.


    macpro.png

  4. #4
    chas_m
    Guest
    The program is called Messages, and can you be a bit more specific about EXACTLY what happens? Does it launch, for example.

  5. #5
    iMessage no longer works.  Upgraded to El Capitan
    dtravis7's Avatar
    Member Since
    Jan 04, 2005
    Location
    Modesto, Ca.
    Posts
    30,104
    Your Mac's Specs
    iMac late 2012 21.5 i5 10:14. iMac 2010 27"QuadI7 OS10.13, MBPLate2011, iPad Pro10.5", iPhone7
    Rep Power
    38
    I had that once not long ago and had to go to apple and request an App Specific password for messages. Put that in and all was fine.

    Not sure if that is your issue but might be worth a try.

  6. #6
    Quote Originally Posted by chas_m View Post
    The program is called Messages, and can you be a bit more specific about EXACTLY what happens? Does it launch, for example.
    I do software testing as part of my daily job. Perhaps reading my first post closer might help. This part specifically:

    iMessage opens with the "Log in with your appleid and password" I do, the fields go light gray for a second or three then come back full colour. Nothing else happens.

    I click "Not Now" and get into the program. All of my gmail and appleid accounts are there with (inactive) on them. Try to log in with my appleid and password and "An Error Occurred During Authentication" Just now while I was writing this I got a "must log into icloud with System Preferences again, so I did. Still getting error occurred and spinning disc with nothing happening other than that.
    But should someone not understand what I meant by all that:

    First I click on the launch icon (small rocket on the bottom of the screen)
    I then click on Messages (cartoon talking bubbles, blue and white with the white one having three blue dots in it)
    I get this box:
    start1.png

    I type in the same Apple ID and Password as I've done on my iPads, MacBook Pro, MacBook Air, Mac Pro (previous OS install) and Mac Pro (this install with all the other items that require Apple ID and Password. They all work)

    start2.png

    About 99% of the time the Apple ID and Password boxes go light gray (and nothing can be typed in them) and then just come back exactly as they look above. Well, with my actual Apple ID rather than stars. No error, no nothing. Just back to square one with the boxes filled in. I can enter the information all day and get the same thing or I can just hit the Sign In button and light gray-return to that box.

    Every now and again I get the iMessages application (it says iMessages at the top of it so that's what I'll call it) comes up with the Accounts box open and all the accounts marked as inactive and with this error box:

    start3.png

    I click on the OK button and that goes away. I then see "Enter Apple ID" with an Apple ID and a Password box looking like this after I fill it out (with my real apple id rather than stars in the Apple ID box)

    start4.png

    Everything grays out for one to about 5 minutes then I get this error message:

    start5.png

    I can try all day, reentering my Apple ID and Password, cutting and pasting from another app, just clicking on sign in when it comes back, whatever.

    Now, for trouble shooting, I have:

    Made sure I could sign in and out of Message on my phone, iPads, MacBook Pro, MacBook Air
    Made sure I could sign in and out of FaceTime on all the above
    Checked to make sure the machine's serial number is set in the OS
    Made sure I was typing the Apple ID and password correctly, tried typing it in multiple times, tried cut and pasting
    Made sure there was no proxy server set
    Opened the Utilities , found Keychain Access. Deleted all keys that had Message
    Tried to log in some more with exactly the same results.
    Turned off "Find My Mac"
    Rebooted, logged in as guest user, tried all the AppleID required programs. All of them work except Messages


    Now, was that specific enough?

    DanH

  7. #7
    iMessage no longer works.  Upgraded to El Capitan
    dtravis7's Avatar
    Member Since
    Jan 04, 2005
    Location
    Modesto, Ca.
    Posts
    30,104
    Your Mac's Specs
    iMac late 2012 21.5 i5 10:14. iMac 2010 27"QuadI7 OS10.13, MBPLate2011, iPad Pro10.5", iPhone7
    Rep Power
    38
    What I suggested is NOT in your list. You just might try it. It can not hurt you.

  8. #8
    Yeah, I've logged onto and off of iCloud from every one of the Macs with a keyboard just to make sure the authentication works. Every machine that message worked on previous, worked again when I signed back in and this mac pro still does not. I've tried this at least two times on the other machines and a whole lot more than that on the Mac Pro.

    When I "Sign Out" of iCloud it deletes all the local files from my iCloud. When I sign back in, they come back.

    FaceTime works here. iCloud works here. iCloud Mail works here. Contacts works here. Safari bookmarks, history work here. Keychain works here. Photos works here.

    The only thing that does not work is Messages.

  9. #9
    MacInWin
    Guest
    So I'm confused. The app is not named iMessages, it's Messages. That changed name was from some time ago, as I recall. I don't know why iMessages is still in the Launchpad (the rocket thingy) but if you look in the Applications folder, you should see Messages. That's what you need to use.

  10. #10
    MacInWin
    Guest
    BTW, that's what chas_m pointed to in post #4. Messages, not iMessage.

  11. #11
    Quote Originally Posted by MacInWin View Post
    So I'm confused. The app is not named iMessages, it's Messages. That changed name was from some time ago, as I recall. I don't know why iMessages is still in the Launchpad (the rocket thingy) but if you look in the Applications folder, you should see Messages. That's what you need to use.
    I have started it via the launchpad, I've started it by double clicking in Finder under Applications/Message.app, I've started it by command line. Look at the screen shots I've put up there, all of them with the title of the program in it says iMessages. Yeah, the launchpad says Messages but nothing in the program does.

  12. #12
    Quote Originally Posted by danielgmac View Post
    I have started it via the launchpad, I've started it by double clicking in Finder under Applications/Message.app, I've started it by command line. Look at the screen shots I've put up there, all of them with the title of the program in it says iMessages. Yeah, the launchpad says Messages but nothing in the program does.
    Any chance you got this figured out? I bought a brand new MacBook Pro yesterday, and I'm having the EXACT SAME ISSUE as you had (just as you described the first time ;-) )

  13. #13
    MacInWin
    Guest
    Apple has reported issues with Messages, is working on a solution. There is an article here:

    http://www.macrumors.com

    It's from yesterday, so you'll need to scroll down a bit for it.

  14. #14
    I just (05.19.20) upgraded to El Capitan 10.11.5 and my Message icon did not work either. I put my iPhone next to my computer (MacBook Pro 17") and followed the directions
    in this thread.

    https://support.apple.com/kb/PH22363?locale=en_US

    My iPhone already had already been set up and working prior to El Capitan upgrade, therefore my "Text Message Forwarding" was already toggled "ON" to connect with my Mac.

    I simply toggled it OFF and then back ON. Instantly my computer screen had a code to connect to my iPhone. MESSAGES began working immediately on my computer screen without any intervention.

    The solution might be just this simple for some.

    Your Welcome.

  15. #15
    Do we have an answer on this?
    Same thing just happened to me yesterday! I think it has something to do with a process I disabled. I forget the process now, too.

    Anyone?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Just upgraded to El Capitan
    By mattymac in forum macOS - Operating System
    Replies: 2
    Last Post: 10-29-2015, 04:30 PM
  2. Upgraded to OS X Capitan and can't get pics or Microsoft Office
    By mkuhl65107 in forum macOS - Operating System
    Replies: 5
    Last Post: 10-21-2015, 06:13 PM
  3. Upgraded to El Capitan now Hotmail doesn't work
    By Jaybird180 in forum macOS - Operating System
    Replies: 12
    Last Post: 10-19-2015, 09:31 AM
  4. El Capitan upgraded. Mission control & Split view now working
    By clemolo in forum macOS - Operating System
    Replies: 9
    Last Post: 10-06-2015, 10:15 PM
  5. iMessage not longer working
    By adz in forum iOS and Apps
    Replies: 2
    Last Post: 07-03-2012, 06:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •