Please visit the new Mac-Forums Facebook page:
https://www.facebook.com/macforums1




Results 1 to 4 of 4
  1. #1


    Member Since
    Jan 14, 2016
    Location
    Santa Cruz Mtns foothills, Cupertino, CA
    Posts
    10
    Your Mac's Specs
    Mac Pro loaded, Mac Book, Mac Mini
    Rep Power
    4
    Canít attach GIFís to messages
    Iím trying to send a message with one of the GIFs from the library but I get ďCannot Send Message -- iMessage needs to be enabled to send this message.Ē

    Problem is, iMessage IS enabled, at least I think it is. Under Settings/Messages, iMessage is in fact turned on, and so is MMS messaging, but nothing else.

    What am I missing?? Thanks in advance,

    -Ig.

  2. #2
    It's an older discussion, but perhaps try some of the tips here:

    "iMessage needs to be enabled to send this message?
    https://discussions.apple.com/thread/5187065

    Examples:

    Managed to solve this on my phone. One or both of the following did it: 1) Reset Network Settings (General | Reset | Reset Network Settings). This was a recommendation for IOS 8 texting issues. It deletes all wifi passwords, so beware. 2) Toggle iMesage on, then turn phone off and back on, then sent a message, and toggle iMessage off again. After all of this, all of my texts seem to go through.
    @leesehome, I just upgraded to IOS on iPhone 4S as well. I also usually do not use iMessage and was getting this error. To fix my issue, I enabled iMessage, sent a message, then disabled iMessage and the error no longer appears. I don't know if simply toggling iMessage on and off would fix this issue, but I would give that a try.
    Holy Mackerel! I've been searching for the solution to this for a couple months, and now I just found it. This is the EASY fix people.



    The reason it is trying to send using IMESSAGE is that it's trying to continue a thread you had before with that recipient. Just open up the message window and at the top do a search for that person's name. Then for each entry found (including groups if you want) swipe them left to delete them. When you're done, the screen should be pretty much blank. Start a new message to this person and it should come up GREEN as SMS and you're good to go.



    Note I didn't have to do anything in my settings or reboot the phone or any of that stuff. I've had iMessage turned off for a while and have been dealing with this problem for some time.
    -Jonathan
    iMac (27-inch, Late 2012) - 2.9 GHz Intel Core i5
    MacBook Air (13-inch, Mid 2012) - 1.8 GHz Intel Core i5

  3. #3


    Member Since
    Jan 14, 2016
    Location
    Santa Cruz Mtns foothills, Cupertino, CA
    Posts
    10
    Your Mac's Specs
    Mac Pro loaded, Mac Book, Mac Mini
    Rep Power
    4
    Resetting Network Settings did the trick!

    Grazie, Gracias, Obrigado, Arigato, Thanks.

  4. #4
    Quote Originally Posted by IgorP View Post
    Resetting Network Settings did the trick!

    Grazie, Gracias, Obrigado, Arigato, Thanks.
    Awesome!
    -Jonathan
    iMac (27-inch, Late 2012) - 2.9 GHz Intel Core i5
    MacBook Air (13-inch, Mid 2012) - 1.8 GHz Intel Core i5

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Iphone6 suddenly receiving weird Asian text messages and warning messages
    By LEKOVISION in forum iPhone Hardware and Accessories
    Replies: 7
    Last Post: 10-26-2016, 01:50 PM
  2. Replies: 7
    Last Post: 02-25-2014, 08:54 AM
  3. Attach a QuickTime file
    By vank66 in forum Switcher Hangout
    Replies: 2
    Last Post: 10-20-2009, 11:24 AM
  4. pc to mac attach pdf
    By corpsol in forum macOS - Apps and Games
    Replies: 4
    Last Post: 06-13-2009, 01:03 AM
  5. USB Hubbing... what to attach?
    By logic_user99 in forum Other Hardware and Peripherals
    Replies: 5
    Last Post: 09-09-2007, 09:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •