Results 1 to 15 of 15
  1. #1
    No Texts on iPad
    I get text messages to and from my iPhone. It has my phone number. But, my iPad just has my email address and I've tried to change it to my phone number but there doesn't seem to be a way. So, my text messages won't sync to both devices. Help please. Thanks.

  2. #2
    No Texts on iPad
    ferrarr's Avatar
    Member Since
    May 21, 2012
    Location
    Pawtucket, RI, U.S.A.
    Posts
    7,695
    Your Mac's Specs
    L2014 Mac mini macOS 15, iPhone 11 iOS 13, 1st Gen 12.9" iPad Pro iPadOS 13
    Rep Power
    15
    On the iPhone, make sure you have enabled text forwarding.
    -- Bob --
    Please backup. Everything has a life cycle, unexpected and warning free. Nothing will last as long as you want it to.

  3. #3
    No Texts on iPad
    lclev's Avatar
    Member Since
    Jul 24, 2013
    Location
    Ohio (USA)
    Posts
    4,229
    Your Mac's Specs
    2020 13" MBPro, 2010 MacPro, 11”‘ iPad Pro, iPhone Xs Max
    Rep Power
    13
    On your iPad go to Settings -> Tap on your name on the left (Apple ID). Then look at Reachable at. It should show your iPhone number and under it list iMessage and Face time. If that is wrong you can can tap on edit or add a phone number if necessary to receive iMessages.

    Here is a link from Apple with more information. Scroll down to find the part about iMessage problems.

    If you can'''t send or receive messages on your iPhone, iPad, or iPod touch - Apple Support

    Lisa
    Recommend using Onyx to clean your Mac.
    If you have been helped, please add to their reputation by clicking on the icon in the lower left hand corner of the post.

  4. #4
    Thanks, but...
    Quote Originally Posted by ferrarr View Post
    On the iPhone, make sure you have enabled text forwarding.
    All I show is “call forwarding”. No text forwarding.

  5. #5
    No Texts on iPad
    Raz0rEdge's Avatar
    Member Since
    Jul 17, 2009
    Location
    MA
    Posts
    12,584
    Rep Power
    24
    Go to Settings->Messages and click on Send & Receive and there you will see a list of all the ways people can reach you (phone and email) and how your messages go out. Ensure that your number is listed as an accessible thing and not just your email.
    --
    Regards
    ...Ashwin


  6. #6
    Not working
    Quote Originally Posted by Raz0rEdge View Post
    Go to Settings->Messages and click on Send & Receive and there you will see a list of all the ways people can reach you (phone and email) and how your messages go out. Ensure that your number is listed as an accessible thing and not just your email.
    I did as you suggested, but all that's there is my email address and no way to add a phone number. When I click on my Apple I.D. above all this, it gives me three options, Change location, Sign Out and Cancel. I tried the sign out option the other day and it caused all kinds of problems. I almost couldn't get back in. In fact I had to reset my iPad completely.

  7. #7
    No Texts on iPad
    chscag's Avatar
    Member Since
    Jan 23, 2008
    Location
    Keller, Texas
    Posts
    60,272
    Your Mac's Specs
    2017 27" iMac, 10.5" iPad Pro, iPhone 7+, iPhone 8, Numerous iPods, Catalina
    Rep Power
    56
    Have you tried what Lisa suggested in reply #3? That should work.

  8. #8
    Quote Originally Posted by lclev View Post
    On your iPad go to Settings -> Tap on your name on the left (Apple ID). Then look at Reachable at. It should show your iPhone number and under it list iMessage and Face time. If that is wrong you can can tap on edit or add a phone number if necessary to receive iMessages.

    Here is a link from Apple with more information. Scroll down to find the part about iMessage problems.

    If you can'''t send or receive messages on your iPhone, iPad, or iPod touch - Apple Support

    Lisa
    Lisa, I did as you suggested, and there are three items there. My email, my iPhone phone number and my iCloud email address. My number is correct, so I don't know what's up with that. I used to get my text message on my iPad, but not anymore. I completely reset my iPad, but to know avail.

    - - - Updated - - -

    Yes, but it didn't work. See my response to her. Thanks chscag.

  9. #9
    No Texts on iPad
    chscag's Avatar
    Member Since
    Jan 23, 2008
    Location
    Keller, Texas
    Posts
    60,272
    Your Mac's Specs
    2017 27" iMac, 10.5" iPad Pro, iPhone 7+, iPhone 8, Numerous iPods, Catalina
    Rep Power
    56
    Yes, but it didn't work. See my response to her. Thanks chscag.
    Okay. Have you tried signing out of iCloud on all your devices and then signing back in? I see that you stated above that you signed out of your Apple ID but I'm not sure exactly what it was that you did? Signing in and out of iCloud should be easy and not cause you any problems.

  10. #10
    No Texts on iPad
    badshoehabit's Avatar
    Member Since
    Aug 02, 2011
    Location
    Tyneside, UK
    Posts
    1,714
    Your Mac's Specs
    MBP Retina mid 2015 15.4" 16GB 2.5 GHz OS Catalina; iPhone 7 128gb; iPad Mini 2, 32gb
    Rep Power
    10
    Are messages enabled under Settings > iCloud> Messages on both devices?
    Sue

    If the shoe fits, buy it in every colour.

  11. #11
    Quote Originally Posted by badshoehabit View Post
    Are messages enabled under Settings > iCloud> Messages on both devices?
    No, just my iPad. That may be it! I’ll know tomorrow when I get texts from my son. I’ll let you know. Thanks so much.

  12. #12
    No Texts on iPad
    ferrarr's Avatar
    Member Since
    May 21, 2012
    Location
    Pawtucket, RI, U.S.A.
    Posts
    7,695
    Your Mac's Specs
    L2014 Mac mini macOS 15, iPhone 11 iOS 13, 1st Gen 12.9" iPad Pro iPadOS 13
    Rep Power
    15
    Quote Originally Posted by billinden View Post
    All I show is “call forwarding”. No text forwarding.
    Did you look in Settings > Messages? I have the option of "Text message Forwarding" for my 2 other devices (iPad and Mini).
    -- Bob --
    Please backup. Everything has a life cycle, unexpected and warning free. Nothing will last as long as you want it to.

  13. #13
    I think my problem has been solved. Thanks everyone so much.

  14. #14
    No Texts on iPad
    ferrarr's Avatar
    Member Since
    May 21, 2012
    Location
    Pawtucket, RI, U.S.A.
    Posts
    7,695
    Your Mac's Specs
    L2014 Mac mini macOS 15, iPhone 11 iOS 13, 1st Gen 12.9" iPad Pro iPadOS 13
    Rep Power
    15
    The Settings I am referring to are on the iPhone, not the iPad.
    -- Bob --
    Please backup. Everything has a life cycle, unexpected and warning free. Nothing will last as long as you want it to.

  15. #15
    Thanks
    Quote Originally Posted by ferrarr View Post
    The Settings I am referring to are on the iPhone, not the iPad.
    I know. I made sure both settings are the same. I really appreciate your help. Very much.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Why do our texts appear both phones?
    By tobindia in forum iOS and Apps
    Replies: 5
    Last Post: 11-23-2018, 11:29 AM
  2. texts not deleting from MBP
    By lori5060 in forum macOS - Apps and Games
    Replies: 16
    Last Post: 05-08-2018, 09:29 PM
  3. iPhone texts onto a PC?
    By cherry_bomb in forum iOS and Apps
    Replies: 2
    Last Post: 09-23-2015, 03:05 PM
  4. Retrieving deleted texts and archiving texts
    By Rambler66 in forum iOS and Apps
    Replies: 0
    Last Post: 05-04-2011, 12:38 PM
  5. Sms Texts On Mac
    By jackob2545 in forum Schweb's Lounge
    Replies: 4
    Last Post: 08-24-2008, 02:06 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •