What I'm trying to do is use my own Iphone and Ipad as a simulator through xcode. I'm doing this because the built in simulator cannot get past the log in page on my app, any valid user name and password will result in the error message "Service Error, A server with the specified host name could not be found". Because of this error, I cannot test the code I've changed.

I believe I have the profiles and certificates set up correctly on xcode, when I look at my phone's provisioning profiles in the organizer I see "Ad Hoc, Dist, Dev, and iOS Team Provisioning profile" all with a "Valid profile" status..

But when I try to run the app on my phone I get the "Code Sign error: Provisioning profile 'random letters and numbers" cant be found.. I've searched this issue and came to the conclusion that I needed to modify my .xcodeproj project folder, specifically the project.pbxproj file. I go to that file and delete the line "provisioning_profile[sdk=iphoneos*]" = "random numbers and letters"..

Now when I run the app on my iphone after deleting that line it gives me the error "libxml/tree.h" file not found... I've found the fix to this problem, but once I fix it ill get the error "openssl/ssl.h not found"..

It seems like there is another underlying cause to these problems, because once I fix something it will just break something else. Thanks for reading and hopefully there is someone out there who had this problem and fixed it.

XCode: 4.6.3 Please let me know if there are any other specs needed that would help in debugging this problem.