Hi:

Ive noticed that my iPhone's phone number is not associated with my iMessage account. My contacts are only able to iMessage me with via my email address. I still receive normal sms messages via my phone number. I checked my settings:

Settings/Messages/Receive At/No Phone number associated with the account.

I also can't find a way to "add" my phone number. Anyone experience this or have a fix for this?

Thanks!
Verne