Results 1 to 14 of 14
  1. #1
    Sucuri Firewall? - Is that a service this forum uses?
    krs's Avatar
    Member Since
    Sep 16, 2008
    Posts
    1,582
    Rep Power
    12
    Sucuri Firewall? - Is that a service this forum uses?
    I keep somewhat randomly blocked from posting in some threads in this forum.

    The message that comes up is attached
    BTW - all I'm trying to post is either plain text or plain text with a small jpeg image - nothing even remotely connected to SQL as the message claims.


    Blocked to mac forum_800.jpg

  2. #2
    Sucuri Firewall? - Is that a service this forum uses?
    Raz0rEdge's Avatar
    Member Since
    Jul 17, 2009
    Location
    MA
    Posts
    12,584
    Rep Power
    24
    Yes, that's the firewall we use. Looks like it's quite sensitive.
    --
    Regards
    ...Ashwin


  3. #3
    Sucuri Firewall? - Is that a service this forum uses?
    pm-r's Avatar
    Member Since
    Oct 16, 2010
    Location
    Brentwood Bay, BC, Canada
    Posts
    13,109
    Rep Power
    20
    Quote Originally Posted by Raz0rEdge View Post
    Yes, that's the firewall we use. Looks like it's quite sensitive.
    I also occasionally get the same Sucuri Firewall - Access denied warning with nothing but normal text in the post and it's bloody annoying, so is there some way the Admins or someone could turn down its sensitivity???

    I even went googling on "Sucuri Firewall SQL injection" (the stated reason for the blockage) and there sure in hell wasn't anything like they described in the message to be posted, which of course never did get posted or around the denial.



    - Patrick
    ======

  4. #4
    Sucuri Firewall? - Is that a service this forum uses?
    krs's Avatar
    Member Since
    Sep 16, 2008
    Posts
    1,582
    Rep Power
    12
    Quote Originally Posted by Raz0rEdge View Post
    Yes, that's the firewall we use. Looks like it's quite sensitive.
    Sensitive is fine;
    tripping on a plain text message is not.

    And then coming up with a totally unrelated reason for the block, ie SQL.... is even worse

    Somebody is paying those guys several hundred dollars each year...those Securi guys need to get their act together

  5. #5
    Sucuri Firewall? - Is that a service this forum uses?
    ferrarr's Avatar
    Member Since
    May 21, 2012
    Location
    Pawtucket, RI, U.S.A.
    Posts
    7,695
    Your Mac's Specs
    L2014 Mac mini macOS 15, iPhone 11 iOS 13, 1st Gen 12.9" iPad Pro iPadOS 13
    Rep Power
    15
    Quote Originally Posted by krs View Post
    I keep somewhat randomly blocked from posting in some threads in this forum.

    The message that comes up is attached
    BTW - all I'm trying to post is either plain text or plain text with a small jpeg image - nothing even remotely connected to SQL as the message claims.


    Blocked to mac forum_800.jpg
    Were you attaching an image from your computer, or from the internet?
    -- Bob --
    Please backup. Everything has a life cycle, unexpected and warning free. Nothing will last as long as you want it to.

  6. #6
    Sucuri Firewall? - Is that a service this forum uses?
    krs's Avatar
    Member Since
    Sep 16, 2008
    Posts
    1,582
    Rep Power
    12
    It's the image that pops up on my screen when I get blocked.

    I then copy it to my Mac using Grab, convert it from a tiff file (which is what grab gives you by default) to a jpg using Preview
    Check the size with Preview and reduce it to 800 pixels for this forum
    And then insert the saved 800 pixel jpg image from the Mac to my post on the forum.

    I have been posting here for a while and this is the first time my post was blocked that way.
    I still don't understand why - the post wasjust plain text - actually the part that seems to have triggered the block were the automatically insertec quote tabs, but only the third set of them in my post.
    When I removed those tabs and just posted the text things worked fine.

    I don't think I ever used three quotes in one post before...

    But in the end, the block had nothing to do with the image I tried to post, that was just collateral damage.

  7. #7
    Sucuri Firewall? - Is that a service this forum uses?
    pm-r's Avatar
    Member Since
    Oct 16, 2010
    Location
    Brentwood Bay, BC, Canada
    Posts
    13,109
    Rep Power
    20
    It's the image that pops up on my screen when I get blocked.
    I then copy it to my Mac using Grab, convert it from a tiff file (which is what grab gives you by default) to a jpg using Preview

    Not meaning to go OT here, but wouldn't it be easier to just use the Mac's command+shift+4 and select the area you want to capture??? Then just open the file that will be on your Desktop to check/change size etc. It will already be in an acceptable format to just use and post to the forum.


    - Patrick
    ======

  8. #8
    Sucuri Firewall? - Is that a service this forum uses?
    krs's Avatar
    Member Since
    Sep 16, 2008
    Posts
    1,582
    Rep Power
    12
    Quote Originally Posted by pm-r View Post
    Not meaning to go OT here, but wouldn't it be easier to just use the Mac's command+shift+4 and select the area you want to capture??? Then just open the file that will be on your Desktop to check/change size etc. It will already be in an acceptable format to just use and post to the forum.
    Not for me, actually.
    To start with, I don't take screen shots that often, so I can never remember if it is Command shift 3 or command shif 4, or eben option shift 3 or option shift 4.
    If I neede that operation often, I would probably see if I can reassign one of my function keys to do that - I have F13 to F19 on my keyboard that are not doing anything.
    I then still have to select the part of the screen I want to capture, same as with grab.
    With grab the file goes into a folder that I sort of use as a scratch pad - I know exactly where the screen shot is, right at the top.
    Trying to find the screen shot on my desktop when using cmd+sft+4 always takes a while because my destop is pretty busy and the screen shot saved that way never end up in the same area on the desktop, so I have to search for them
    And finally, most places accept tiff files, this forum is one of the exceptions.

    At one point I was thinking of changing the file format with grab to png, but that involves working with the terminal commands, so for the number of times I need that, I decided to pass.

    But thanks for your suggestion - just doesn't work for me - it would actually take longer that way in my case.

  9. #9
    Sucuri Firewall? - Is that a service this forum uses?
    pm-r's Avatar
    Member Since
    Oct 16, 2010
    Location
    Brentwood Bay, BC, Canada
    Posts
    13,109
    Rep Power
    20
    Trying to find the screen shot on my desktop when using cmd+sft+4 always takes a while because my destop is pretty busy and the screen shot saved that way never end up in the same area on the desktop, so I have to search for them
    For such a user, and that would include myself, to make Desktop file sorting or finding easier, create an alias of your Desktop folder and drag it to the Dock. Then you have the option to sort by date when it's opened, with the most recent either at the top or the bottom of the list whichever you like.

    Just a thought...


    - Patrick
    ======

  10. #10
    Sucuri Firewall? - Is that a service this forum uses?
    krs's Avatar
    Member Since
    Sep 16, 2008
    Posts
    1,582
    Rep Power
    12
    I do something like that when I can't find a file or folder that is on the desktop.
    I opedn any folder, then select the desktop folder in the left window which brings up a listing of all the desktop items, and then sort if necessary.

    But my desktop on the Mac is organized like my real desktop - folders (mostly, just very few files) are placed together in clusters.
    Works very well for the work I do.

  11. #11
    Sucuri Firewall? - Is that a service this forum uses?
    IWT's Avatar
    Member Since
    Jan 23, 2009
    Location
    Born in Scotland, Worked in Scotland then England, Now live in Wales
    Posts
    6,498
    Your Mac's Specs
    iMac 5K Retina 27", August 2019, 3.6GHz Intel Core i9, Memory 32GB, 2TB SSD, macOS Mojave 10.14.6
    Rep Power
    22
    Works very well for the work I do.
    As Woody Allen said "Whatever Works".

    Ian
    Ian

  12. #12
    Sucuri Firewall? - Is that a service this forum uses?
    ferrarr's Avatar
    Member Since
    May 21, 2012
    Location
    Pawtucket, RI, U.S.A.
    Posts
    7,695
    Your Mac's Specs
    L2014 Mac mini macOS 15, iPhone 11 iOS 13, 1st Gen 12.9" iPad Pro iPadOS 13
    Rep Power
    15
    Quote Originally Posted by krs View Post
    It's the image that pops up on my screen when I get blocked.

    I then copy it to my Mac using Grab, convert it from a tiff file (which is what grab gives you by default) to a jpg using Preview
    Check the size with Preview and reduce it to 800 pixels for this forum
    And then insert the saved 800 pixel jpg image from the Mac to my post on the forum.

    I have been posting here for a while and this is the first time my post was blocked that way.
    I still don't understand why - the post wasjust plain text - actually the part that seems to have triggered the block were the automatically insertec quote tabs, but only the third set of them in my post.
    When I removed those tabs and just posted the text things worked fine.

    I don't think I ever used three quotes in one post before...

    But in the end, the block had nothing to do with the image I tried to post, that was just collateral damage.
    No, I meant before you get the popup? In your original post (#1) you mentioned you get the popup if you are attaching an image? Was that image from the internet (with URL) or from your computer?

    I remembered, I was having an issue, when I wanted to post a screen shot of an app Help Menu (I don't remember which app), and I got that same pop up? I was just trying to get clarification, because I thought you said previously, you linked images from another forum, and I wasn't sure if that would cause an issue?
    -- Bob --
    Please backup. Everything has a life cycle, unexpected and warning free. Nothing will last as long as you want it to.

  13. #13
    Sucuri Firewall? - Is that a service this forum uses?
    krs's Avatar
    Member Since
    Sep 16, 2008
    Posts
    1,582
    Rep Power
    12
    Quote Originally Posted by ferrarr View Post
    No, I meant before you get the popup? In your original post (#1) you mentioned you get the popup if you are attaching an image? Was that image from the internet (with URL) or from your computer?
    Oh...I see...

    The comment about the image was false alarm.

    Adding the image was just the last thing I did before hitting the post button, but with some testing afterwards by just typing a few lines of text and posting at that time, I eventually found that the third quote tag seemed to trigger the block.
    But I assume there is more to it than that.

    But to answer your question, that image which I was also from my Mac, not the net, it was a screen shot of my Apple Mail window.
    In the end, it turned out the block had nothing to do with the image I was trying to attach.

    For me, the block was now just a false positive - the first one.
    But other members have had the same issue, more often apparently, so that firewall really needs some fine tuning.
    But at least I know now not to blame my ISP.

  14. #14
    Sucuri Firewall? - Is that a service this forum uses?
    ferrarr's Avatar
    Member Since
    May 21, 2012
    Location
    Pawtucket, RI, U.S.A.
    Posts
    7,695
    Your Mac's Specs
    L2014 Mac mini macOS 15, iPhone 11 iOS 13, 1st Gen 12.9" iPad Pro iPadOS 13
    Rep Power
    15
    Quote Originally Posted by krs View Post
    Oh...I see...

    The comment about the image was false alarm.

    Adding the image was just the last thing I did before hitting the post button, but with some testing afterwards by just typing a few lines of text and posting at that time, I eventually found that the third quote tag seemed to trigger the block.
    But I assume there is more to it than that.

    But to answer your question, that image which I was also from my Mac, not the net, it was a screen shot of my Apple Mail window.
    In the end, it turned out the block had nothing to do with the image I was trying to attach.

    For me, the block was now just a false positive - the first one.
    But other members have had the same issue, more often apparently, so that firewall really needs some fine tuning.
    But at least I know now not to blame my ISP.
    Thanks for the clarification.
    -- Bob --
    Please backup. Everything has a life cycle, unexpected and warning free. Nothing will last as long as you want it to.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 11
    Last Post: 10-18-2019, 07:10 AM
  2. Ipad 3 always has no service, even when my iphone has FULL service
    By rohardi in forum iPad Hardware and Accessories
    Replies: 4
    Last Post: 09-29-2012, 07:29 PM
  3. Forum Rules updated and forum settings tweaked
    By schweb in forum News and Community Announcements
    Replies: 2
    Last Post: 04-01-2007, 09:57 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •