View Full Version : Bootcamp on Leopard

10-29-2007, 10:05 PM
I recently upgraded to 10.5 and now my Windows partition won't start. I press down the option key at startup like I always have, but instead of showing my two partitions and asking me which one to load, it shows a lock with a text box underneath it. I type in my root password and click the arrow next to the text box, but nothing happens. All it does is clear the text box. The only way to get out of that screen is to hold down the power button. Please help!


10-29-2007, 10:39 PM
I posted about this in the forum about Windows and Linux, but I think it might be better-suited for this one. I had Windows installed on BootCamp before I installed Leopard. I just tried to start Windows like I always have. I restarted my computer and held down the option key. Instead of asking me which partition to boot into, it just shows an image of a lock with a text box beneath it. I thought maybe it was some new security feature and I entered my root password and clicked the arrow next to the text box. Instead of taking me to my partitions, it just clears the text. The only way for me to get out of that screen was to hold down the power button. Also, when I open BootCamp utility, it doesn't even show my Windows partition. What gives?

10-29-2007, 11:37 PM
Can a moderator please rename this thread Boot Camp? I accidentally named it Leopard.

10-30-2007, 01:03 AM
Sorry bro;

I just installed Leopard and my Vista partition still work perfectly. I had a little problem getting the new drivers installed but I fixed it in the end. I think you might as well re-install XP.

Good Luck!

10-30-2007, 01:13 AM
Shoot, I hope someone else has a suggestion. I don't want to have to find my XP disk again.

10-31-2007, 03:33 AM
Okay, so I reinstalled XP. It works fine. The only problem is that when I turn on my computer and hold down the option key, I get the same result. I get the stupid lock with the text box. The only way for me to boot windows is to go into System Prefs and click on startup disk and select Windows and restart. Can someone please tell me how to fix this?

10-31-2007, 06:42 AM
Have not had nor seen this myself, so did some searching around.
The only thing I found was from an older article.
It says the lock you're seeing is due to the wrong drive being indicated to the system as the "bootable" Operating System.
Give this a try - Sys Pref's - Startup Disk - select your 10.5 partition and click on Restart from there. when it restarts, hold down the Option key and see what happens then. Let us know - I'll keep looking unless someone else comes up with a fix.

10-31-2007, 12:00 PM
Well, I tried that and I got the same result. :( I really hope someone can help me figure it out. One question though, when I was installing Windows, I saw 4 partitions. There were two really small ones and there were the two big ones. Is this normal?

10-31-2007, 12:18 PM
Yeah, OSX makes separate small partitions for firmware.

10-31-2007, 12:32 PM
Okay, just wanted to make sure. I was just wondering if those were something extra that were confusing my computer. Good to know ;)

11-02-2007, 12:53 AM
Anyone have even a guess? It's pretty annoying having to log into OS X in order to log into XP.

11-02-2007, 12:55 AM
I guess that, since I have AppleCare, I could call customer support. I'm just thinking that since Leopard was just released that the wait times will probably be ridiculous.

11-02-2007, 11:54 PM
I wanted to post this in case anyone else encounters this problem in the future and searches for it. The reason I couldn't load Windows by holding down the option key was due to the firmware lock. That's what the lock image was. Although I enabled the firmware lock, I (stupidly) must have failed to actually set a password for it. That's why when I entered my root password, it still didn't let me past that screen. So....... if you're going to enable the firmware protection, make sure that you actually set a password. :)

11-03-2007, 02:23 AM
So, how did you get past the lock? Was there a way to reset the password?

11-03-2007, 12:15 PM
I'm sorry. I guess that would have been useful info. I used the install DVD to turn off the firmware lock.

11-03-2007, 06:01 PM
I'm sorry and this might not apply anymore but instead of using BootCamp you could try rEFIt (http://refit.sourceforge.net/). I use it to boot my linux but it can be used to boot windows too.

Nice day to all

11-03-2007, 09:47 PM
what is firmware protection?

11-03-2007, 09:49 PM
is it safe to install XP in my mcbook pro with leopard?

11-04-2007, 01:23 AM
The firmware lock (or whatever it's called) is something you have the option of setting by using the Leopard Install DVD. I simply sets a password that is required when doing anything that changes any firmware settings, such as booting from something other than Mac OS X.

Yes it is safe to install XP on your MacBook Pro with Leopard. If it weren't safe, Apple wouldn't have created Boot Camp. That being said, it is important to use your Windows partition just like any other responsible Windows user and keep up-to-date virus, spyware, and malware protection.