View Full Version : Problems importing media to mac

Farmer Pug
11-14-2017, 02:46 PM
I have tried recently to import video files from my camera to my imac via final cut pro x.
In the past this is something which never caused any issues. However recenlty i get this message:

The camera is a sony DSC-HX100V which saves in AVCHD format. I normally plug the SD card into the back of the mac and import media that way, however this time the mac didnt recgonise the video files on the SD card when i browsed for them on finder. The card has been formatted on the camera.
i had to remove the files on a windows computer and use handbrake to convert them to MP4, this was strange as final cut could show the video files were there, finder and image capture couldnt.

I have now tried to import videos with my iphone and am getting similar issues, final cut wont show any video footage of new video clips:
This is the clips when imported:

The same video clip when imported into photos
This is a clip recorded on an iphone 7, i have never had such issues in the past:

11-15-2017, 10:39 AM
OK. I think these maybe two separate issues.

For the Sony import - is Image Capture able to copy the file(s) across to your Mac?

For the iPhone import - What version of Mac OS do you have? I suspect the issue here is that you're recording in HEVC (iOS 11) but the version of Mac OS you're running can't read HEVC.

Again - Can Image Capture import these files OK.
Is final cut up to date?

Farmer Pug
11-15-2017, 02:13 PM
Hi there

These are the versions of what i am running
Late 2013 Imac with OSX High Sierra 10.13.1
Iphone 7 with iOS 11.1.1
Final Cut Pro X 10.3.4
Photos 3.0

Everything is up to date, and i suspect these issues have happened since the most recent import.

Image capture nor fineder would show up the media on the sony cameras SD card, final cut would show it was there but wouldnt import it. I had to import it on a seperate windows computer, convert to MP4 and bring it back to the mac.
Trying again tonight if i plug the SD card into the back of the mac finder shows its there but will not show any raw footage files, only final cut shows that it has footage but i cant import it

The iphone ive changed the camera resolution to 1080p 60, now photos and image capture work fine, but final cut will still not show its footage. Having said that previously the iphone sat at 4K resolution when recording videos and no programs had any issues.

One other device i have tried is my Gopro hero 5 black, if i plug its SD card into the imac it works fine, footage imports into final cut without any issues.

11-16-2017, 10:37 AM
iOS 11 brought HEVC packaged video. Final Cut has yet to be updated to handle HEVC. An update is expected 'soon'. As a workaround you can change back to MP4 in Settings - Camera - Format - Most Compatible for all future recordings.
In the interim I think Handbrake can transcode from HEVC containers.

The Sony issue is an odd one. Finder should show the files on the card regardless of type. Do you know what file system the SD card has been formatted to?

01-20-2018, 02:03 PM
I've got the same problem. Videos no longer show in Photos when insert SD card into iMac. I've upgraded to Photos 3.0. When I put same SD card in my laptop which is still running Photos 2.0, the videos are there. So seems it's the Photos 3.0, perhaps only with SD used in Sony camera. Please set me know if you've got a fix as now I've got to go into finder and taxes several steps going into "Private" folder, and then finding video in AVCHD and then BDVM and finally opening it with QuickTime Player. Can only do one video at a time

Farmer Pug
01-24-2018, 08:12 PM
Still having problems with the sony camera
I have found that the files can be found by going further into the SD card and opening package contents to get MTS files.

I imported media to final cut the other day, it seemd to work fine, but the camera icon appeared beside the media and it says "This item cannot be shared while it is still referencing media on the camera"

I had perian on this computer in the past, the sony puts out video in AVCHD format although if it all worked before id expect it to work again.

An absolute headache, id consider buying a replacement camera but most are using the same format anyhow.

01-25-2018, 12:42 AM
1. Spent a lot of time online with AppleCare and best they could recommend was using iMovie to open the videos stuck on AVCHD.

2. I found it much easier to go to Finder, and open the SD card, click on "Private" and then go to the AVCHD folder, click on "Show Package Contents" which opens a BDVM folder, and then "Open with" that folder using QuickTime, and all of the videos on the SD appear on a screen. Go to File on Quicktime menu, and "Export To" and you can put the video wherever you want.

3. I don't know about your Sony camera, but when I go to look at my videos on the camera screen, I go to Menu and click "Playback", and then "Still/Movie Silect". Whenever I did that I saw there were two options for movies, AVCHD or MP4, but my movies were on the AVCHD file. I realized that's what's the problem, and went to the Instruction Manual for my camera, and found how to switch the mode for recording movies from AVCHD to MP4. I did that and now all my movies appear right away in Photos when I put my SD card into the slot on my iMac. So the way I described in 2. above is only needed to move old movies from the SD card to Photos, going forward I can import movies at the same time i'm importing photos.