View Full Version : Solved tricky problem with Soundflower not giving audio to Quicktime

03-20-2017, 10:45 AM
I am using Sierra on a Mac Pro.

I stumbled upon the following fix after many hours of trying to figure it out. I hope that it saves others the aggravation.

I wasn’t getting sound out of Soundflower to the Quicktime audio recorder (no indications on the meters) or for that matter any other sound recorder app that I had.

I tried uninstalling Soundflower, getting the latest one and reinstalling it. This was NOT the problem!!

It turns out that I had to move the Master and individual volumes in Soundflower to 0 and then back to maximum in the Midi app (Probably could have also done it in Apple Preferences for sound)!!! I did it for both the Input and the Output for Soundflower.

Note that before I reset the volume controls, they were already at maximum, so the reset apparently did something to get Soundflower back to putting out sound correctly.

I learned later by testing that it is only the Output volumn controls that need to be reset. This needs to be done (although not always per later testing) whenever you change the output device from Soundflower to something else like the internal speakers!!!

03-20-2017, 02:12 PM
Thanks for posting the solution. Seems to me that there should be an easier way than having to resort to a work around with the volume controls.

By the way, interesting note about development on their website - you might be interested in reading if you haven't already:

"Thankfully, at the end of 2015, Soundflower's original author Matt Ingalls picked up the baton. We expect he'll be providing some updates to Soundflower in the near future, via this GitHub link."