View Full Version : Sansa clipp problem

11-25-2016, 07:01 AM
I have a Sansa clipp MP3 player. It now says FAT is corrupted and to connect to my computer. I have done this and gone into Disk Utility several times and carried out various procedures that I have found on the internet. Nothing has worked yet it doesn't appear to be totally "dead". Has anyone had experience of this and knows what to do. It's been a great little MP3 player and I don't know what I've done wrong. I haven't disconnected it without properly ejecting it first so I don't know what's gone wrong. Help please!

11-25-2016, 03:40 PM
You might try reformatting it. Make sure you reformat it as FAT (MS DOS) from Disk Utility. I'm not sure what model Sansa Clipp you have, however, the ones that I have purchased here in the US are cheaply made and do not seem to last very long. Frankly, I have given up on cheap MP3 players and only purchase Apple iPods which seem to hold up better than others do.

11-26-2016, 02:12 PM
Thank you. I have already tried that but to no avail. I use my iPhone now for music on the go, but I did like my little Sansa Clipp!