View Full Version : My Connection Is Not Private?

05-17-2016, 12:19 PM
I did a google search for links for NY State to acquire a sales tax permit so basically a state government website. When clicking on the link I got this notification...

Your connection is not private

Attackers might be trying to steal your information from www.tax.ny.gov (for example, passwords, messages, or credit cards). NET::ERR_CERT_AUTHORITY_INVALID

Then a check box to "Automatically report details of possible security incidents to Google. Privacy policy"

Then a blue box that reads "BACK TO SAFTY"

Another clickable box that reads "ADVANCED" so I click this box and it reads...

This server could not prove that it is www.tax.ny.gov its security certificate is not trusted by your computer's operating system. This may be caused by a misconfiguration or an attacker intercepting your connection.

And finally a link that reads...

Proceed to www.tax.ny.gov (unsafe)

I tried the same thing today but to get sales tax rates for counties in NY and got the same notices. Seems I'm blocked from all government websites for a security failure on my part?

Anybody have a clue what's going on here or is "my" computer illiteracy at fault?


05-17-2016, 12:53 PM
Then a blue box that reads "BACK TO SAFTY"

If it really has that word misspelled, that's a hint that it might be a hijacking, and a scam.

05-17-2016, 01:02 PM
I visited the page and didn't have the same issue. You are doing this on Chrome, do you get the same error with Safari? You might want to get MalwareBytes (https://www.malwarebytes.org/antimalware/mac/) and run it to see if it finds any issues.

05-17-2016, 01:15 PM
What this means is the certificate being sent by the other server is not valid for your computer. This could be because of a legitimate issue or more likely your computer is holding an old certificate or the date and time on your computer is off or you are using Chrome.

If you are using Chrome try using Safari or another browser. Chrome has been know to have issues with being overly picky with certificates.

If that does not apply or work, try the steps below:

1 .Make sure the date and time on your computer is correct.
2. Go to Applications->Utilities-> Keychain (this holds the certificates), open "Login", search for Verisign and delete the Verisign certificates. This forces your computer to request new certificates. Verisign provides site validation.

I did not have anything pop up when I accessed the site.


05-17-2016, 02:15 PM
Saft(e)y Spelling faux pas on my part.

My Safari isn't responding, haven't used it in a dogs age since I've been using chrome for a year or so. Wasn't able to update it last attempt. Said it couldn't find the server when I asked for NY sales tax info. I'm running OX version 10.6.8.

Followed your suggestion Iclev, got as far as opening the keychain but no option to login. My antiquated machine?

05-17-2016, 02:25 PM
Tried copying and pasting the NY tax web address into Safari browser and I got... Safari Can't verify the Identity of the Website www.tax.ny.gov

05-17-2016, 02:53 PM
It appears that agency has not updated their certificate if you're getting the same response from Chrome and Safari. I had the same thing happen several months ago when accessing a Microsoft download site. They (MS) have since fixed it so their site can be accessed. If you have an iPad or iPhone, see if you can gain access to site that way. Sometimes that will work.

05-17-2016, 03:06 PM
The certificate isn't going to expire until Sep, 2016 so that isn't an issue.

05-17-2016, 03:21 PM
The certificate isn't going to expire until Sep, 2016 so that isn't an issue.

You're right. I just accessed the site using Chrome. Don't know what her problem is then unless she's using an old version of Chrome?

05-17-2016, 03:29 PM
Was actually able to access the site for application to apply for sales tax permit while on ipad but at a certain point it wouldn't go any further and I had to go to the public library to use their MS computers. Makes me wonder what people are(n't) thinking. Guess it will still be a while before the world changes and realizes they should upgrade and exclusively use Mac, a superior product.

05-17-2016, 03:59 PM
And you could be dealing with the fallout from an older version of OS X. I have no idea how to direct you from here. If I open my version of Chrome, I can go to settings-> show advanced -> HTTPS/SSL and click on the manage certificates button. That opens Keychain for me. But I am not sure if or what will work for you.


05-17-2016, 04:04 PM
Maybe something on your computer is messed up/"confused". If it's still running OS 10.6.8…it may not have gotten any "maintenance love" in a long time!;)

Things to try:

- Download the free maintenance app called Onyx (for Snow Leopard). Open Onyx…click on the "Automation" button…and let it do its thing (default settings). Then reboot the computer…and see if that helps.

- A full Safari reset.

- If neither of these help…do an IP Address lookup on your computer (do this multiple times). I've run into this in the past where (for some reason)…my computer (to the internet world)…looks like I'm in multiple locations (hundreds of miles apart). I think that some webpages are sensitive to this…and if you/your computer looks "shady"…you get blocked. The way I finally solved this problem was a complete "nuke & pave" of my computer (wipe the hard drive & fresh OS install).

Good luck,

- Nick

05-17-2016, 05:34 PM
And it is an old operating system and there are security problems with it. No security updates. And some institutions use technicians that only set up for Windows. Banks are often included in this. It took years of petitioning the Australian Tax Office to even consider setting up Mac friendly software.

Being Snow Leopard, by any chance is the encryption WEP which is considered so very easy to crack?