View Full Version : No more lasso selection in Preview ?!

12-20-2015, 01:09 AM
Hi all !

I remember I was working with lasso selection in Preview 5.0 (Snow leopard).
This fonction seems to have disappeared in Preview 8.0 (Yosemite). There's only square selection.

1- Does Preview 8.1 (El Capitan) has the lasso selection fonction ?

2- Is it possible to make Preview 5.0 work in Yosemite ?
I tried to copy Preview 5.0 in Yosemite but it doesn't launch.

Thanks a lot

12-20-2015, 01:42 AM
The lasso selection tool is still present in Preview under El Capitan. It may be a bit hidden though. here'a how to get it:
1. Open a document in Preview and see if the Markup toolbar is present. It has icons for the editing tools.
2. If it is not present Press Shift, Command, A simultaneously (this command is in the View menu).
3. The selection tool is usually on the far side of the bar and look like a rectangular selection. Click there. Lasso is one of the option.

12-20-2015, 02:04 AM
Thanks for the reply Slydude !
Unfortunately it will be hard to run El Capitan on my machine.

Does anybody knows if I could upgrade to Preview 8.1 in Yosemite ?
Or get Preview 8.1 and copy-paste in application folder...


12-20-2015, 01:55 PM
I think that tool is still available in the version of Preview that is in Yosemite. Let me double check something and I'll post back with and answer soon

12-20-2015, 01:59 PM
Does anybody knows if I could upgrade to Preview 8.1 in Yosemite ?Software included with OS X is tied to the OS version so unless Apple backports it, which isn't likely, you can't move between versions that aren't included with the OS are in a subsequent OS X update.

12-20-2015, 02:19 PM
Thanks Van. I thought of that right after I made my post.

@waarzawa I booted my MacBook Pro into Yosemite for a few minutes to check a few things. The version of Preview I have in Yosemite is 8.0 It still has the lasso tool you are talking about. Follow the directions in my post above (post 2). I have noticed that in one document I opened I couldn't select one of the selection tools. That document might be copy protected. The I try that tip on one of my own documents it works under Yosemite.

12-22-2015, 08:19 AM
Thanks all for your replies.

As you said Slydude, the lasso tool is not available for all the documents, like PDF for example. In this case rectangular selection is the only option...
I tried with few jpeg and png and it's working fine.

Problem solved, thanks again.

12-22-2015, 03:02 PM
You're welcome. Glad to help sort that out. I'm not sure what made me think to check PDFs.

There may well be other document types that Preview can open that don't show all he selection tools. I haven't for example, tried Word docs. In that case I suspect that which tools are present will depend upon what cement of the document you are in (different tools for graphics vs. text).